]> TLD Linux GIT Repositories - packages/apache.git/blobdiff - apache.spec
- patch24 probably deprecated
[packages/apache.git] / apache.spec
index 05c15cbeb900c488b4edb4c026091a66c0453d26..2b0d9168362828b832c7bdd892d5f63f7c961f20 100644 (file)
 %bcond_without ssl             # build without SSL support
 %bcond_without ldap            # build without LDAP support
 %bcond_without peruser         # peruser MPM
-%bcond_without event           # event MPM
 %bcond_with    itk             # ITK MPM
 %bcond_with    distcache       # distcache support
 %bcond_with    bucketeer       # debug one
 
 # this is internal macro, don't change to %%apache_modules_api
-%define                _apache_modules_api 20051115
+%define                _apache_modules_api 20120211
 
 %define                openssl_ver     0.9.8i
 %define                apr_ver         1:1.4.5
@@ -89,7 +88,6 @@ Patch14:      httpd-2.0.48-corelimit.patch
 Patch15:       httpd-2.0.48-debuglog.patch
 Patch18:       %{name}-v6only-ENOPROTOOPT.patch
 Patch19:       %{name}-conffile-path.patch
-Patch20:       %{name}-apxs.patch
 Patch23:       %{name}-suexec_fcgi.patch
 Patch24:       %{name}-bug-48094.patch
 # http://scripts.mit.edu/trac/browser/trunk/server/common/patches/httpd-2.2.x-mod_ssl-sessioncaching.patch?rev=1348
@@ -1774,21 +1772,22 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch12 -p1
+#%%patch12 -p1
 %patch14 -p1
 %patch15 -p1
 %patch18 -p1
 %patch19 -p1
-%patch20 -p1
 %patch23 -p1
-%patch24 -p1
-%patch25 -p1
+# breaks worker build
+#%%patch24 -p1
+# seems already applied
+#%%patch25 -p1
 %patch26 -p1
-%patch28 -p1
+%{?with_itk:%patch28 -p1}
 %patch29 -p1
 
 # using system apr, apr-util and pcre
-%{__rm} -r srclib/{apr,apr-util,pcre}
+#%%{__rm} -r srclib/{apr,apr-util,pcre}
 
 # sanity check
 MODULES_API=`awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' include/ap_mmn.h`
@@ -1819,12 +1818,10 @@ touch ssl_expr_scan.c
 cd ../..
 
 CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
-for mpm in prefork worker %{?with_event:event} %{?with_itk:itk}; do
-install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
-../%configure \
+%configure \
        --enable-layout=TLD \
        --disable-v4-mapped \
-       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" -o "${mpm}" = "itk" ] && echo "--enable-exception-hook" ) \
+       --enable-exception-hook \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1879,13 +1876,9 @@ install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
        --enable-speling \
        --enable-rewrite \
        --enable-so \
-       --with-program-name=httpd.${mpm} \
-       --with-mpm=${mpm} \
-%ifarch %{ix86}
-%ifnarch i386 i486
-       $( [ "${mpm}" = "leader" ] && echo "--enable-nonportable-atomics=yes" ) \
-%endif
-%endif
+       --with-program-name=httpd \
+       --with-mpm=prefork \
+       --enable-mpms-shared=all \
        --with-suexec-bin=%{_sbindir}/suexec \
        --with-suexec-caller=http \
        --with-suexec-docroot=%{_datadir} \
@@ -1898,18 +1891,7 @@ install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
        --with-pcre
 
 %{__make}
-./httpd.${mpm} -l | grep -v "${mpm}" > modules-inside
-cd ..
-
-done
-
-for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
-       if ! cmp -s buildmpm-prefork/modules-inside buildmpm-${mpm}/modules-inside; then
-               echo "List of compiled modules is different between prefork-MPM and ${mpm}-MPM!"
-               echo "Build failed."
-               exit 1
-       fi
-done
+./httpd -l > modules-inside
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -1920,18 +1902,13 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 # prefork is default one
-%{__make} -C buildmpm-prefork install \
+%{__make}  install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# install other mpm-s
-for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
-       install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
-done
-
-ln -s httpd.prefork $RPM_BUILD_ROOT%{_sbindir}/httpd
 ln -s %{_libexecdir} $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s %{_localstatedir}/run/httpd $RPM_BUILD_ROOT%{_sysconfdir}/run
 ln -s %{_var}/log/httpd $RPM_BUILD_ROOT%{_sysconfdir}/logs
+mv $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf.orig
 ln -s conf.d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 
 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/httpd