]> TLD Linux GIT Repositories - packages/mysql.git/blobdiff - mysql.spec
- fixed upstream
[packages/mysql.git] / mysql.spec
index 4dd93f1d35d328acfb7ac97281c5d95b66370ada..76cdfbfd9adec72b6a09a98a13e57f32ca3dbffb 100644 (file)
@@ -23,7 +23,7 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
-%define        percona_rel     31.0
+%define        percona_rel     35.1
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -34,16 +34,14 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.5.32
-Release:       3
+Version:       5.5.37
+Release:       1
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
-# Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
-# Source0:     http://vesta.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.5/%{name}-%{version}.tar.gz
-Source0:       http://www.percona.com/redir/downloads/Percona-Server-5.5/LATEST/source/Percona-Server-%{version}-rel%{percona_rel}.tar.gz
-# Source0-md5: aafbc2a94353d68b5cbfbeddb7eb2e08
-Source100:     http://www.sphinxsearch.com/files/sphinx-2.0.8-release.tar.gz
-# Source100-md5:       bcaf0af0ba403a43b9ef3af6f9599cb4
+Source0:       http://www.percona.com/redir/downloads/Percona-Server-5.5/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
+# Source0-md5: 0ef76fa2ec0559810a8a78800022f9a2
+Source100:     http://www.sphinxsearch.com/files/sphinx-2.1.8-release.tar.gz
+# Source100-md5:       ef21091bb30a82f175be5bf9142490b7
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -59,7 +57,7 @@ Source13:     %{name}-client.conf
 Source14:      my.cnf
 # from fedora
 Source15:      lib%{name}.version
-Patch0:                %{name}-link.patch
+
 Patch2:                %{name}hotcopy-5.0-5.5.patch
 Patch3:                bug-67402.patch
 # from fedora
@@ -73,16 +71,12 @@ Patch18:    %{name}-sphinx.patch
 Patch19:       %{name}-chain-certs.patch
 # from fedora
 Patch20:       %{name}-dubious-exports.patch
-Patch21:       bison3.patch
+Patch21:       bug-66589.patch
 URL:           http://www.mysql.com/products/community/
 BuildRequires: bison >= 1.875
 BuildRequires: cmake >= 2.6
 BuildRequires: groff
-%if "%{pld_release}" == "ac"
-BuildRequires: libstdc++4-devel >= 5:4.0
-%else
 BuildRequires: libstdc++-devel >= 5:4.0
-%endif
 BuildRequires: libtool
 %{?with_tcpd:BuildRequires:    libwrap-devel}
 BuildRequires: ncurses-devel >= 4.2
@@ -485,13 +479,18 @@ This package contains the standard MySQL NDB CPC Daemon.
 Ten pakiet zawiera standardowego demona MySQL NDB CPC.
 
 %prep
-%setup -q -n Percona-Server-%{version}-rel%{percona_rel} %{?with_sphinx:-a100}
+%setup -q -n percona-server-%{version}-%{percona_rel} %{?with_sphinx:-a100}
+
+# we want to use old, mysql compatible client library name
+find . -name CMakeLists.txt -exec sed -i -e 's#perconaserverclient#mysqlclient#g' "{}" ";"
+sed -i -e 's#perconaserverclient#mysqlclient#g' libmysql/libmysql.{ver.in,map} scripts/mysql_config.*
+
 %if %{with sphinx}
 # http://www.sphinxsearch.com/docs/manual-0.9.9.html#sphinxse-mysql51
 mv sphinx-*/mysqlse storage/sphinx
 %patch18 -p1
 %endif
-%patch0 -p1
+
 %patch2 -p1
 %patch3 -p1
 
@@ -516,13 +515,6 @@ cd build
 # (it defaults to first cluster but user may change it to whatever
 # cluster it wants)
 
-%if "%{pld_release}" == "ac"
-# add suffix, but allow ccache, etc in ~/.rpmmacros
-%{expand:%%define      __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
-%{expand:%%define      __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
-%{expand:%%define      __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
-%endif
-
 # upstream has fallen down badly on symbol versioning, do it ourselves
 install -d libmysql
 cp -a %{SOURCE15} libmysql/libmysql.version
@@ -531,9 +523,9 @@ cp -a %{SOURCE15} libmysql/libmysql.version
        -DCMAKE_BUILD_TYPE=%{!?debug:RelWithDebInfo}%{?debug:Debug} \
        -DCMAKE_C_FLAGS_RELEASE="%{rpmcflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
        -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
-       -DCOMPILATION_COMMENT="PLD/Linux Distribution MySQL RPM" \
+       -DCOMPILATION_COMMENT="TLD Linux MySQL RPM" \
        -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
-       %{!?with_systemtap:-DENABLE_DTRACE=OFF} \
+       %{?with_systemtap:-DENABLE_DTRACE=ON} \
        -DFEATURE_SET="community" \
        -DINSTALL_LAYOUT=RPM \
        -DINSTALL_LIBDIR=%{_lib} \
@@ -551,11 +543,7 @@ cp -a %{SOURCE15} libmysql/libmysql.version
        -DWITH_PERFSCHEMA_STORAGE_ENGINE=1 \
        -DWITH_PIC=ON \
        -DWITH_READLINE=OFF \
-%if "%{pld_release}" == "ac"
-       -DWITH_SSL=%{?with_ssl:bundled}%{!?with_ssl:no} \
-%else
        -DWITH_SSL=%{?with_ssl:system}%{!?with_ssl:no} \
-%endif
        -DWITH_UNIT_TESTS=%{?with_tests:ON}%{!?with_tests:OFF} \
        -DWITH_ZLIB=system \
        ..
@@ -766,7 +754,7 @@ for config in $(awk -F= '!/^#/ && /=/{print $1}' /etc/%{name}/clusters.conf); do
        fi
 
        if [ ! -f "$config_file" ]; then
-                       echo >&2 "Lost myself! Please report this (with above errors, if any) to http://bugs.pld-linux.org/"
+                       echo >&2 "Lost myself! Please report this (with above errors, if any) to TLD Linux mailing lists."
                        exit 1
        fi
        echo "Adding option old-passwords to config: $config_file"
@@ -805,7 +793,7 @@ for config in $(awk -F= '!/^#/ && /=/{print $1}' /etc/%{name}/clusters.conf); do
        fi
 
        if [ ! -f "$config_file" ]; then
-               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to http://bugs.pld-linux.org/"
+               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to TLD Linux mailing lists."
                continue
        fi
        configs="$configs $config_file"
@@ -844,7 +832,7 @@ for config in $(awk -F= '!/^#/ && /=/{print $1}' /etc/%{name}/clusters.conf); do
        fi
 
        if [ ! -f "$config_file" ]; then
-               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to http://bugs.pld-linux.org/"
+               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to TLD Linux mailing lists."
                continue
        fi
        configs="$configs $config_file"
@@ -889,6 +877,7 @@ done
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/plugin
 %attr(755,root,root) %{_libdir}/%{name}/plugin/adt_null.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/audit_log.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_pam.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_pam_compat.so
@@ -898,12 +887,16 @@ done
 %attr(755,root,root) %{_libdir}/%{name}/plugin/ha_archive.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/ha_blackhole.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/ha_federated.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/libfnv_udf.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/libfnv1a_udf.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/libmurmur_udf.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/mypluglib.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/qa_auth_client.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/qa_auth_interface.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/qa_auth_server.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/semisync_master.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/semisync_slave.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/scalability_metrics.so
 %if %{with sphinx}
 %attr(755,root,root) %{_libdir}/%{name}/plugin/ha_sphinx.so
 %endif