]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql.spec
- moved data clusters to /var/lib/postgresql, misc fixes
[packages/postgresql.git] / postgresql.spec
index 04366b400ff80b1c8e97e4e9e4e46a8a1ae20e72..f01307d8ece7d67d7b7c7783650a6ac6b96d32a9 100644 (file)
@@ -1,4 +1,4 @@
-#7
+#
 # Conditional build:
 %bcond_without tests                   # disable testing
 %bcond_without tcl                     # disable Tcl support
@@ -526,7 +526,6 @@ find src -name \*.l -o -name \*.y | xargs touch
        %{?with_python:--with-python} \
        %{?with_selinux:--with-selinux} \
        --with-system-tzdata=%{_datadir}/zoneinfo \
-       --without-systemd \
        %{?with_tcl:--with-tcl --with-tclconfig=%{_ulibdir}} \
        --with-uuid=e2fs
 
@@ -549,7 +548,7 @@ done
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
-       $RPM_BUILD_ROOT/var/{lib/pgsql,log,run/postgresql} \
+       $RPM_BUILD_ROOT/var/{lib/postgresql/%{pgsqlversion},log,run/postgresql} \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
        $RPM_BUILD_ROOT%{_mandir}
 
@@ -778,7 +777,6 @@ fi
 %{pgsqldatadir}/man/man1/pg_rewind.1*
 %{pgsqldatadir}/man/man1/pg_test_fsync.1*
 %{pgsqldatadir}/man/man1/pg_test_timing.1*
-%{pgsqldatadir}/man/man1/pg_test_timing.1*
 %{pgsqldatadir}/man/man1/pg_upgrade.1*
 %{pgsqldatadir}/man/man1/pg_xlogdump.1*
 %{pgsqldatadir}/man/man1/pgbench.1*
@@ -795,6 +793,7 @@ fi
 %dir %{pgsqldatadir}/man/man1
 %dir %{pgsqldatadir}/man/man3
 %dir %{pgsqldatadir}/man/man7
+%attr(700,postgres,postgres) %dir /var/lib/postgresql/%{pgsqlversion}
 
 %files doc
 %defattr(644,root,root,755)