]> TLD Linux GIT Repositories - packages/proftpd.git/blobdiff - proftpd.spec
- drop one more old configuration migration trigger
[packages/proftpd.git] / proftpd.spec
index c152d95b41dbd410ca2fb1f9348e6b2695befe33..60301d59c2da360e47644b96f3ad100f02bc6bb4 100644 (file)
@@ -23,13 +23,13 @@ Summary(pl.UTF-8):  PROfesionalny serwer FTP
 Summary(pt_BR.UTF-8):  Servidor FTP profissional, com sintaxe de configuração semelhante à do apache
 Summary(zh_CN.UTF-8):  易于管理的,安全的 FTP 服务器
 Name:          proftpd
-Version:       1.3.7c
+Version:       1.3.7f
 Release:       1
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Daemons
 Source0:       ftp://ftp.proftpd.org/distrib/source/%{name}-%{version}.tar.gz
-# Source0-md5: bee3df0bc3c945c62657410610fedeb3
+# Source0-md5: 5dab21933de54926fa0bb0a51a5a8578
 # https://github.com/jbenden/mod_clamav
 Source1:       mod_clamav-%{mod_clamav_version}.tar.xz
 # Source1-md5: 89ec19115d9ea7c7f4e0b0c4551e69bc
@@ -95,34 +95,13 @@ if [ "$1" = "0" ]; then \
        fi \
 fi
 
-%define module_triggerun \
-if [ $1 -le 1 ]; then \
-        exit 0 \
-fi \
-[ -d /etc/proftpd/conf.d ] || mkdir -p /etc/proftpd 2>/dev/null || : \
-%if "%1" == "mod_tls" \
-for f in /etc/ftpd/{conf.d/mod_tls.conf,server.crt,server.key}; do \
-       f=${f##*/} \
-       [ -f "/etc/ftpd/$f" ] && mv "/etc/ftpd/$f" /etc/proftpd 2>/dev/null || : \
-       [ -f "/etc/ftpd/conf.d/$f" ] && mv "/etc/ftpd/conf.d/$f" /etc/proftpd/conf.d 2>/dev/null || : \
-done \
-%else \
-[ -f /etc/ftpd/conf.d/%1.conf ] && mv /etc/ftpd/conf.d/%1.conf /etc/proftpd/conf.d 2>/dev/null || : \
-%endif \
-sed -i -e 's|/etc/ftpd|/etc/proftpd|g' /etc/ftpd/conf.d/%1.conf 2>/dev/null \
-[ -n "$(find /etc/ftpd/conf.d -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd/conf.d 2>/dev/null || : \
-[ -n "$(find /etc/ftpd -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd 2>/dev/null || :
-
 # it's sooo annoying to write them
 %define        module_scripts() \
 %post %1 \
 %module_post \
 \
 %postun %1 \
-%module_postun \
-\
-%triggerun %1 -- proftpd-%1 \
-%module_triggerun
+%module_postun
 
 %description
 ProFTPD is a highly configurable FTP daemon for Unix and Unix-like
@@ -655,35 +634,6 @@ if [ "$2" != 1 ]; then
        %service -q proftpd restart
 fi
 
-%triggerun common -- proftpd-common < 2:1.3.6-5
-if [ $1 -le 1 ]; then
-       exit 0
-fi
-[ -d /etc/proftpd/conf.d ] || mkdir -p /etc/proftpd/conf.d 2>/dev/null || :
-for f in /etc/ftpd/{conf.d/mod_{auth_file,clamav,ident}.conf,ftpusers,ftpusers.default,proftpd.conf}; do
-       f=${f##*/}
-       [ -f "/etc/ftpd/$f" ] && mv "/etc/ftpd/$f" /etc/proftpd 2>/dev/null || :
-       [ -f "/etc/ftpd/conf.d/$f" ] && mv "/etc/ftpd/conf.d/$f" /etc/proftpd/conf.d 2>/dev/null || :
-done
-find /etc/proftpd -type f 2>/dev/null | xargs sed -i -e 's|/etc/ftpd|/etc/proftpd|g' 2>/dev/null
-[ -n "$(find /etc/ftpd/conf.d -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd 2>/dev/null || :
-[ -n "$(find /etc/ftpd -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd 2>/dev/null || :
-
-%triggerpostun common -- proftpd-common < 2:1.3.6-5
-echo
-echo "Warning! Configuration has been migrated to /etc/proftpd."
-echo
-
-%triggerun anonftp -- proftpd-anonftp < 2:1.3.6-5
-if [ $1 -le 1 ]; then
-        exit 0
-fi
-[ -d /etc/proftpd/conf.d ] || mkdir -p /etc/proftpd 2>/dev/null || :
-[ -f /etc/ftpd/conf.d/anonftp.conf ] && mv /etc/ftpd/conf.d/anonftp.conf /etc/proftpd/conf.d 2>/dev/null || :
-sed -i -e 's|/etc/ftpd|/etc/proftpd|g' /etc/ftpd/conf.d/anonftp.conf 2>/dev/null
-[ -n "$(find /etc/ftpd/conf.d -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd 2>/dev/null || :
-[ -n "$(find /etc/ftpd -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd 2>/dev/null || :
-
 %module_scripts mod_auth_pam
 %module_scripts mod_ldap
 %module_scripts mod_quotatab