]> TLD Linux GIT Repositories - packages/proftpd.git/blobdiff - proftpd.spec
- drop one more old configuration migration trigger
[packages/proftpd.git] / proftpd.spec
index fcd03cacffcf2fdb8f1f6611c061c5e48ac0aa58..60301d59c2da360e47644b96f3ad100f02bc6bb4 100644 (file)
@@ -23,13 +23,13 @@ Summary(pl.UTF-8):  PROfesionalny serwer FTP
 Summary(pt_BR.UTF-8):  Servidor FTP profissional, com sintaxe de configuração semelhante à do apache
 Summary(zh_CN.UTF-8):  易于管理的,安全的 FTP 服务器
 Name:          proftpd
-Version:       1.3.6
-Release:       4
+Version:       1.3.7f
+Release:       1
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Daemons
 Source0:       ftp://ftp.proftpd.org/distrib/source/%{name}-%{version}.tar.gz
-# Source0-md5: 13270911c42aac842435f18205546a1b
+# Source0-md5: 5dab21933de54926fa0bb0a51a5a8578
 # https://github.com/jbenden/mod_clamav
 Source1:       mod_clamav-%{mod_clamav_version}.tar.xz
 # Source1-md5: 89ec19115d9ea7c7f4e0b0c4551e69bc
@@ -71,10 +71,38 @@ BuildRequires:      postgresql-devel
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir             /etc/ftpd
+%define                _sysconfdir             /etc/proftpd
 %define                _localstatedir          /var/run
 %define                _libexecdir             %{_prefix}/%{_lib}/%{name}
 
+# macro called at module post scriptlet
+%define        module_post \
+if [ "$1" = "1" ]; then \
+       if grep -iEqs "^ServerType[[:space:]]+inetd" %{_sysconfdir}/proftpd.conf; then \
+               %service -q rc-inetd reload \
+       elif grep -iEqs "^ServerType[[:space:]]+standalone" %{_sysconfdir}/proftpd.conf; then \
+               %service -q proftpd restart \
+       fi \
+fi
+
+# macro called at module postun scriptlet
+%define        module_postun \
+if [ "$1" = "0" ]; then \
+       if grep -iEqs "^ServerType[[:space:]]+inetd" %{_sysconfdir}/proftpd.conf; then \
+               %service -q rc-inetd reload \
+       elif grep -iEqs "^ServerType[[:space:]]+standalone" %{_sysconfdir}/proftpd.conf; then \
+               %service -q proftpd restart \
+       fi \
+fi
+
+# it's sooo annoying to write them
+%define        module_scripts() \
+%post %1 \
+%module_post \
+\
+%postun %1 \
+%module_postun
+
 %description
 ProFTPD is a highly configurable FTP daemon for Unix and Unix-like
 operating systems. ProFTPD is designed to be somewhat of a "drop-in"
@@ -606,34 +634,6 @@ if [ "$2" != 1 ]; then
        %service -q proftpd restart
 fi
 
-# macro called at module post scriptlet
-%define        module_post \
-if [ "$1" = "1" ]; then \
-       if grep -iEqs "^ServerType[[:space:]]+inetd" %{_sysconfdir}/proftpd.conf; then \
-               %service -q rc-inetd reload \
-       elif grep -iEqs "^ServerType[[:space:]]+standalone" %{_sysconfdir}/proftpd.conf; then \
-               %service -q proftpd restart \
-       fi \
-fi
-
-# macro called at module postun scriptlet
-%define        module_postun \
-if [ "$1" = "0" ]; then \
-       if grep -iEqs "^ServerType[[:space:]]+inetd" %{_sysconfdir}/proftpd.conf; then \
-               %service -q rc-inetd reload \
-       elif grep -iEqs "^ServerType[[:space:]]+standalone" %{_sysconfdir}/proftpd.conf; then \
-               %service -q proftpd restart \
-       fi \
-fi
-
-# it's sooo annoying to write them
-%define        module_scripts() \
-%post %1 \
-%module_post \
-\
-%postun %1 \
-%module_postun
-
 %module_scripts mod_auth_pam
 %module_scripts mod_ldap
 %module_scripts mod_quotatab
@@ -652,8 +652,7 @@ fi
 %files common
 %defattr(644,root,root,755)
 %doc sample-configurations/*.conf CREDITS ChangeLog NEWS RELEASE_NOTES
-%doc README.md README.capabilities README.classes README.controls README.IPv6
-%doc README.modules
+%doc README.md README.modules
 %doc doc/*.html doc/contrib doc/howto doc/modules
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/proftpd
 %dir %attr(750,root,ftp) %dir %{_sysconfdir}
@@ -706,7 +705,6 @@ fi
 %if %{with pam}
 %files mod_auth_pam
 %defattr(644,root,root,755)
-%doc README.PAM
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.ftp
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/mod_auth_pam.conf