]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu.spec
- partial PLD merge
[packages/qemu.git] / qemu.spec
index 6302a68095edf7dc5beb220b747243cf95940bab..93ce3a9b13244b9c740c1d7a56f2485db100b924 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -25,6 +25,8 @@
 %bcond_without user_static     # build linux-user static packages
 %bcond_with    lttng           # lttng-ust trace backend support
 %bcond_with    systemtap       # SystemTap/dtrace trace backend support
+%bcond_with    virgl           # build virgl support
+%bcond_without xkbcommon       # xkbcommon support
 
 %if %{with gtk2}
 %undefine with_gtk3
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.12.1
+Version:       3.0.0
 Release:       1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.xz
-# Source0-md5: 6e830a88e36908d9563ed01131ce72ec
+# Source0-md5: 6a5c8df583406ea24ef25b239c3243e0
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -54,12 +56,11 @@ Source9:    ksmtuned
 Source10:      ksmtuned.conf
 Source12:      99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
-Patch1:                vgabios-widescreens.patch
-Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-user-execve.patch
-Patch4:                %{name}-xattr.patch
-Patch5:                libjpeg-boolean.patch
-Patch6:                x32.patch
+Patch1:                %{name}-whitelist.patch
+Patch2:                %{name}-user-execve.patch
+Patch3:                %{name}-xattr.patch
+Patch4:                libjpeg-boolean.patch
+Patch5:                x32.patch
 URL:           http://www.qemu-project.org/
 %{?with_gl:BuildRequires:      OpenGL-GLX-devel}
 %{?with_gl:BuildRequires:      OpenGL-devel}
@@ -118,8 +119,10 @@ BuildRequires:     texinfo
 %{?with_lttng:BuildRequires:   userspace-rcu-devel}
 BuildRequires: vde2-devel
 BuildRequires: which
+%{?with_virgl:BuildRequires:   virglrenderer-devel}
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
 BuildRequires: xfsprogs-devel
+%{?with_xkbcommon:BuildRequires:       xorg-lib-libxkbcommon-devel}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: zlib-devel
 %if %{with gtk2}
@@ -839,7 +842,6 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
@@ -902,6 +904,7 @@ build dynamic \
        --enable-vnc-png \
        --enable-vnc-sasl \
        %{!?with_vte:--disable-vte} \
+       %{__enable_disable virgl virglrenderer} \
        %{__enable_disable xen} \
        --enable-modules \
        --disable-netmap \
@@ -939,9 +942,6 @@ build static \
 
 %endif
 
-# rebuild patched vesa tables with additional widescreen modes.
-%{__make} -C roms/vgabios stdvga-bios
-
 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
 
 %install
@@ -993,9 +993,6 @@ install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-doc.html
 
-# install patched vesa tables with additional widescreen modes.
-cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
-
 %if %{with system_seabios}
 ln -sf /usr/share/seabios/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios-256k.bin
 # bios.bin provided by qemu is stripped to 128k, with no Xen support, keep it
@@ -1044,7 +1041,7 @@ fi
 %dir /etc/qemu
 %attr(640,root,qemu) %config(noreplace) %verify(not md5 mtime size) /etc/qemu/bridge.conf
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
-%attr(755,root,root) %{_bindir}/qemu-keymap
+%{?with_xkbcommon:%attr(755,root,root) %{_bindir}/qemu-keymap}
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_bindir}/qemu-pr-helper
 %attr(755,root,root) %{_bindir}/qemu-tilegx
@@ -1107,14 +1104,16 @@ fi
 
 # modules without too many external dependencies
 %attr(755,root,root) %{_libdir}/%{name}/block-dmg-bz2.so
-%attr(755,root,root) %{_libdir}/%{name}/block-nfs.so
+%{?with_libnfs:%attr(755,root,root) %{_libdir}/%{name}/block-nfs.so}
 
 %attr(755,root,root) %{_libdir}/%{name}/audio-alsa.so
-%attr(755,root,root) %{_libdir}/%{name}/audio-pa.so
-%attr(755,root,root) %{_libdir}/%{name}/audio-sdl.so
+%{?with_pulseaudio:%attr(755,root,root) %{_libdir}/%{name}/audio-pa.so}
+%{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/audio-sdl.so}
 %attr(755,root,root) %{_libdir}/%{name}/ui-curses.so
+%if %{with gtk2} || %{with gtk3}
 %attr(755,root,root) %{_libdir}/%{name}/ui-gtk.so
-%attr(755,root,root) %{_libdir}/%{name}/ui-sdl.so
+%endif
+%{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/ui-sdl.so}
 
 %files img
 %defattr(644,root,root,755)