]> TLD Linux GIT Repositories - packages/rpm.git/blobdiff - rpm.spec
- enable python3
[packages/rpm.git] / rpm.spec
index b38ec09f373385832aeb7f89891a6c768e7c70d4..cbb164815119f806a0c0de62fc226cbfc7e5e446 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -4,7 +4,7 @@
 #
 # Conditional build:
 %bcond_with    apidocs         # Doxygen based API documentation
-%bcond_with    python3         # Python (3) bindings
+%bcond_without python3         # Python (3) bindings
 %bcond_with    plugins         # plugins (all, including: audit, imaevm, selinux, systemd)
 %bcond_with    recommends_tags # use of Recommends tag (disable for bootstrapping)
 %bcond_with    imaevm          # IMA/EVM signing support (requires libimaevm from ima-evm-utils)
@@ -834,7 +834,9 @@ cd python
 cd ..
 %endif
 
+%if %{with plugins}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
+%endif
 
 # wrong location, not used anyway
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}