]> TLD Linux GIT Repositories - packages/rpm.git/blobdiff - rpm.spec
- enable python3
[packages/rpm.git] / rpm.spec
index f1c4b4adaf2ef196b4aafe9c96bdfc113f98d0ca..cbb164815119f806a0c0de62fc226cbfc7e5e446 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,15 +3,15 @@
 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
 #
 # Conditional build:
-%bcond_without apidocs         # Doxygen based API documentation
+%bcond_with    apidocs         # Doxygen based API documentation
 %bcond_without python3         # Python (3) bindings
-%bcond_without plugins         # plugins (all, including: audit, imaevm, selinux, systemd)
-%bcond_without recommends_tags # use of Recommends tag (disable for bootstrapping)
+%bcond_with    plugins         # plugins (all, including: audit, imaevm, selinux, systemd)
+%bcond_with    recommends_tags # use of Recommends tag (disable for bootstrapping)
 %bcond_with    imaevm          # IMA/EVM signing support (requires libimaevm from ima-evm-utils)
-%bcond_without audit           # audit plugin
-%bcond_without selinux         # SELinux plugin
+%bcond_with    audit           # audit plugin
+%bcond_with    selinux         # SELinux plugin
 %bcond_with    systemd         # systemd inhibit plugin
-%bcond_without fsverity        # fsverity plugin
+%bcond_with    fsverity        # fsverity plugin
 
 %define                popt_ver        1.15
 %define                sover           9.3.0
@@ -34,14 +34,14 @@ Summary(ru.UTF-8):  Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.17.1.1
-Release:       5
+Release:       1
 Epoch:         1
 License:       GPL v2 / LGPL v2.1
 Group:         Base
 Source0:       http://ftp.rpm.org/releases/rpm-4.17.x/%{name}-%{version}.tar.bz2
 # Source0-md5: 30e5806bdcb06a17cabf23d8f07b6b0f
 Source1:       https://ftp.tld-linux.org/TLD/TLD-Linux.asc
-# Source1-md5: 23914bb49fafe7153cee87126d966461
+# Source1-md5: 5b5caff8c570489ad5bf950734546c24
 Source2:       macros.local
 Source3:       macros.lang
 Source4:       %{name}.sysconfig
@@ -124,7 +124,7 @@ BuildRequires:      python3-devel >= 1:3.2
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.750
 %endif
-BuildRequires: rpm-build >= 4.6
+BuildRequires: rpm-build
 BuildRequires: sqlite3-devel >= 3.22.0
 BuildRequires: tcl
 BuildRequires: xz-devel
@@ -143,12 +143,6 @@ Requires:  FHS >= 3.0-2
 Requires:      libgcrypt
 Requires:      popt >= %{popt_ver}
 Requires:      rpm-tld-macros >= 2.002
-%if %{with recommends_tags}
-Recommends:    rpm-plugin-audit
-Recommends:    rpm-plugin-prioreset
-Recommends:    rpm-plugin-syslog
-Recommends:    rpm-plugin-systemd-inhibit
-%endif
 Obsoletes:     rpm-utils-perl < 1:4.15
 Obsoletes:     rpm-utils-static < 1:4.15
 Conflicts:     glibc < 2.2.92
@@ -343,10 +337,6 @@ Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
 Group:         Applications/File
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      popt >= %{popt_ver}
-%if %{with recommends_tags}
-Recommends:    bzip2
-Recommends:    gzip
-%endif
 Conflicts:     filesystem-debuginfo < 3.0-16
 
 %description utils
@@ -844,7 +834,9 @@ cd python
 cd ..
 %endif
 
+%if %{with plugins}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
+%endif
 
 # wrong location, not used anyway
 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}