]> TLD Linux GIT Repositories - packages/FHS.git/commitdiff
- PLD merge
authorMarcin Krol <hawk@tld-linux.org>
Wed, 18 Oct 2017 22:53:52 +0000 (22:53 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 18 Oct 2017 22:53:52 +0000 (22:53 +0000)
FHS.spec

index 46d60296635bef4325694ba15200713bb351f525..2feaa8b21f70138bf065afb9676856719069857e 100644 (file)
--- a/FHS.spec
+++ b/FHS.spec
@@ -2,17 +2,21 @@
 # - don't use %{_*dir} macros for paths defined by FHS
 # - do not add any dependencies to this pkg, FHS should be the first package being installed
 # - do not use any other user/group than "root", as then we have to depend on "setup" package.
-Summary:       Basic FHS 2.3 filesystem layout
+#   But: root %attr+chown in %post means integrity verification (rpm -V) error.
+#   Maybe use non-root %attr+numeric chown in %post (without setup dependency)? The only disadvantage
+#   seems to be a warning message on install.
+Summary:       Basic FHS 3.0 filesystem layout
 Summary(de.UTF-8):     Grundlegende Dateisystemstruktur
 Summary(fr.UTF-8):     Arborescence de base du système de fichiers
-Summary(pl.UTF-8):     Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
+Summary(pl.UTF-8):     Podstawowy układ katalogów systemu Linux zgodny z FHS 3.0
 Summary(tr.UTF-8):     Temel dosya sistemi yapısı
 Name:          FHS
-Version:       2.3
-Release:       38
+Version:       3.0
+Release:       2
 License:       GPL
 Group:         Base
-URL:           http://www.pathname.com/fhs/
+URL:           http://refspecs.linuxfoundation.org/fhs.shtml
+# list of languages for localized man pages directories
 Source0:       locale-dirs
 BuildRequires: mktemp
 BuildRequires: rpmbuild(macros) >= 1.213
@@ -29,69 +33,59 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
 %define                __spec_clean_body       %{nil}
 
-%define                _locmandir      /usr/local/man
-
 # doesn't contain any files, but we're not noarch package
 %define        no_install_post_strip   1
 %define        no_install_post_chrpath 1
 %define        no_install_post_compress_modules        1
 
 # we have to use numeric uids/groups. see comment above
-
 %define                gid_uucp        14
 %define                gid_mail        12
 
 %description
 This package contains the basic directory layout for a Linux system,
 including the proper permissions for the directories. This layout
-conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
+conforms to the Filesystem Hierarchy Standard (FHS) %{version}.
 
 %description -l de.UTF-8
 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
-Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
+Struktur entspricht dem Filesystem Hierarchy Standard (FHS) %{version}.
 
 %description -l fr.UTF-8
 Ce package contient l'arborescence type pour système Linux y compris
 les permissions adéquates pour les répertoires. Cette arborescence est
-conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
+conforme au standard "Filesystem Hierarchy Standard" (FHS) %{version}.
 
 %description -l pl.UTF-8
 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
 systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
-2.3.
-
-%description -l tr.UTF-8
-Bu paket GNU makro işleme dilini içerir. Mantıksal olarak
-ayrıştırılabilen metin dosyaları yazımı için yararlıdır.
+%{version}.
 
 %prep
 %setup -qcT
-cp -a %{SOURCE0} .
+cp -p %{SOURCE0} .
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 install -d \
-       $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
+       $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,run,srv,sys} \
        $RPM_BUILD_ROOT/etc/{X11,opt} \
        $RPM_BUILD_ROOT/lib/modules \
        $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
-       $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
-       $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
+       $RPM_BUILD_ROOT/usr/{bin,games,include,lib{,exec},sbin,share,src} \
+       $RPM_BUILD_ROOT/usr/share/{color/icc,dict,doc,games,info,misc,ppd,tmac,xml} \
        $RPM_BUILD_ROOT/usr/lib/games \
-       $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
-       $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp,yp}
+       $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib{,exec},sbin,share/{color/icc,doc,info,man},src} \
+       $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/{color/icc,misc},local,lock,log,mail,opt,run,spool,tmp,yp}
 
 %if %{with lib64}
 install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
 %endif
 
 install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
-install -d $RPM_BUILD_ROOT%{_locmandir}/man{1,2,3,4,5,6,7,8}
-
-# "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
-ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
+install -d $RPM_BUILD_ROOT/usr/local/share/man/man{1,2,3,4,5,6,7,8}
 
 > %{name}.lang
 for mloc in $(cat locale-dirs); do
@@ -108,10 +102,9 @@ cd $RPM_BUILD_ROOT
 check_filesystem_dirs() {
        RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
        TMPFILE=$(mktemp)
-       find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
+       find | sed -e 's|^\.||g' -e '/^$/d' | LC_ALL=C sort > $TMPFILE
 
-       # find finds also '.', so use option -B for diff
-       if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
+       if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -u $TMPFILE - ; then
                rm -rf $RPM_BUILD_ROOT
        else
                echo -e "\nNot so good, some directories are not included in package\n"
@@ -121,8 +114,14 @@ check_filesystem_dirs() {
 }
 check_filesystem_dirs
 
-# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
+%pretrans -p <lua>
+st = posix.stat("/usr/local/share/man")
+if st and st.type == "link" then
+    os.remove("/usr/local/share/man")
+end
+
 %post -p <lua>
+--# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
 posix.chown("/var/mail", 0, %{gid_mail})
 posix.chown("/var/lock", 0, %{gid_uucp})
 
@@ -144,17 +143,22 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir %attr(555,root,root) %verify(not group) /proc
 %dir %attr(700,root,root) /root
 %dir %attr(700,root,root) /root/tmp
+%dir /run
 %dir /sbin
 %dir %attr(755,root,root) /srv
+%dir /sys
 %dir %attr(1777,root,root) /tmp
 %dir /usr
 %dir /usr/bin
 %dir /usr/games
 %dir /usr/include
 %dir /usr/lib
+%dir /usr/libexec
 %dir /usr/lib/games
 %dir /usr/sbin
 %dir /usr/share
+%dir /usr/share/color
+%dir /usr/share/color/icc
 %dir /usr/share/dict
 %dir /usr/share/doc
 %dir /usr/share/games
@@ -162,6 +166,7 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /usr/share/man
 %dir /usr/share/man/man[1-8]
 %dir /usr/share/misc
+%dir /usr/share/ppd
 %dir /usr/share/tmac
 %dir /usr/share/xml
 %dir /usr/src
@@ -171,12 +176,15 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /usr/local/games
 %dir /usr/local/include
 %dir /usr/local/lib
+%dir /usr/local/libexec
 %dir /usr/local/sbin
 %dir /usr/local/share
+%dir /usr/local/share/color
+%dir /usr/local/share/color/icc
 %dir /usr/local/share/doc
 %dir /usr/local/share/info
-/usr/local/share/man
-%{_locmandir}
+%dir /usr/local/share/man
+%dir /usr/local/share/man/man[1-8]
 %dir /usr/local/src
 %dir /var
 %dir /var/cache
@@ -184,6 +192,8 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /var/db
 %dir /var/games
 %dir /var/lib
+%dir /var/lib/color
+%dir /var/lib/color/icc
 %dir /var/lib/misc
 %dir /var/local
 %dir %attr(1771,root,root) /var/lock