]> TLD Linux GIT Repositories - packages/ansible.git/blobdiff - ansible.spec
- updated to 2.8.1
[packages/ansible.git] / ansible.spec
index ce41f92c1d4135f6ffdd3f534b777353234f283e..f74775eb27fe3d42cb947b52a587696d278d50eb 100644 (file)
@@ -1,13 +1,15 @@
 Summary:       SSH-based configuration management, deployment, and task execution system
 Name:          ansible
-Version:       2.8.0
+Version:       2.8.1
 Release:       1
 License:       GPL v3+
 Group:         Development/Libraries
 Source0:       https://releases.ansible.com/ansible/%{name}-%{version}.tar.gz
-# Source0-md5: 9320cd9e26f929568038db49781df245
+# Source0-md5: f288271db1129672a2443478053bec87
+Source1:       poldek.py
+Patch0:                poldek.patch
 URL:           http://ansible.github.com/
-BuildRequires: python-modules >= 1:2.6
+BuildRequires: python3-modules
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.710
 Requires:      python3-PyYAML
@@ -29,6 +31,7 @@ are transferred to managed machines automatically.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %py3_build
@@ -38,6 +41,8 @@ are transferred to managed machines automatically.
 rm -rf $RPM_BUILD_ROOT
 %py3_install
 
+install -p %{SOURCE1} $RPM_BUILD_ROOT%{py3_sitescriptdir}/ansible/modules/packaging/os
+
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_mandir}}
 sed -re '/^#/ !s,[^#]+$,#&,' examples/hosts > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/hosts
 cp -p examples/ansible.cfg $RPM_BUILD_ROOT%{_sysconfdir}/%{name}