]> TLD Linux GIT Repositories - packages/apache.git/blobdiff - apache.spec
- move this into main pretrans
[packages/apache.git] / apache.spec
index 23e530bf2fe22128cf34e1a8d5dd23b522fa0278..04eb43f98a22a133804d3e9fb912df9b73c5b7e5 100644 (file)
@@ -193,6 +193,7 @@ Requires:   /sbin/chkconfig
 Requires:      apr >= %{apr_ver}
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.1.23
+Requires:      %{name}-mod_unixd = %{version}-%{release}
 Provides:      apache(modules-api) = %{_apache_modules_api}
 Provides:      group(http)
 Provides:      user(http)
@@ -2376,6 +2377,15 @@ if [ ! -L /etc/httpd/httpd.conf ]; then
        install -d /etc/httpd
        ln -s conf.d /etc/httpd/httpd.conf
 fi
+if [ -f /etc/sysconfig/httpd ]; then
+       MPM=$(grep HTTPD_MPM /etc/sysconfig/httpd |sed 's,HTTPD_MPM=,,;s,",,g')
+       if [ -n $MPM ]; then
+               echo "LoadModule mpm_${MPM}_module                modules/mod_mpm_${MPM}.so" > /etc/httpd/conf.d/10_mpm.conf.rpmnew
+               cat /etc/httpd/conf.d/10_mpm.conf >> /etc/httpd/conf.d/10_mpm.conf.rpmnew
+               mv /etc/httpd/conf.d/10_mpm.conf.rpmnew /etc/httpd/conf.d/10_mpm.conf
+       fi
+fi
+
 exit 0
 
 %post base
@@ -2482,21 +2492,12 @@ Please report bugs to <http://bugs.pld-linux.org/>.
 EOF
 
 %triggerpostun base -- %{name} < 2.4.0
-if [ -f /etc/sysconfig/httpd ]; then
-       MPM=$(grep HTTPD_MPM /etc/sysconfig/httpd |sed 's,HTTPD_MPM=,,;s,",,g')
-       echo "LoadModule mpm_${MPM}_module                modules/mod_mpm_${MPM}.so" > /etc/httpd/conf.d/10_mpm.conf.rpmnew
-       cat /etc/httpd/conf.d/10_mpm.conf >> /etc/httpd/conf.d/10_mpm.conf.rpmnew
-       mv /etc/httpd/conf.d/10_mpm.conf.rpmnew /etc/httpd/conf.d/10_mpm.conf
-fi
-%banner -e %{name} << EOF
+%banner %{name}-2.4.1 << EOF
 WARNING!!!
 Since apache-2.4 mod_authn_alias has been obsoleted.
 If you use access control (Deny,Allow) install mod_access_compat by doing:
 poldek -ivh %{name}-mod_access_compat
 
-If you use "User" statement install mod_unixd by doing:
-poldek -ivh %{name}-mod_unixd
-
 In apache-2.4 mod_authn_default and mod_authz_default have been obsoleted by
 mod_authn_core and authz_core. If you used these modules install the new ones by invoking:
 poldek -ivh %{name}-mod_authn_core