]> TLD Linux GIT Repositories - packages/apache.git/blobdiff - apache.spec
- updated to 2.4.23
[packages/apache.git] / apache.spec
index 3f9f47b12497cd3d199630e7684b756ef925e03b..628bd57d519c93cae43ef067302b620031bab200 100644 (file)
@@ -1,4 +1,4 @@
-# # TODO:
+# # TODO: 
 # - config examples for mod_*
 # - --with-suexec-uidmin=500 or =1000 ?
 # - check those autn modules inner deps
@@ -21,7 +21,7 @@
 # this is internal macro, don't change to %%apache_modules_api
 %define                _apache_modules_api 20120211
 
-%define                openssl_ver     1.0.1e
+%define                openssl_ver     1.0.1f
 %define                apr_ver         1:1.5.0
 
 %include       /usr/lib/rpm/macros.perl
@@ -34,12 +34,12 @@ Summary(pt_BR.UTF-8):       Servidor HTTPD para prover serviços WWW
 Summary(ru.UTF-8):     Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
-Version:       2.4.7
+Version:       2.4.23
 Release:       1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
-# Source0-md5: 9272aadaa2d702f6ae5758641d830d7f
+# Source0-md5: b711ea7d8b75dc8bfdf5a5d7e5253088
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
@@ -69,8 +69,6 @@ Source26:     %{name}-mod_log_config.conf
 Source27:      %{name}-mod_mime_magic.conf
 Source28:      %{name}-mod_cache.conf
 Source29:      %{name}-example.net.conf
-Source30:      %{name}.tmpfiles
-Source31:      %{name}.service
 Patch0:                %{name}-configdir_skip_backups.patch
 Patch1:                %{name}-layout.patch
 Patch2:                %{name}-suexec.patch
@@ -187,13 +185,11 @@ Requires(pre):    /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires(post,preun,postun):   systemd-units >= 38
 Requires:      /sbin/chkconfig
 Requires:      apr >= %{apr_ver}
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.1.23
 Requires:      sed >= 4.0
-Requires:      systemd-units >= 38
 Provides:      apache(modules-api) = %{_apache_modules_api}
 Provides:      group(http)
 Provides:      user(http)
@@ -2629,6 +2625,7 @@ install -d build; cd build
        --enable-unique-id \
        --enable-proxy \
        --enable-proxy-connect \
+       --enable-proxy-fdpass \
        --enable-proxy-ftp \
        --enable-proxy-http \
        --enable-proxy-ajp \
@@ -2669,12 +2666,10 @@ install -d build; cd build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,systemd/system} \
+install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT%{_var}/{log/{httpd,archive/httpd},{run,cache}/httpd,lock/mod_dav} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{webapps.d,conf.d,vhosts.d} \
-       $RPM_BUILD_ROOT%{_datadir}/{cgi-bin,vhosts} \
-       $RPM_BUILD_ROOT%{systemdtmpfilesdir} \
-       $RPM_BUILD_ROOT%{systemdunitdir}
+       $RPM_BUILD_ROOT%{_datadir}/{cgi-bin,vhosts}
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -2682,8 +2677,6 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,systemd/system
 # clean "ccache" prefix. confuses other build systems (like php)
 %{__sed} -i -re '/^(CC|CPP|CXX)/ s/ccache //' $RPM_BUILD_ROOT%{_libdir}/%{name}/build/config_vars.mk
 
-install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/httpd.service
-ln -s %{systemdunitdir}/httpd.service $RPM_BUILD_ROOT/etc/systemd/system/httpd.service
 ln -s %{_libexecdir} $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s %{_localstatedir}/run/httpd $RPM_BUILD_ROOT%{_sysconfdir}/run
 ln -s %{_var}/log/httpd $RPM_BUILD_ROOT%{_sysconfdir}/logs
@@ -2731,8 +2724,6 @@ cp -a %{SOURCE21} $CFG/10_mpm.conf
 cp -a %{SOURCE22} $CFG/20_languages.conf
 cp -a %{SOURCE29} $RPM_BUILD_ROOT%{_sysconfdir}/vhosts.d/example.net.conf
 
-install %{SOURCE30} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
-
 echo "LoadModule access_compat_module   modules/mod_access_compat.so" > $CFG/00_mod_access_compat.conf
 echo "LoadModule actions_module        modules/mod_actions.so" > $CFG/00_mod_actions.conf
 echo "LoadModule alias_module modules/mod_alias.so" > $CFG/00_mod_alias.conf
@@ -2894,21 +2885,18 @@ exit 0
 /sbin/chkconfig --add httpd
 umask 137
 touch /var/log/httpd/{access,error,agent,referer}_log
-%systemd_post httpd.service
 
 %preun base
 if [ "$1" = "0" ]; then
        %service httpd stop
        /sbin/chkconfig --del httpd
 fi
-%systemd_preun httpd.service
 
 %postun base
 if [ "$1" = "0" ]; then
        %userremove http
        %groupremove http
 fi
-%systemd_reload
 
 %triggerpostun base -- %{name} < 2.0.50-6.9
 %banner %{name}-2.0.50-6 << EOF
@@ -3013,7 +3001,6 @@ EOF
 if [ -z "$HTTPD_CONF" ]; then
        echo 'HTTPD_CONF="/etc/httpd/apache.conf"' >> /etc/sysconfig/httpd
 fi
-%systemd_trigger httpd.service
 
 %triggerpostun base -- %{name} < 2.4.0
 cp -f /etc/httpd/apache.conf{,.rpmsave}
@@ -3056,20 +3043,17 @@ mv -f /var/lock/subsys/httpd{.disabled,} 2>/dev/null
 
 # restart webserver at the end of transaction
 %service httpd restart
-%systemd_service_restart httpd.service
 
 # macro called at module post scriptlet
 %define        module_post \
 if [ "$1" = "1" ]; then \
        %service -q httpd restart \
-       %systemd_service_restart httpd.service \
 fi
 
 # macro called at module postun scriptlet
 %define        module_postun \
 if [ "$1" = "0" ]; then \
        %service -q httpd restart \
-       %systemd_service_restart httpd.service \
 fi
 
 # it's sooo annoying to write them
@@ -3178,25 +3162,21 @@ fi
 %post cgi_test
 if [ "$1" = "1" ]; then
        %service -q httpd reload
-       %systemd_service_reload httpd.service
 fi
 
 %postun cgi_test
 if [ "$1" = "0" ]; then
        %service -q httpd reload
-       %systemd_service_reload httpd.service
 fi
 
 %post errordocs
 if [ "$1" = "1" ]; then
        %service -q httpd reload
-       %systemd_service_reload httpd.service
 fi
 
 %postun errordocs
 if [ "$1" = "0" ]; then
        %service -q httpd reload
-       %systemd_service_reload httpd.service
 fi
 
 %files
@@ -3231,10 +3211,6 @@ fi
 %dir %attr(770,root,http) /var/run/httpd
 %dir %attr(770,root,http) /var/cache/httpd
 
-%{systemdtmpfilesdir}/%{name}.conf
-%{systemdunitdir}/httpd.service
-%config(noreplace) %verify(not md5 mtime size) /etc/systemd/system/httpd.service
-
 %{_mandir}/man8/httpd.8*
 
 %attr(2751,root,logs) %dir /var/log/httpd