]> TLD Linux GIT Repositories - packages/apache.git/blobdiff - apache.spec
- updated to 2.4.48
[packages/apache.git] / apache.spec
index a331e8a7f89cf5c7d5652bc83b5de135f3b35c18..629a89085881bcba2dafb5c5e36684186ca0f7f5 100644 (file)
@@ -25,7 +25,6 @@
 %define                apr_ver         1:1.6.0
 %define                apr_util_ver    1:1.6.0
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       The most widely used Web server on the Internet
 Summary(de.UTF-8):     Leading World Wide Web-Server
 Summary(es.UTF-8):     Servidor HTTPD para proveer servicios WWW
@@ -35,12 +34,12 @@ Summary(pt_BR.UTF-8):       Servidor HTTPD para prover serviços WWW
 Summary(ru.UTF-8):     Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
-Version:       2.4.33
-Release:       2
+Version:       2.4.48
+Release:       1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
-# Source0-md5: 6ef469d3f16fffeb688bc6e0346823e5
+# Source0-md5: a7088cec171b0d00bf43394ce64d3909
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
@@ -98,6 +97,7 @@ BuildRequires:        apr-util-devel >= %{apr_util_ver}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 %{?with_distcache:BuildRequires:       distcache-devel}
+BuildRequires: jansson-devel >= 0.6.0
 BuildRequires: libbrotli-devel >= 0.6.0
 BuildRequires: libtool >= 2:1.5
 BuildRequires: libxml2-devel >= 2
@@ -2332,6 +2332,7 @@ Requires: %{name}-base = %{version}-%{release}
 Provides:      apache(mod_socache) = %{version}-%{release}
 Provides:      apache(mod_socache_dbm) = %{version}-%{release}
 Provides:      apache(mod_socache_memcache) = %{version}-%{release}
+Provides:      apache(mod_socache_redis) = %{version}-%{release}
 Provides:      apache(mod_socache_shmcb) = %{version}-%{release}
 Obsoletes:     apache-mod_socache_dbm
 Obsoletes:     apache-mod_socache_memcache
@@ -2345,6 +2346,10 @@ mod_socache_memcache is a shared object cache provider which provides
 for creation and access to a cache backed by the memcached
 high-performance, distributed memory object caching system.
 
+mod_socache_redis is a shared object cache provider which provides
+for creation and access to a cache backed by the redis
+high-performance, distributed memory object caching system.
+
 mod_socache_shmcb is a shared object cache provider which provides for
 creation and access to a cache backed by a high-performance cyclic
 buffer inside a shared memory segment.
@@ -2354,12 +2359,17 @@ mod_socache_dbm to moduł dostarczający współdzieloną pamięć podręczną
 obiektów, zapewniający tworzenie i dostęp do cache'a zapisywanego w
 bazie DBM.
 
-mod_socache_dbm to moduł dostarczający współdzieloną pamięć podręczną
+mod_socache_memcache to moduł dostarczający współdzieloną pamięć podręczną
 obiektów, zapewniający tworzenie i dostęp do cache'a zapisywanego w
 systemie memcached - wysoko wydajnym, ozproszonym systemie pamięci
 podręcznej obiektów.
 
-mod_socache_dbm to moduł dostarczający współdzieloną pamięć podręczną
+mod_socache_redis to moduł dostarczający współdzieloną pamięć podręczną
+obiektów, zapewniający tworzenie i dostęp do cache'a zapisywanego w
+systemie redis - wysoko wydajnym, ozproszonym systemie pamięci
+podręcznej obiektów.
+
+mod_socache_shmcb to moduł dostarczający współdzieloną pamięć podręczną
 obiektów, zapewniający tworzenie i dostęp do cache'a zapisywanego w
 wysoko wydajnym buforze cyklicznym wewnątrz segmentu pamięci
 dzielonej.
@@ -2712,6 +2722,7 @@ CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
 install -d build; cd build
 ../%configure \
        --enable-layout=TLD \
+       --disable-systemd \
        --disable-v4-mapped \
        --enable-exception-hook \
        --enable-modules=all \
@@ -2754,6 +2765,7 @@ install -d build; cd build
        --enable-log-forensic \
        --enable-logio \
        --enable-lua \
+       --enable-md \
        --enable-mime-magic \
        --enable-mpms-shared=all \
 %ifarch %{ix86}
@@ -2801,7 +2813,7 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{webapps.d,conf.d,vhosts.d} \
        $RPM_BUILD_ROOT%{_datadir}/{cgi-bin,vhosts}
 
-%{__make} -C build install \
+%{__make} -j 1 -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # clean "ccache" prefix. confuses other build systems (like php)
@@ -2881,7 +2893,7 @@ for module in access_compat actions alias allowmethods asis auth_basic \
        ratelimit reflector remoteip reqtimeout request rewrite \
        sed session_cookie session_crypto session_dbd session setenvif \
        slotmem_plain slotmem_shm socache_dbm socache_memcache \
-       socache_shmcb speling substitute \
+       socache_redis socache_shmcb speling substitute \
        unique_id usertrack version watchdog xml2enc; do
 
        LoadModule 00 $module
@@ -3697,9 +3709,11 @@ fi
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_socache_dbm.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_socache_memcache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_socache_redis.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_socache_shmcb.conf
 %attr(755,root,root) %{_libexecdir}/mod_socache_dbm.so
 %attr(755,root,root) %{_libexecdir}/mod_socache_memcache.so
+%attr(755,root,root) %{_libexecdir}/mod_socache_redis.so
 %attr(755,root,root) %{_libexecdir}/mod_socache_shmcb.so
 
 %files mod_speling