]> TLD Linux GIT Repositories - packages/apache.git/blobdiff - libtool-tag.patch
- adjusted for rpm.org, partial PLD merge
[packages/apache.git] / libtool-tag.patch
index 17259e44df508daca7f81b9b51467331e40bfbde..7cc55fd957b33585a9dcc4d378ddd16d5cd8c116 100644 (file)
@@ -1,25 +1,25 @@
 --- httpd-2.2.17/build/rules.mk.in~    2006-07-12 06:38:44.000000000 +0300
 +++ httpd-2.2.17/build/rules.mk.in     2011-03-26 18:27:36.410587573 +0200
-@@ -38,17 +38,17 @@
- COMPILE      = $(BASE_CC) @PICFLAGS@
- CXX_COMPILE  = $(BASE_CXX) @PICFLAGS@
+@@ -41,17 +41,17 @@
+ COMPILE      = $(BASE_CC) $(PICFLAGS)
+ CXX_COMPILE  = $(BASE_CXX) $(PICFLAGS)
  
--SH_COMPILE     = $(LIBTOOL) --mode=compile $(BASE_CC) @SHLTCFLAGS@ -c $< && touch $@
--SH_CXX_COMPILE = $(LIBTOOL) --mode=compile $(BASE_CXX) @SHLTCFLAGS@ -c $< && touch $@
-+SH_COMPILE     = $(LIBTOOL) --mode=compile --tag=CC $(BASE_CC) @SHLTCFLAGS@ -c $< && touch $@
-+SH_CXX_COMPILE = $(LIBTOOL) --mode=compile --tag=CXX $(BASE_CXX) @SHLTCFLAGS@ -c $< && touch $@
+-SH_COMPILE     = $(LIBTOOL) --mode=compile $(BASE_CC) $(SHLTCFLAGS) -c $< && touch $@
+-SH_CXX_COMPILE = $(LIBTOOL) --mode=compile $(BASE_CXX) $(SHLTCFLAGS) -c $< && touch $@
++SH_COMPILE     = $(LIBTOOL) --mode=compile --tag=CC $(BASE_CC) $(SHLTCFLAGS) -c $< && touch $@
++SH_CXX_COMPILE = $(LIBTOOL) --mode=compile --tag=CXX $(BASE_CXX) $(SHLTCFLAGS) -c $< && touch $@
  
--LT_COMPILE     = $(LIBTOOL) --mode=compile $(COMPILE) @LTCFLAGS@ -c $< && touch $@
--LT_CXX_COMPILE = $(LIBTOOL) --mode=compile $(CXX_COMPILE) @LTCFLAGS@ -c $< && touch $@
-+LT_COMPILE     = $(LIBTOOL) --mode=compile --tag=CC $(COMPILE) @LTCFLAGS@ -c $< && touch $@
-+LT_CXX_COMPILE = $(LIBTOOL) --mode=compile --tag=CXX $(CXX_COMPILE) @LTCFLAGS@ -c $< && touch $@
+-LT_COMPILE     = $(LIBTOOL) --mode=compile $(COMPILE) $(LTCFLAGS) -c $< && touch $@
+-LT_CXX_COMPILE = $(LIBTOOL) --mode=compile $(CXX_COMPILE) $(LTCFLAGS) -c $< && touch $@
++LT_COMPILE     = $(LIBTOOL) --mode=compile --tag=CC $(COMPILE) $(LTCFLAGS) -c $< && touch $@
++LT_CXX_COMPILE = $(LIBTOOL) --mode=compile --tag=CXX $(CXX_COMPILE) $(LTCFLAGS) -c $< && touch $@
  
  # Link-related commands
  
--LINK     = $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) @PILDFLAGS@ $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@
+-LINK     = $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) $(PILDFLAGS) $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@
 -SH_LINK  = $(SH_LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) $(LT_LDFLAGS) $(ALL_LDFLAGS) $(SH_LDFLAGS) $(CORE_IMPLIB) $(SH_LIBS) -o $@
 -MOD_LINK = $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) -static $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@
-+LINK     = $(LIBTOOL) --mode=link --tag=CC $(CC) $(ALL_CFLAGS) @PILDFLAGS@ $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@
++LINK     = $(LIBTOOL) --mode=link --tag=CC $(CC) $(ALL_CFLAGS) $(PILDFLAGS) $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@
 +SH_LINK  = $(SH_LIBTOOL) --mode=link --tag=CC $(CC) $(ALL_CFLAGS) $(LT_LDFLAGS) $(ALL_LDFLAGS) $(SH_LDFLAGS) $(CORE_IMPLIB) $(SH_LIBS) -o $@
 +MOD_LINK = $(LIBTOOL) --mode=link --tag=CC $(CC) $(ALL_CFLAGS) -static $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@
  
  
  #
  # Dependencies
+--- httpd-2.4.16/support/Makefile.in   2015-09-11 16:11:56.135519322 +0300
++++ httpd-2.4.16/support/Makefile.in   2015-09-11 16:16:16.075587666 +0300
+@@ -62,10 +62,10 @@ htdbm: $(htdbm_OBJECTS)
+ ab_OBJECTS = ab.lo
+ ab_LDADD = $(PROGRAM_LDADD) $(MATH_LIBS) $(ab_LIBS)
+ ab.lo: ab.c
+-      $(LIBTOOL) --mode=compile $(CC) $(ab_CFLAGS) $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
++      $(LIBTOOL) --mode=compile --tag=CC $(CC) $(ab_CFLAGS) $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
+           $(ALL_INCLUDES) $(PICFLAGS) $(LTCFLAGS) -c $< && touch $@
+ ab: $(ab_OBJECTS)
+-      $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) $(PILDFLAGS) \
++      $(LIBTOOL) --mode=link --tag=CC $(CC) $(ALL_CFLAGS) $(PILDFLAGS) \
+           $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@ $(ab_LTFLAGS) $(ab_OBJECTS) $(ab_LDADD)
+ checkgid_OBJECTS = checkgid.lo
+--- httpd-2.4.16/support/apxs.in~      2015-09-11 16:01:29.000000000 +0300
++++ httpd-2.4.16/support/apxs.in       2015-09-11 16:02:27.246251056 +0300
+@@ -430,7 +430,7 @@
+         $la =~ s|\.c$|.la|;
+         my $o = $s;
+         $o =~ s|\.c$|.o|;
+-        push(@cmds, "$libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $apr_includedir $apu_includedir $opt -c -o $lo $s && touch $slo");
++        push(@cmds, "$libtool $ltflags --mode=compile --tag=CC $CFG_CC $cflags -I$CFG_INCLUDEDIR $apr_includedir $apu_includedir $opt -c -o $lo $s && touch $slo");
+         unshift(@objs, $lo);
+     }
+@@ -471,7 +471,7 @@
+         $opt .= " -rpath $CFG_LIBEXECDIR -module -avoid-version $apr_ldflags";
+     }
+-    push(@cmds, "$libtool $ltflags --mode=link $CFG_CC $ldflags -o $dso_file $opt $lo");
++    push(@cmds, "$libtool $ltflags --mode=link --tag=CC $CFG_CC $ldflags -o $dso_file $opt $lo");
+     #   execute the commands
+     &execute_cmds(@cmds);