]> TLD Linux GIT Repositories - packages/apache.git/blobdiff - libtool-tag.patch
- adjusted for rpm.org, partial PLD merge
[packages/apache.git] / libtool-tag.patch
index a5c230bdcef2593c72cbe46b0bb828e8180d92ec..7cc55fd957b33585a9dcc4d378ddd16d5cd8c116 100644 (file)
@@ -1,5 +1,5 @@
---- httpd-2.4.4/build/rules.mk.in.orig 2012-09-26 16:30:31.000000000 +0200
-+++ httpd-2.4.4/build/rules.mk.in      2013-03-07 23:18:20.779633942 +0100
+--- httpd-2.2.17/build/rules.mk.in~    2006-07-12 06:38:44.000000000 +0300
++++ httpd-2.2.17/build/rules.mk.in     2011-03-26 18:27:36.410587573 +0200
 @@ -41,17 +41,17 @@
  COMPILE      = $(BASE_CC) $(PICFLAGS)
  CXX_COMPILE  = $(BASE_CXX) $(PICFLAGS)
@@ -25,7 +25,7 @@
  
  # Cross compile commands
  
-@@ -228,7 +228,7 @@
+@@ -216,7 +216,7 @@
  
  # Makes an import library from a def file
  .def.la:
  
  #
  # Dependencies
+--- httpd-2.4.16/support/Makefile.in   2015-09-11 16:11:56.135519322 +0300
++++ httpd-2.4.16/support/Makefile.in   2015-09-11 16:16:16.075587666 +0300
+@@ -62,10 +62,10 @@ htdbm: $(htdbm_OBJECTS)
+ ab_OBJECTS = ab.lo
+ ab_LDADD = $(PROGRAM_LDADD) $(MATH_LIBS) $(ab_LIBS)
+ ab.lo: ab.c
+-      $(LIBTOOL) --mode=compile $(CC) $(ab_CFLAGS) $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
++      $(LIBTOOL) --mode=compile --tag=CC $(CC) $(ab_CFLAGS) $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
+           $(ALL_INCLUDES) $(PICFLAGS) $(LTCFLAGS) -c $< && touch $@
+ ab: $(ab_OBJECTS)
+-      $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) $(PILDFLAGS) \
++      $(LIBTOOL) --mode=link --tag=CC $(CC) $(ALL_CFLAGS) $(PILDFLAGS) \
+           $(LT_LDFLAGS) $(ALL_LDFLAGS) -o $@ $(ab_LTFLAGS) $(ab_OBJECTS) $(ab_LDADD)
+ checkgid_OBJECTS = checkgid.lo
+--- httpd-2.4.16/support/apxs.in~      2015-09-11 16:01:29.000000000 +0300
++++ httpd-2.4.16/support/apxs.in       2015-09-11 16:02:27.246251056 +0300
+@@ -430,7 +430,7 @@
+         $la =~ s|\.c$|.la|;
+         my $o = $s;
+         $o =~ s|\.c$|.o|;
+-        push(@cmds, "$libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $apr_includedir $apu_includedir $opt -c -o $lo $s && touch $slo");
++        push(@cmds, "$libtool $ltflags --mode=compile --tag=CC $CFG_CC $cflags -I$CFG_INCLUDEDIR $apr_includedir $apu_includedir $opt -c -o $lo $s && touch $slo");
+         unshift(@objs, $lo);
+     }
+@@ -471,7 +471,7 @@
+         $opt .= " -rpath $CFG_LIBEXECDIR -module -avoid-version $apr_ldflags";
+     }
+-    push(@cmds, "$libtool $ltflags --mode=link $CFG_CC $ldflags -o $dso_file $opt $lo");
++    push(@cmds, "$libtool $ltflags --mode=link --tag=CC $CFG_CC $ldflags -o $dso_file $opt $lo");
+     #   execute the commands
+     &execute_cmds(@cmds);