]> TLD Linux GIT Repositories - packages/apache.git/commitdiff
- more triggers to provide smoother upgrade from 2.2
authorBartosz Świątek <shadzik@tld-linux.org>
Sun, 26 Feb 2012 20:11:55 +0000 (21:11 +0100)
committerBartosz Świątek <shadzik@tld-linux.org>
Sun, 26 Feb 2012 20:11:55 +0000 (21:11 +0100)
apache.spec

index 684a61147ee615d51de0788879483c5bb321e55b..2a6123cf99976c1dcf7ee80c2d877ab7ace5f885 100644 (file)
@@ -2468,22 +2468,16 @@ Please report bugs to <http://bugs.pld-linux.org/>.
 EOF
 
 %triggerpostun base -- %{name} < 2.4.0
-%banner -e %{name} << EOF
-WARNING!!!
-Since apache-2.4 mod_authn_alias has been obsoleted.
-If you use access control (Deny,Allow) install mod_access_compat by doing:
-poldek -ivh %{name}-mod_access_compat
-
-In apache-2.4 mod_authn_default and mod_authz_default have been obsoleted by
-mod_authn_core and authz_core. If you used these modules install the new ones by invoking:
-poldek -ivh %{name}-mod_authn_core
-and/or
-poldek -ivh %{name}-mod_authz_core
-
-For more information on how to upgrade from Apache 2.2 visit:
-http://httpd.apache.org/docs/2.4/upgrading.html
-EOF
-
+cp -f /etc/httpd/apache.conf{,.rpmsave}
+sed -i -e '
+       /^DefaultType.*/s,.*,,
+       /^Include /s,^Include ,IncludeOptional ,
+       /^NameVirtualHost.*/s,.*,,
+       /^User/s,^,LoadModule unixd_module modules/mod_unixd.so\n,
+' /etc/httpd/apache.conf
+sed -i -e '
+       s,^LockFile /var/run/httpd/accept.lock,Mutex file:/var/run/httpd/,g
+' /etc/httpd/conf.d/10_mpm.conf
 
 %triggerpostun mod_ssl -- %{name}-mod_ssl < 1:2.2.0-3.1
 cp -f /etc/httpd/conf.d/40_mod_ssl.conf{,.rpmsave}
@@ -2492,6 +2486,13 @@ sed -i -e '
        s,/var/cache/apache,/var/cache/httpd,g
 ' /etc/httpd/conf.d/40_mod_ssl.conf
 
+%triggerpostun mod_ssl -- %{name}-mod_ssl < 1:2.4.0
+cp -f /etc/httpd/conf.d/40_mod_ssl.conf{,.rpmsave}
+sed -i -e '
+       /^SSLMutex/s,^,#,
+       /^NameVirtualHost.*/s,.*,,
+' /etc/httpd/conf.d/40_mod_ssl.conf
+
 %posttrans base
 # restore lock which we disabled in pretrans
 mv -f /var/lock/subsys/httpd{.disabled,} 2>/dev/null