]> TLD Linux GIT Repositories - packages/apr-util.git/blobdiff - apr-util.spec
- fix building with MySQL 8.x
[packages/apr-util.git] / apr-util.spec
index 58baf34984b2c5d54913478b882ad189a70842e2..641e713302d72f50d07a029c407026855592ca8e 100644 (file)
@@ -1,6 +1,7 @@
+# NOTE: drop freetds bcond if/when upstream removes the rest of dbd-freetds code
 #
 # Conditional build:
-%bcond_without freetds # without FreeTDS (sybdb) DBD module
+%bcond_with    freetds # without FreeTDS (sybdb) DBD module [unsupported since 1.6.0]
 %bcond_without mysql   # without MySQL DBD module
 %bcond_without odbc    # without ODBC DBD module
 %bcond_with    oracle  # with Oracle DBD module (BR: proprietary libs)
 %bcond_without openssl # without OpenSSL crypto module
 %bcond_without tests   # don't perform "make check"
 
-%define        dbver   db45
-
-# tests fail on x32
-%ifarch x32
-%undefine      with_nss
-%endif
-
-# files list broken, feel free to really fix
-%ifarch alpha
-%undefine      with_mysql
-%endif
+%define        dbver   db53
 
 Summary:       A companion library to Apache Portable Runtime
 Summary(pl.UTF-8):     Biblioteka towarzysząca Apache Portable Runtime
 Name:          apr-util
-Version:       1.5.4
+Version:       1.6.3
 Release:       2
 Epoch:         1
 License:       Apache v2.0
 Group:         Libraries
 Source0:       http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
-# Source0-md5: 2202b18f269ad606d70e1864857ed93c
+# Source0-md5: b6e8c9b31d938fe5797ceb0d1ff2eb69
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-config-noldap.patch
-Patch2:                %{name}-libtool.patch
 Patch3:                %{name}-flags.patch
+Patch4:                mysql8.patch
 URL:           http://apr.apache.org/
-BuildRequires: apr-devel >= 1:1.3.0
+BuildRequires: apr-devel >= 1:1.6.0
 BuildRequires: autoconf >= 2.59
-BuildRequires: db-devel >= 4.5
+BuildRequires: db-devel >= 5.3
 BuildRequires: expat-devel
 %{?with_freetds:BuildRequires: freetds-devel}
 BuildRequires: libtool
-%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_mysql:BuildRequires:   mysql-devel >= 8.0.35}
 %{?with_nss:BuildRequires:     nss-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 %{?with_openssl:BuildRequires: openssl-devel}
@@ -55,7 +46,8 @@ BuildRequires:        rpm >= 4.4.9-56
 %{?with_sqlite3:BuildRequires: sqlite3-devel >= 3}
 %{?with_odbc:BuildRequires:    unixODBC-devel}
 BuildRequires: which
-Requires:      apr >= 1:1.3.0
+Requires:      apr >= 1:1.6.0
+%{!?with_freetds:Obsoletes:    apr-util-dbd-freetds}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _includedir     /usr/include/apr-util
@@ -206,7 +198,7 @@ Summary:    Header files and development documentation for apr-util
 Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja programisty do apr-util
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      apr-devel >= 1:1.3.0
+Requires:      apr-devel >= 1:1.6.0
 Requires:      expat-devel
 
 %description devel
@@ -231,11 +223,8 @@ Statyczna biblioteka apr-util.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
-
-# ensure system expat is used
-%{__rm} -r xml/expat
+%patch4 -p0
 
 echo '
 <Layout TLD>
@@ -257,6 +246,7 @@ echo '
 ' > config.layout
 
 %build
+PYTHON=%{__python3} \
 ./buildconf \
        --with-apr=%{_datadir}/apr
 
@@ -275,7 +265,7 @@ echo '
        %{?with_nss:--with-nss} \
        %{?with_openssl:--with-openssl} \
        %{!?with_freetds:--without-freetds} \
-       %{?with_mysql:--with-mysql=%{_prefix}} \
+       %{?with_mysql:--with-mysql} \
        %{!?with_odbc:--without-odbc} \
        %{?with_oracle:--with-oracle} \
        %{!?with_pgsql:--without-pgsql} \