]> TLD Linux GIT Repositories - packages/bash-completion.git/commitdiff
- TLDized
authorMarcin Krol <hawk@tld-linux.org>
Mon, 3 Aug 2015 08:32:09 +0000 (08:32 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 3 Aug 2015 08:32:09 +0000 (08:32 +0000)
bash-completion-tld.patch [new file with mode: 0644]
bash-completion.spec
builder.bash-completion

diff --git a/bash-completion-tld.patch b/bash-completion-tld.patch
new file mode 100644 (file)
index 0000000..055b426
--- /dev/null
@@ -0,0 +1,14 @@
+diff -ur bash-completion-2.1.orig/bash_completion bash-completion-2.1/bash_completion
+--- bash-completion-2.1.orig/bash_completion   2013-04-05 10:55:51.000000000 +0000
++++ bash-completion-2.1/bash_completion        2015-08-03 08:29:53.003582721 +0000
+@@ -858,8 +858,8 @@
+         COMPREPLY=( $( compgen -W "$( printf '%s\n' \
+             /etc/sysconfig/network/ifcfg-* | \
+             sed -ne 's|.*ifcfg-\(.*\)|\1|p' )" -- "$cur" ) )
+-    elif [[ -f /etc/pld-release ]]; then
+-        # PLD Linux
++    elif [[ -f /etc/tld-release ]]; then
++        # TLD Linux
+         COMPREPLY=( $( compgen -W "$( command ls -B \
+             /etc/sysconfig/interfaces | \
+             sed -ne 's|.*ifcfg-\(.*\)|\1|p' )" -- "$cur" ) )
index 13ff511ad7bcd598819ec8d9f052875e38e55833..5ba1c44d6c00ca773cde4db77b58940889a3d630 100644 (file)
@@ -6,7 +6,7 @@ Summary:        bash-completion offers programmable completion for bash
 Summary(pl.UTF-8):     Programowalne uzupełnianie nazw dla basha
 Name:          bash-completion
 Version:       2.1
 Summary(pl.UTF-8):     Programowalne uzupełnianie nazw dla basha
 Name:          bash-completion
 Version:       2.1
-Release:       4
+Release:       5
 Epoch:         1
 License:       GPL v2+
 Group:         Applications/Shells
 Epoch:         1
 License:       GPL v2+
 Group:         Applications/Shells
@@ -16,7 +16,7 @@ Source1:      %{name}-poldek.sh
 # https://bugs.launchpad.net/ubuntu/+source/mysql-dfsg-5.0/+bug/106975
 Source3:       http://launchpadlibrarian.net/19164189/mysqldump
 # Source3-md5: 09e4885be92e032400ed702f39925d85
 # https://bugs.launchpad.net/ubuntu/+source/mysql-dfsg-5.0/+bug/106975
 Source3:       http://launchpadlibrarian.net/19164189/mysqldump
 # Source3-md5: 09e4885be92e032400ed702f39925d85
-Source4:       http://svn.php.net/viewvc/pear2/sandbox/PEAR_BashCompletion/trunk/pear?revision=285425&view=co?/pear
+Source4:       pear
 # Source4-md5: 8ce77e4459e2c45e2096da8d03c8f43d
 Patch0:                %{name}-rpm-cache.patch
 Patch1:                pear.patch
 # Source4-md5: 8ce77e4459e2c45e2096da8d03c8f43d
 Patch0:                %{name}-rpm-cache.patch
 Patch1:                pear.patch
@@ -24,7 +24,7 @@ URL:          http://bash-completion.alioth.debian.org/
 BuildRequires: sed >= 4.0
 Requires(triggerpostun):       sed >= 4.0
 Requires:      bash >= 4.1
 BuildRequires: sed >= 4.0
 Requires(triggerpostun):       sed >= 4.0
 Requires:      bash >= 4.1
-Requires:      pld-release
+Requires:      issue >= 2013.01
 Obsoletes:     bash-completion-rpm-cache
 Conflicts:     rpm < 4.4.9-44
 BuildArch:     noarch
 Obsoletes:     bash-completion-rpm-cache
 Conflicts:     rpm < 4.4.9-44
 BuildArch:     noarch
@@ -72,7 +72,7 @@ cp -p completions/pear $RPM_BUILD_ROOT%{_datadir}/%{name}/completions
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/{cal,chsh,dmesg,eject,hexdump,hwclock,ionice,look,newgrp,renice,rtcwake,su}
 # No package matches '*/apache2ctl'
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/apache2ctl
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/{cal,chsh,dmesg,eject,hexdump,hwclock,ionice,look,newgrp,renice,rtcwake,su}
 # No package matches '*/apache2ctl'
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/apache2ctl
-# No PLD package or no such binary to complete on
+# No TLD package or no such binary to complete on
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/{larch,lisp,monodevelop,[pg]4,cowsay,cowthink,cpan2dist}
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/{mkinitrd,rpmcheck}
 # FreeBSD stuff
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/{larch,lisp,monodevelop,[pg]4,cowsay,cowthink,cpan2dist}
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/completions/{mkinitrd,rpmcheck}
 # FreeBSD stuff
index 0b081c8d960d8741494c83103cfbbf196c64b3c0..623683f83aba7a99845b18efa2e76e8eb56c8cb1 100644 (file)
@@ -1,4 +1,4 @@
-# PLD Linux builder(1) script completion
+# TLD Linux builder(1) script completion
 
 # get active spec file from commandline
 # caller should make $spec local variable
 
 # get active spec file from commandline
 # caller should make $spec local variable