]> TLD Linux GIT Repositories - packages/busybox.git/blob - busybox.spec
- merged 1.31.1 from PLD
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define         with_glibc      1
34 %endif
35 %ifarch x32
36 # until uClibc builds on x32
37 %undefine       with_static
38 %endif
39 Summary:        Set of common Unix utilities for embeded systems
40 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
41 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
42 Name:           busybox
43 # stable line only
44 Version:        1.31.1
45 Release:        2
46 License:        GPL v2
47 Group:          Applications
48 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
49 # Source0-md5:  70913edaf2263a157393af07565c17f0
50 Source1:        %{name}.config
51 Source2:        %{name}-initrd.config
52 %{?with_altconfig:Source3:      %{cfgfile}}
53 Patch0:         x32.patch
54 Patch1:         %{name}-logconsole.patch
55 Patch2:         %{name}-printf-gettext.patch
56 Patch3:         %{name}-loadfont.patch
57 Patch4:         %{name}-kernel_headers.patch
58 Patch5:         %{name}-insmod-morearchs.patch
59 Patch6:         %{name}-dhcp.patch
60 Patch7:         %{name}-fix_64_archs.patch
61 Patch8:         busybox-1.31.1-stime-fix.patch
62 Patch9:         %{name}-ash-export-PATH.patch
63 URL:            http://www.busybox.net/
64 BuildRequires:  gcc >= 3.2
65 BuildRequires:  perl-tools-pod
66 BuildRequires:  rpmbuild(macros) >= 1.652
67 %if %{with initrd} || %{with static}
68         %if %{with dietlibc}
69 BuildRequires:  dietlibc-static
70         %else
71                 %if %{with glibc}
72 BuildRequires:  glibc-static
73                 %else
74 %if "%{_target_base_arch}" != "%{_host_base_arch}"
75 BuildRequires:  cross%{_target_base_arch}-uClibc-static
76 %else
77         %ifarch ppc %{x8664}
78 BuildRequires:  uClibc-static >= 3:0.9.30.1
79         %else
80 BuildRequires:  uClibc-static >= 3:0.9.30.1
81         %endif
82 %endif
83                 %endif
84         %endif
85 %endif
86 %{?with_sh_prov:Provides:       /bin/sh}
87 %{?with_fileutl_prov:Provides:  fileutils}
88 %{?with_grep_prov:Provides:     grep}
89 Provides:       busybox-implementation = %{version}-%{release}
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _bindir         /bin
93
94 %if "%{_target_base_arch}" != "%{_host_base_arch}"
95         %define CrossOpts CROSS="%{_target_cpu}-tld-linux-"
96 %else
97         %define CrossOpts %{nil}
98 %endif
99
100 %define         filterout_ld    -Wl,-z,(combreloc|relro)
101
102 %description
103 BusyBox combines tiny versions of many common UNIX utilities into a
104 single small executable. It provides minimalist replacements for most
105 of the utilities you usually find in fileutils, shellutils, findutils,
106 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
107 POSIX environment for any small or embedded system. The utilities in
108 BusyBox generally have fewer options than their full-featured GNU
109 cousins; however, the options that are included provide the expected
110 functionality and behave very much like their GNU counterparts.
111
112 BusyBox has been written with size-optimization and limited resources
113 in mind. It is also extremely modular so you can easily include or
114 exclude commands (or features) at compile time. This makes it easy to
115 customize your embedded systems. To create a working system, just add
116 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
117 ae).
118
119 %description -l pl.UTF-8
120 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
121 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
122 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
123 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
124 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
125 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
126 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
127 (np. elvis-tiny albo ae).
128
129 %description -l pt_BR.UTF-8
130 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
131 executável, fornecendo substitutos minimalistas para muitos dos
132 executáveis encontrados em pacotes como fileutils, shellutils,
133 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
134 em geral têm menos opções que os utilitários GNU, mas as opções
135 implementadas comportam-se de maneira similar aos equivalentes GNU.
136
137 %package static
138 Summary:        Static busybox
139 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
140 Group:          Applications
141
142 %description static
143 Static busybox.
144
145 %description static -l pl.UTF-8
146 Statycznie skonsolidowany busybox.
147
148 %package initrd
149 Summary:        Static busybox for initrd
150 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
151 Group:          Base
152 Conflicts:      geninitrd < 10000.20
153 Provides:       busybox-implementation = %{version}-%{release}
154
155 %description initrd
156 Static busybox for initrd.
157
158 %description initrd -l pl.UTF-8
159 Statycznie skonsolidowany busybox dla initrd.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164 %patch1 -p1
165 %patch2 -p1
166 #%patch3 -p1
167 %patch4 -p1
168 %patch5 -p1
169 %patch6 -p1
170 %patch7 -p1
171 %patch8 -p1
172 %patch9 -p1
173
174 %build
175 install -d built
176 %if %{with initrd}
177 install %{SOURCE2} .config
178 %{__make} oldconfig
179 %{__make} \
180         %{?with_verbose:V=1} \
181         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
182         LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
183 %if %{with dietlibc}
184         LIBRARIES="-lrpc" \
185         CC="diet %{__cc}"
186 %else
187 %if %{with glibc}
188         %{CrossOpts} \
189         CC="%{__cc}"
190 %else
191         %if "%{_target_base_arch}" != "%{_host_base_arch}"
192         CROSS="%{_target_cpu}-uclibc-" \
193         %endif
194         CC="%{_target_cpu}-uclibc-gcc"
195 %endif
196 %endif
197
198 mv -f busybox built/busybox.initrd
199 %{__make} clean
200 %endif
201
202 %if %{with altconfig}
203 install %{SOURCE3} .config
204 %else
205 install %{SOURCE1} .config
206 %endif
207
208 %if %{with static}
209 %{__make} oldconfig
210 %{__make} \
211         %{?with_verbose:V=1} \
212         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
213         LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
214 %if %{with dietlibc}
215         LIBRARIES="-lrpc" \
216         CC="diet %{__cc}"
217 %else
218 %if %{with glibc}
219         %{CrossOpts} \
220         CC="%{__cc}"
221 %else
222         %if "%{_target_base_arch}" != "%{_host_base_arch}"
223         CROSS="%{_target_cpu}-uclibc-" \
224         %endif
225         CC="%{_target_cpu}-uclibc-gcc"
226 %endif
227 %endif
228
229 mv -f busybox built/busybox.static
230 %{__make} clean
231 %endif
232
233 %if %{with dynamic}
234 %{__make} oldconfig
235 %{__make} \
236         %{?with_verbose:V=1} \
237         %{CrossOpts} \
238         CFLAGS_EXTRA="%{rpmcflags}" \
239         LDFLAGS="%{rpmldflags} -Wl,-z,noexecstack" \
240         CC="%{__cc}"
241 %{__make} busybox.links docs/busybox.1
242 %endif
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246
247 %if %{with static}
248 install -d $RPM_BUILD_ROOT%{_bindir}
249 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
250 %endif
251
252 %if %{with initrd}
253 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
254 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
255 %endif
256
257 %if %{with dynamic}
258 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
259 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
260 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
261
262 # install links to busybox binary, when linkfl is defined
263 %if %{with linkfl}
264 %{__make} install \
265         PREFIX=$RPM_BUILD_ROOT
266 %else
267 install busybox $RPM_BUILD_ROOT%{_bindir}
268 %endif
269 %endif
270
271 %clean
272 rm -rf $RPM_BUILD_ROOT
273
274 %if %{with dynamic}
275 %files
276 %defattr(644,root,root,755)
277 %doc AUTHORS README .config
278
279 %if %{with linkfl}
280 %attr(755,root,root) /bin/*
281 %attr(755,root,root) /sbin/*
282 %attr(755,root,root) %{_bindir}/*
283 %attr(755,root,root) %{_sbindir}/*
284 %else
285 %attr(755,root,root) %{_bindir}/busybox
286 %endif
287
288 %{_libdir}/busybox
289 %{_mandir}/man1/busybox.1*
290 %endif
291
292 %if %{with static}
293 %files static
294 %defattr(644,root,root,755)
295 %attr(755,root,root) %{_bindir}/busybox.static
296 %endif
297
298 %if %{with initrd}
299 %files initrd
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_libdir}/initrd/busybox
302 %endif