]> TLD Linux GIT Repositories - packages/clamav.git/blobdiff - ac2.68.patch
- merged 0.98.3 from PLD, fixed ac patch
[packages/clamav.git] / ac2.68.patch
index ba4ae541acc08fa737405d663651bc1a21d23c00..68fe4d2766324d8d98b3d79d952bd2b062df2774 100644 (file)
@@ -1,25 +1,33 @@
-diff -ur clamav-0.98.orig/configure.ac clamav-0.98/configure.ac
---- clamav-0.98.orig/configure.ac      2013-09-21 10:56:27.087891623 +0000
-+++ clamav-0.98/configure.ac   2013-09-21 11:01:02.996891571 +0000
-@@ -54,6 +54,8 @@
- AC_PROG_INSTALL
- AC_PROG_LN_S
- AC_PROG_MAKE_SET
-+AM_PROG_AR
-+AM_PROG_CC_C_O
+diff -uNr clamav-0.98.3/configure.ac clamav-0.98.3-ac2.68/configure.ac
+--- clamav-0.98.3/configure.ac 2014-05-06 20:42:41.000000000 +0200
++++ clamav-0.98.3-ac2.68/configure.ac  2014-05-09 10:51:30.508280355 +0200
+@@ -42,12 +42,12 @@
+ AC_DEFINE([PACKAGE], PACKAGE_NAME, [Name of package])
+ m4_include([m4/reorganization/version.m4])
++m4_include([m4/reorganization/build_tools.m4])
  
  LT_CONFIG_LTDL_DIR([libltdl])
  LT_INIT([dlopen disable-static])
-@@ -469,7 +471,7 @@
+ LTDL_INIT([recursive])
  
- if test "$enable_check_ut" != "no" ; then
-       AC_LIB_FIND([check],[check.h],
--                      AC_LANG_PROGRAM([#include <check.h>],[srunner_create(0)]),
-+                      [AC_LANG_PROGRAM([#include <check.h>],[srunner_create(0)])],
-                       [CHECK_CPPFLAGS="$INCCHECK"; CHECK_LIBS="$LTLIBCHECK"],
-                       [])
- fi
-@@ -1548,8 +1550,8 @@
+-m4_include([m4/reorganization/build_tools.m4])
+ m4_include([m4/reorganization/headers.m4])
+ AC_CONFIG_FILES([libltdl/Makefile])
+diff -uNr clamav-0.98.3/m4/reorganization/build_tools.m4 clamav-0.98.3-ac2.68/m4/reorganization/build_tools.m4
+--- clamav-0.98.3/m4/reorganization/build_tools.m4     2014-05-06 20:39:56.000000000 +0200
++++ clamav-0.98.3-ac2.68/m4/reorganization/build_tools.m4      2014-05-09 10:53:30.800262620 +0200
+@@ -1,3 +1,5 @@
++AM_PROG_AR
+ AC_PROG_CC
++AM_PROG_CC_C_O
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+diff -uNr clamav-0.98.3/m4/reorganization/clamdtop.m4 clamav-0.98.3-ac2.68/m4/reorganization/clamdtop.m4
+--- clamav-0.98.3/m4/reorganization/clamdtop.m4        2014-05-06 20:39:56.000000000 +0200
++++ clamav-0.98.3-ac2.68/m4/reorganization/clamdtop.m4 2014-05-09 10:51:06.963907781 +0200
+@@ -6,8 +6,8 @@
  if test "$enable_clamdtop" != "no"; then
  
  AC_LIB_FIND([ncurses], [ncurses/ncurses.h],
@@ -30,7 +38,7 @@ diff -ur clamav-0.98.orig/configure.ac clamav-0.98/configure.ac
            [CURSES_CPPFLAGS="$INCNCURSES"; CURSES_LIBS="$LTLIBNCURSES";
             CURSES_INCLUDE="<ncurses/ncurses.h>"],
            [])
-@@ -1557,8 +1559,8 @@
+@@ -15,8 +15,8 @@
  if test "X$HAVE_LIBNCURSES" != "Xyes"; then
      HAVE_LIBNCURSES=
      AC_LIB_FIND([ncurses], [ncurses.h],
@@ -41,7 +49,7 @@ diff -ur clamav-0.98.orig/configure.ac clamav-0.98/configure.ac
            [CURSES_CPPFLAGS="$INCNCURSES"; CURSES_LIBS="$LTLIBNCURSES";
             CURSES_INCLUDE="<ncurses.h>"],
            [])
-@@ -1566,8 +1568,8 @@
+@@ -24,8 +24,8 @@
  
  if test "X$HAVE_LIBNCURSES" != "Xyes"; then
      AC_LIB_FIND([pdcurses],[curses.h],
@@ -52,3 +60,15 @@ diff -ur clamav-0.98.orig/configure.ac clamav-0.98/configure.ac
                            [CURSES_CPPFLAGS="$INCPDCURSES";
                             CURSES_LIBS="$LTLIBPDCURSES";
                             CURSES_INCLUDE="<curses.h>"],
+diff -uNr clamav-0.98.3/m4/reorganization/code_checks/unit_tests.m4 clamav-0.98.3-ac2.68/m4/reorganization/code_checks/unit_tests.m4
+--- clamav-0.98.3/m4/reorganization/code_checks/unit_tests.m4  2014-05-06 20:39:56.000000000 +0200
++++ clamav-0.98.3-ac2.68/m4/reorganization/code_checks/unit_tests.m4   2014-05-09 10:51:06.963907781 +0200
+@@ -12,7 +12,7 @@
+ esac
+       AC_LIB_FIND([check],[check.h],
+-                      AC_LANG_PROGRAM([#include <check.h>],[srunner_create(0)]),
++                      [AC_LANG_PROGRAM([#include <check.h>],[srunner_create(0)])],
+                       [CHECK_CPPFLAGS="$INCCHECK"; CHECK_LIBS="$LTLIBCHECK $LDFLAGS"],
+                       [])