]> TLD Linux GIT Repositories - packages/coreutils.git/blobdiff - coreutils.spec
- updated to 8.26
[packages/coreutils.git] / coreutils.spec
index dc098979bfbb0f1bc563044171832ab84d27d563..f1b2d5169a380280727eb2e4210edf26efabc62d 100644 (file)
@@ -1,42 +1,42 @@
-#
 # Conditional build:
 %bcond_with    advcopy # progress bar in cp (orphaned patch)
+%bcond_with    multicall       # Compile all the tools in a single binary
 %bcond_without tests   # do not perform "make test check"
-#
+
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       8.21
+Version:       8.26
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 065ba41828644eca5dd8163446de5d64
+# Source0-md5: d5aa2072f662d4118b9f4c63b94601a6
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
-Source3:       fileutils.sh
-Source4:       fileutils.csh
-Source5:       mktemp.1.pl
+Source3:       DIR_COLORS.256color
+Source4:       colorls.sh
+Source5:       colorls.csh
+Source6:       mktemp.1.pl
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-getgid.patch
 Patch2:                %{name}-uname-cpuinfo.patch
 Patch3:                %{name}-date-man.patch
-Patch5:                %{name}-7.4-sttytcsadrain.patch
 Patch6:                %{name}-fmt-wchars.patch
 Patch7:                %{name}-sparc64.patch
 # http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
 Patch8:                %{name}-pl.po-update.patch
 # from http://www.beatex.org/web/advancedcopy.html, edited by shadzik
 Patch9:                %{name}-advcopy.patch
-Patch10:       format-security.patch
+Patch10:       tests.patch
 URL:           http://www.gnu.org/software/coreutils/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11.2
 BuildRequires: gcc >= 5:3.2
-BuildRequires: gettext-devel >= 0.18.1
+BuildRequires: gettext-tools >= 0.18.1
 BuildRequires: gmp-devel
 BuildRequires: help2man
 BuildRequires: libcap-devel
@@ -103,12 +103,11 @@ Programy zawarte w tym pakiecie to:
 
 %prep
 %setup -q -a1
-#patch8 -p1
+%patch8 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch5 -p1
 %patch6 -p1
 %ifarch sparc64
 %patch7 -p1
@@ -119,6 +118,8 @@ Programy zawarte w tym pakiecie to:
 %endif
 %patch10 -p1
 
+mv man/pt_BR man/pt
+
 %{__perl} -pi -e 's@GNU/Linux@TLD Linux@' m4/host-os.m4
 
 # allow rebuilding *.gmo
@@ -142,6 +143,17 @@ Programy zawarte w tym pakiecie to:
 %{__rm} tests/ls/stat-free-color.sh
 %{__sed} -i -e '/ls\/stat-free-color/d' tests/local.mk
 
+# filesystem layout dependant (fails on some xfs fs)
+%{__rm} tests/dd/sparse.sh
+%{__sed} -i -e '/dd\/sparse/d' tests/local.mk
+
+# mksh is too smart for those, won't let programs fail on ulimit
+# would need bash here
+%{__rm} tests/misc/sort-merge-fdlimit.sh
+%{__sed} -i -e '/misc\/sort-merge-fdlimit/d' tests/local.mk
+%{__rm} tests/split/r-chunk.sh
+%{__sed} -i -e '/split\/r-chunk/d' tests/local.mk
+
 %build
 build-aux/gen-lists-of-programs.sh --autoconf > m4/cu-progs.m4
 build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
@@ -153,6 +165,7 @@ build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
 %configure \
        CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
        DEFAULT_POSIX2_VERSION=199209 \
+       %{?with_multicall:--enable-single-binary=symlinks} \
        --disable-silent-rules \
        --enable-install-program=arch \
        --enable-no-install-program=hostname,kill,uptime
@@ -161,7 +174,7 @@ build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
 
 %if %{with tests}
 sed -i -e 's#COLUMNS##g' tests/envvar-check
-%{__make} -j1 tests check
+LC_ALL=C LANG=C %{__make} -j1 tests check
 %endif
 
 %install
@@ -171,25 +184,32 @@ install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/shrc.d}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
-df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,rm,rmdir,\
+mv $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
+df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,readlink,rm,rmdir,\
 sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
+%if %{with multicall}
+mv $RPM_BUILD_ROOT{%{_bindir},/bin}/coreutils
+ln -s ../../bin/coreutils $RPM_BUILD_ROOT%{_bindir}
+%endif
+
+mv $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
-cp -p %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
+cp -p %{SOURCE4} %{SOURCE5} $RPM_BUILD_ROOT/etc/shrc.d
 
-cp -a man/pt_BR man/pt
 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN; do
        install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
        cp -p man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
 done
-install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
+cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
 # unwanted (-f left intentionally - some manuals could have no translations)
 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,su,uptime}.1
 # always remove, never packaged but sometimes installed
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
+# remove locales not available in the system
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr/LC_TIME
 
 %find_lang %{name}
 
@@ -228,6 +248,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /bin/nice
 %attr(755,root,root) /bin/printf
 %attr(755,root,root) /bin/pwd
+%attr(755,root,root) /bin/readlink
 %attr(755,root,root) /bin/rm
 %attr(755,root,root) /bin/rmdir
 %attr(755,root,root) /bin/sleep
@@ -240,6 +261,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /bin/uname
 %attr(755,root,root) /bin/unlink
 %attr(755,root,root) %{_bindir}/[
+%attr(755,root,root) %{_bindir}/b2sum
+%attr(755,root,root) %{_bindir}/base32
 %attr(755,root,root) %{_bindir}/base64
 %attr(755,root,root) %{_bindir}/chcon
 %attr(755,root,root) %{_bindir}/cksum
@@ -276,7 +299,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/pr
 %attr(755,root,root) %{_bindir}/printenv
 %attr(755,root,root) %{_bindir}/ptx
-%attr(755,root,root) %{_bindir}/readlink
 %attr(755,root,root) %{_bindir}/realpath
 %attr(755,root,root) %{_bindir}/runcon
 %attr(755,root,root) %{_bindir}/seq
@@ -308,12 +330,20 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/whoami
 %attr(755,root,root) %{_bindir}/yes
 %attr(755,root,root) %{_sbindir}/chroot
+%if %{with multicall}
+%attr(755,root,root) /bin/coreutils
+%attr(755,root,root) %{_bindir}/coreutils
+%{_mandir}/man1/coreutils.1*
+%endif
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
-%config(noreplace) /etc/shrc.d/fileutils.csh
-%config(noreplace) /etc/shrc.d/fileutils.sh
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS.256color
+%config(noreplace) /etc/shrc.d/colorls.csh
+%config(noreplace) /etc/shrc.d/colorls.sh
 %dir %{_libdir}/coreutils
 %attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
 %{_mandir}/man1/arch.1*
+%{_mandir}/man1/b2sum.1*
+%{_mandir}/man1/base32.1*
 %{_mandir}/man1/base64.1*
 %{_mandir}/man1/basename.1*
 %{_mandir}/man1/cat.1*