]> TLD Linux GIT Repositories - packages/coreutils.git/blobdiff - tests.patch
- updated to 8.26
[packages/coreutils.git] / tests.patch
index 280c5e7414fc054afc89c5b1a09eae5fdd358cc0..89d7b60ee8b7eab938f90166e65f0f02a4dae6ac 100644 (file)
@@ -1,54 +1,43 @@
 --- coreutils-8.21/tests/misc/printenv.sh~     2013-01-31 01:46:24.000000000 +0100
 +++ coreutils-8.21/tests/misc/printenv.sh      2013-12-03 12:25:51.949012868 +0100
-@@ -23,8 +23,8 @@
- # printenv as a builtin, so we must invoke it via "env".
- # But beware of $_, set by many shells to the last command run.
- # Also, filter out LD_PRELOAD, which is set when running under valgrind.
--env | grep -Ev '^(_|LD_PRELOAD=)' > exp || framework_failure_
--env -- printenv | grep -Ev '^(_|LD_PRELOAD=)' > out || fail=1
-+env | grep -Ev '^(_|LD_PRELOAD=|RANDOM=)' > exp || framework_failure_
-+env -- printenv | grep -Ev '^(_|LD_PRELOAD=|RANDOM=)' > out || fail=1
+@@ -27,8 +27,8 @@ print_ver_ printenv
+ # env's output the same way as that of printenv and works around a bug
+ # on aarch64 at least where libc's execvp reverses the order of the
+ # output.
+-env -- env | grep -Ev '^(_|LD_PRELOAD)=' > exp || framework_failure_
+-env -- printenv | grep -Ev '^(_|LD_PRELOAD)=' > out || fail=1
++env -- env | grep -Ev '^(_|LD_PRELOAD|RANDOM=)=' > exp || framework_failure_
++env -- printenv | grep -Ev '^(_|LD_PRELOAD|RANDOM=)=' > out || fail=1
  compare exp out || fail=1
  
  # POSIX is clear that environ may, but need not be, sorted.
 --- coreutils-8.21/tests/misc/realpath.sh.orig 2013-12-03 12:36:46.105079823 +0100
 +++ coreutils-8.21/tests/misc/realpath.sh      2013-12-03 12:46:44.854069134 +0100
-@@ -16,8 +16,8 @@
- # You should have received a copy of the GNU General Public License
- # along with this program.  If not, see <http://www.gnu.org/licenses/>.
--. "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
--print_ver_ realpath
-+. "${srcdir=.}/tests/init.sh"; path_prepend_ $initial_cwd_/src
-+print_ver_ $initial_cwd_/src/realpath
- stat_single=$(stat -c %d:%i /) || framework_failure_
- stat_double=$(stat -c %d:%i //) || framework_failure_
-@@ -40,68 +40,68 @@
+@@ -40,68 +40,68 @@ ln -s // two || framework_failure_
  ln -s /// three || framework_failure_
  
  # Basic operation
 -realpath -Pqz . >/dev/null || fail=1
 +$initial_cwd_/src/realpath -Pqz . >/dev/null || fail=1
  # Operand is required
--realpath >/dev/null && fail=1
--realpath --relative-base . --relative-to . && fail=1
--realpath --relative-base . && fail=1
-+$initial_cwd_/src/realpath >/dev/null && fail=1
-+$initial_cwd_/src/realpath --relative-base . --relative-to . && fail=1
-+$initial_cwd_/src/realpath --relative-base . && fail=1
+-returns_ 1 realpath >/dev/null || fail=1
+-returns_ 1 realpath --relative-base . --relative-to . || fail=1
+-returns_ 1 realpath --relative-base . || fail=1
++returns_ 1 $initial_cwd_/src/realpath >/dev/null || fail=1
++returns_ 1 $initial_cwd_/src/realpath --relative-base . --relative-to . || fail=1
++returns_ 1 $initial_cwd_/src/realpath --relative-base . || fail=1
  
  # -e --relative-* require directories
--realpath -e --relative-to=dir1/f --relative-base=. . && fail=1
+-returns_ 1 realpath -e --relative-to=dir1/f --relative-base=. . || fail=1
 -realpath -e --relative-to=dir1/  --relative-base=. . || fail=1
-+$initial_cwd_/src/realpath -e --relative-to=dir1/f --relative-base=. . && fail=1
++returns_ 1 $initial_cwd_/src/realpath -e --relative-to=dir1/f --relative-base=. . || fail=1
 +$initial_cwd_/src/realpath -e --relative-to=dir1/  --relative-base=. . || fail=1
  
  # Note NUL params are unconditionally rejected by canonicalize_filename_mode
--realpath -m '' && fail=1
--realpath --relative-base= --relative-to=. . && fail=1
-+$initial_cwd_/src/realpath -m '' && fail=1
-+$initial_cwd_/src/realpath --relative-base= --relative-to=. . && fail=1
+-returns_ 1 realpath -m '' || fail=1
+-returns_ 1 realpath --relative-base= --relative-to=. . || fail=1
++returns_ 1 $initial_cwd_/src/realpath -m '' || fail=1
++returns_ 1 $initial_cwd_/src/realpath --relative-base= --relative-to=. . || fail=1
  
  # symlink resolution
 -this=$(realpath .)
  if test $double_slash = //; then
    test "$out" = "/$nl//" || fail=1
  else
---- coreutils-8.21/tests/misc/nohup.sh~        2013-01-31 01:46:24.000000000 +0100
-+++ coreutils-8.21/tests/misc/nohup.sh 2013-12-03 13:35:51.952568924 +0100
-@@ -61,18 +61,18 @@
+--- coreutils-8.26/tests/misc/nohup.sh.orig    2017-02-08 09:53:48.584528406 +0000
++++ coreutils-8.26/tests/misc/nohup.sh 2017-02-08 09:55:18.087527399 +0000
+@@ -61,22 +61,22 @@
  
  # Bug present through coreutils 8.0: failure to print advisory message
  # to stderr must be fatal.  Requires stdout to be terminal.
 -if test -w /dev/full && test -c /dev/full; then
 -(
+-  # POSIX shells immediately exit the subshell on exec error.
+-  # So check we can write to /dev/tty before the exec, which
+-  # isn't possible if we've no controlling tty for example.
+-  test -c /dev/tty && >/dev/tty || exit 0
+-
 -  exec >/dev/tty
 -  test -t 1 || exit 0
--  nohup echo hi 2> /dev/full
--  test $? = 125 || fail=1
+-  returns_ 125 nohup echo hi 2> /dev/full || fail=1
 -  test -f nohup.out || fail=1
--  test -s nohup.out && fail=1
+-  compare /dev/null nohup.out || fail=1
 -  rm -f nohup.out
 -  exit $fail
 -) || fail=1
 -fi
 +#if test -w /dev/full && test -c /dev/full; then
 +#(
++#  # POSIX shells immediately exit the subshell on exec error.
++#  # So check we can write to /dev/tty before the exec, which
++#  # isn't possible if we've no controlling tty for example.
++#  test -c /dev/tty && >/dev/tty || exit 0
++#
 +#  exec >/dev/tty
 +#  test -t 1 || exit 0
-+#  nohup echo hi 2> /dev/full
-+#  test $? = 125 || fail=1
++#  returns_ 125 nohup echo hi 2> /dev/full || fail=1
 +#  test -f nohup.out || fail=1
-+#  test -s nohup.out && fail=1
++#  compare /dev/null nohup.out || fail=1
 +#  rm -f nohup.out
 +#  exit $fail
 +#) || fail=1
  EXTRA_DIST += nap.h test-futimens.h test-lutimens.h test-utimens.h test-utimens-common.h test-utimens.c macros.h
  
  ## end   gnulib module utimens-tests
+--- coreutils-8.23/tests/local.mk~     2015-01-04 16:12:22.000000000 +0000
++++ coreutils-8.23/tests/local.mk      2015-01-04 16:44:31.705861487 +0000
+@@ -163,7 +163,6 @@
+   tests/rm/cycle.sh                           \
+   tests/cp/link-heap.sh                               \
+   tests/cp/no-ctx.sh                          \
+-  tests/misc/tty-eof.pl                               \
+   tests/tail-2/inotify-hash-abuse.sh          \
+   tests/tail-2/inotify-hash-abuse2.sh         \
+   tests/tail-2/F-vs-missing.sh                        \
+@@ -339,7 +339,6 @@
+   tests/misc/sort-unique-segv.sh              \
+   tests/misc/sort-version.sh                  \
+   tests/misc/sort-NaN-infloop.sh              \
+-  tests/misc/sort-u-FMR.sh                    \
+   tests/split/filter.sh                               \
+   tests/split/suffix-auto-length.sh           \
+   tests/split/suffix-length.sh                        \
+@@ -468,7 +467,6 @@
+   tests/df/unreadable.sh                      \
+   tests/df/total-unprocessed.sh                       \
+   tests/df/no-mtab-status.sh                  \
+-  tests/df/skip-duplicates.sh                 \
+   tests/df/skip-rootfs.sh                     \
+   tests/dd/ascii.sh                           \
+   tests/dd/direct.sh                          \