]> TLD Linux GIT Repositories - packages/dracut.git/commitdiff
- don't link udevd as systemd-udevd
authorMarcin Krol <hawk@tld-linux.org>
Sat, 8 Aug 2015 21:47:06 +0000 (21:47 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 8 Aug 2015 21:47:06 +0000 (21:47 +0000)
dracut.spec
no_systemd_udevd.patch [new file with mode: 0644]

index 8d2bd9e446c0783873ff9f2f19f9250b08780c15..581d25538895baf498bac2d490f9712b6a2af7d8 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Initramfs generator using udev
 Summary(pl.UTF-8):     Generator initramfs wykorzystujący udev
 Name:          dracut
 Version:       043
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Base
 Source0:       https://www.kernel.org/pub/linux/utils/boot/dracut/%{name}-%{version}.tar.xz
@@ -18,6 +18,7 @@ Patch8:               xz_compressor.patch
 Patch9:                proc_sys_remount.patch
 Patch10:       misc_fixes.patch
 Patch11:       initrd-release.patch
+Patch12:       no_systemd_udevd.patch
 URL:           https://dracut.wiki.kernel.org/
 BuildRequires: asciidoc
 BuildRequires: dash
@@ -200,6 +201,7 @@ Bashowe dopełnianie składni dla polecenia dracut.
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 %{__sed} -i -e 's,@lib@,%{_lib},g' modules.d/50plymouth/module-setup.sh
 %{__sed} -i -e 's,@lib@,%{_lib},g' modules.d/95resume/module-setup.sh
diff --git a/no_systemd_udevd.patch b/no_systemd_udevd.patch
new file mode 100644 (file)
index 0000000..ebd33a1
--- /dev/null
@@ -0,0 +1,48 @@
+diff -ur dracut-043.orig/modules.d/40network/net-lib.sh dracut-043/modules.d/40network/net-lib.sh
+--- dracut-043.orig/modules.d/40network/net-lib.sh     2015-06-15 10:27:21.000000000 +0000
++++ dracut-043/modules.d/40network/net-lib.sh  2015-08-07 17:43:11.628527800 +0000
+@@ -39,7 +39,7 @@
+ configured_ifaces() {
+     local IFACES="" iface_id="" rv=1
+     [ -e "/tmp/net.ifaces" ] && read IFACES < /tmp/net.ifaces
+-    if { pidof udevd || pidof systemd-udevd; } > /dev/null; then
++    if { pidof udevd; } > /dev/null; then
+         for iface_id in $IFACES; do
+             echo $(iface_name $iface_id)
+             rv=0
+diff -ur dracut-043.orig/modules.d/95udev-rules/module-setup.sh dracut-043/modules.d/95udev-rules/module-setup.sh
+--- dracut-043.orig/modules.d/95udev-rules/module-setup.sh     2015-06-15 10:27:21.000000000 +0000
++++ dracut-043/modules.d/95udev-rules/module-setup.sh  2015-08-07 17:44:57.498527800 +0000
+@@ -12,19 +12,7 @@
+     inst_multiple -o /etc/udev/udev.conf
+     [ -d ${initdir}/$systemdutildir ] || mkdir -p ${initdir}/$systemdutildir
+-    for _i in ${systemdutildir}/systemd-udevd ${udevdir}/udevd /sbin/udevd; do
+-        [ -x "$_i" ] || continue
+-        inst "$_i"
+-
+-        if ! [[ -f  ${initdir}${systemdutildir}/systemd-udevd ]]; then
+-            ln -fs "$_i" ${initdir}${systemdutildir}/systemd-udevd
+-        fi
+-        break
+-    done
+-    if ! [[ -e ${initdir}${systemdutildir}/systemd-udevd ]]; then
+-        derror "Cannot find [systemd-]udevd binary!"
+-        exit 1
+-    fi
++    inst /sbin/udevd;
+     inst_rules \
+         50-firmware.rules \
+diff -ur dracut-043.orig/modules.d/99base/init.sh dracut-043/modules.d/99base/init.sh
+--- dracut-043.orig/modules.d/99base/init.sh   2015-08-07 17:01:00.000000000 +0000
++++ dracut-043/modules.d/99base/init.sh        2015-08-07 17:42:52.207527800 +0000
+@@ -143,7 +143,7 @@
+ getargbool 0 rd.udev.debug -d -y rdudevdebug && UDEV_LOG=debug
+ # start up udev and trigger cold plugs
+-UDEV_LOG=$UDEV_LOG $systemdutildir/systemd-udevd --daemon --resolve-names=never
++UDEV_LOG=$UDEV_LOG /sbin/udevd --daemon --resolve-names=never
+ UDEV_QUEUE_EMPTY="udevadm settle --timeout=0"