]> TLD Linux GIT Repositories - packages/gcc.git/blobdiff - branch.sh
- fixed branch.diff, bug-111413.patch already in branch.diff
[packages/gcc.git] / branch.sh
index 7cc296844c0a0f1cec4e13c6b4e85f6d818da045..28866e8ed3b71708a7bc3eabeec61366a831d86b 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -1,23 +1,25 @@
 #!/bin/sh
 set -e
+url=git://gcc.gnu.org/git/gcc.git
 package=gcc
-svn=svn://gcc.gnu.org/svn/$package
-branch=branches/$package-7-branch
-tag=tags/${package}_7_2_0_release
+tag=releases/gcc-13.2.0
+branch=releases/gcc-13
 out=$package-branch.diff
+repo=$package.git
 
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
-       # remove revno's for smaller diffs
-       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
+       cat
 }
 
-old=$svn/$tag
-new=$svn/$branch
-echo >&2 "Running diff: $old -> $new"
-LC_ALL=C svn diff -x --ignore-eol-style --force --old=$old --new=$new > $out.svn.tmp
-filter < $out.svn.tmp > $out.tmp
-rm -f $out.svn.tmp
+if [ ! -d $repo ]; then
+       git clone --bare $url -b $branch $repo
+fi
+
+cd $repo
+       git fetch origin +$branch:$branch +refs/tags/$tag:refs/tags/$tag
+       git log -p --reverse $tag..$branch ":(exclude)doc/doc-*" ":(exclude)test" ":(exclude).*" | filter > ../$out.tmp
+cd ..
 
 if cmp -s $out{,.tmp}; then
        echo >&2 "No new diffs..."
@@ -25,3 +27,6 @@ if cmp -s $out{,.tmp}; then
        exit 0
 fi
 mv -f $out{.tmp,}
+
+../md5 $package.spec
+../dropin $out