]> TLD Linux GIT Repositories - packages/gcc.git/blobdiff - gcc-nodebug.patch
- fixed branch.diff, bug-111413.patch already in branch.diff
[packages/gcc.git] / gcc-nodebug.patch
index 934fcaa011a05c15e78e1ce11ef8f4d6a28cc73a..7cca63616cbdff2b69cbd5a55548e09427849561 100644 (file)
@@ -1,5 +1,31 @@
---- gcc-4.7.1/gcc/ada/gcc-interface/Makefile.in.orig   2012-07-10 17:33:42.146462985 +0200
-+++ gcc-4.7.1/gcc/ada/gcc-interface/Makefile.in        2012-07-12 18:27:21.682409479 +0200
+diff -urNp -x '*.orig' gcc-10.2.0.org/Makefile.in gcc-10.2.0/Makefile.in
+--- gcc-10.2.0.org/Makefile.in 2020-07-23 08:35:16.912379792 +0200
++++ gcc-10.2.0/Makefile.in     2021-03-21 01:23:21.870335808 +0100
+@@ -373,7 +373,7 @@ BUILD_PREFIX_1 = @BUILD_PREFIX_1@
+ # Flags to pass to stage2 and later makes.  They are defined
+ # here so that they can be overridden by Makefile fragments.
+-BOOT_CFLAGS= -g -O2
++BOOT_CFLAGS= -O2
+ BOOT_LDFLAGS=
+ BOOT_ADAFLAGS= -gnatpg
+@@ -619,9 +619,9 @@ CXXFLAGS_FOR_TARGET = @CXXFLAGS_FOR_TARG
+ LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
+ LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
+ LDFLAGS_FOR_TARGET = @LDFLAGS_FOR_TARGET@
+-GM2FLAGS_FOR_TARGET = -O2 -g
+-GOCFLAGS_FOR_TARGET = -O2 -g
+-GDCFLAGS_FOR_TARGET = -O2 -g
++GM2FLAGS_FOR_TARGET = -O2
++GOCFLAGS_FOR_TARGET = -O2
++GDCFLAGS_FOR_TARGET = -O2
+ FLAGS_FOR_TARGET = @FLAGS_FOR_TARGET@
+ SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gcc-interface/Makefile.in gcc-10.2.0/gcc/ada/gcc-interface/Makefile.in
+--- gcc-10.2.0.org/gcc/ada/gcc-interface/Makefile.in   2020-07-23 08:35:17.112381997 +0200
++++ gcc-10.2.0/gcc/ada/gcc-interface/Makefile.in       2021-03-21 01:23:21.859335808 +0100
 @@ -66,7 +66,7 @@
  # CFLAGS is for the user to override to, e.g., do a bootstrap with -O2.
  # BOOT_CFLAGS is the value of CFLAGS to pass
  BOOT_CFLAGS = -O $(CFLAGS)
  # These exists to be overridden by the t-* files, respectively.
  T_CFLAGS =
-@@ -105,11 +105,11 @@
+@@ -105,13 +105,13 @@ TEXI2PDF = texi2pdf
  GNATBIND_FLAGS = -static -x
  ADA_CFLAGS =
- ADAFLAGS = -W -Wall -gnatpg -gnata
+ ADAFLAGS = -W -Wall -gnatpg -gnata -gnatU
 -FORCE_DEBUG_ADAFLAGS = -g
 +FORCE_DEBUG_ADAFLAGS =
+ NO_INLINE_ADAFLAGS = -fno-inline
+ NO_OMIT_ADAFLAGS = -fno-omit-frame-pointer
  NO_SIBLING_ADAFLAGS = -fno-optimize-sibling-calls
  NO_REORDER_ADAFLAGS = -fno-toplevel-reorder
- GNATLIBFLAGS = -W -Wall -gnatpg -nostdinc
+ GNATLIBFLAGS = -W -Wall -gnatg -nostdinc
 -GNATLIBCFLAGS = -g -O2
 +GNATLIBCFLAGS = -O2
- PICFLAG_FOR_TARGET = @PICFLAG_FOR_TARGET@
  # Pretend that _Unwind_GetIPInfo is available for the target by default.  This
-@@ -2755,7 +2755,7 @@
-       cd $(RTSDIR) && \
-       ../../gnatsym -s SYMVEC_$$$$.opt \
-       $(LIBGNAT_OBJS) $(GNATRTL_NONTASKING_OBJS) && \
--      ../../xgcc -g -B../../ -shared -shared-libgcc \
-+      ../../xgcc -B../../ -shared -shared-libgcc \
-          -o libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) libgnat.a \
-          sys\$$library:trace.exe \
-          --for-linker=/noinform \
-@@ -2764,7 +2764,7 @@
-       cd $(RTSDIR) && \
-       ../../gnatsym -s SYMVEC_$$$$.opt \
-       $(GNATRTL_TASKING_OBJS) && \
--      ../../xgcc -g -B../../ -shared -shared-libgcc \
-+      ../../xgcc -B../../ -shared -shared-libgcc \
-          -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
-          libgnarl.a libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
-          sys\$$library:trace.exe \
---- gcc-4.7.1/libada/Makefile.in.orig  2012-06-12 17:12:37.000000000 +0200
-+++ gcc-4.7.1/libada/Makefile.in       2012-07-12 18:27:53.482408144 +0200
-@@ -59,7 +59,7 @@
+ # should be autodetected during the configuration of libada and passed down to
+ # here, but we need something for --disable-libada and hope for the best.
+diff -urNp -x '*.orig' gcc-10.2.0.org/libada/Makefile.in gcc-10.2.0/libada/Makefile.in
+--- gcc-10.2.0.org/libada/Makefile.in  2020-07-23 08:35:18.684399314 +0200
++++ gcc-10.2.0/libada/Makefile.in      2021-03-21 01:23:21.859335808 +0100
+@@ -61,7 +61,7 @@ LDFLAGS=
  CFLAGS=-g
  PICFLAG = @PICFLAG@
  GNATLIBFLAGS= -W -Wall -gnatpg -nostdinc
 -GNATLIBCFLAGS= -g -O2
 +GNATLIBCFLAGS= -O2
- GNATLIBCFLAGS_FOR_C = -W -Wall $(GNATLIBCFLAGS) \
-       -fexceptions -DIN_RTS @have_getipinfo@
---- gcc-4.7.1/libffi/Makefile.am.orig  2012-02-27 11:00:12.000000000 +0100
-+++ gcc-4.7.1/libffi/Makefile.am       2012-07-12 18:28:20.115740360 +0200
-@@ -168,7 +168,7 @@
- libffi_convenience_la_SOURCES = $(libffi_la_SOURCES)
- nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
+ GNATLIBCFLAGS_FOR_C = -W -Wall $(GNATLIBCFLAGS) $(CFLAGS_FOR_TARGET) \
+       -fexceptions -DIN_RTS @have_getipinfo@ @have_capability@
  
--AM_CFLAGS = -Wall -g -fexceptions
-+AM_CFLAGS = -Wall -fexceptions
+diff -urNp -x '*.orig' gcc-10.2.0.org/libffi/Makefile.am gcc-10.2.0/libffi/Makefile.am
+--- gcc-10.2.0.org/libffi/Makefile.am  2020-07-23 08:35:18.736399887 +0200
++++ gcc-10.2.0/libffi/Makefile.am      2021-03-21 01:23:21.859335808 +0100
+@@ -182,7 +182,7 @@ nodist_libffi_convenience_la_SOURCES = $
  
  LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
  
---- gcc-4.7.1/libffi/Makefile.in.orig  2012-06-14 10:48:08.000000000 +0200
-+++ gcc-4.7.1/libffi/Makefile.in       2012-07-12 18:28:35.029073067 +0200
-@@ -475,7 +475,7 @@
-       $(am__append_24) $(am__append_25)
- libffi_convenience_la_SOURCES = $(libffi_la_SOURCES)
+-AM_CFLAGS = -Wall -g -fexceptions $(CET_FLAGS)
++AM_CFLAGS = -Wall -fexceptions $(CET_FLAGS)
+ if FFI_DEBUG
+ # Build debug. Define FFI_DEBUG on the commandline so that, when building with
+ # MSVC, it can link against the debug CRT.
+diff -urNp -x '*.orig' gcc-10.2.0.org/libffi/Makefile.in gcc-10.2.0/libffi/Makefile.in
+--- gcc-10.2.0.org/libffi/Makefile.in  2020-07-23 08:35:54.708796179 +0200
++++ gcc-10.2.0/libffi/Makefile.in      2021-03-21 01:23:21.860335808 +0100
+@@ -589,7 +589,7 @@ libffi_convenience_la_LIBADD = $(libffi_
+ libffi_convenience_la_DEPENDENCIES = $(libffi_la_DEPENDENCIES)
  nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
--AM_CFLAGS = -Wall -g -fexceptions
-+AM_CFLAGS = -Wall -fexceptions
  LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
- libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version` $(LTLDFLAGS) $(AM_LTLDFLAGS)
- AM_CPPFLAGS = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src
---- gcc-4.7.1/libgcc/Makefile.in.orig  2012-05-24 16:59:38.000000000 +0200
-+++ gcc-4.7.1/libgcc/Makefile.in       2012-07-12 18:28:59.042405393 +0200
-@@ -221,7 +221,7 @@
+-AM_CFLAGS = -Wall -g -fexceptions $(CET_FLAGS) $(am__append_2)
++AM_CFLAGS = -Wall -fexceptions $(CET_FLAGS) $(am__append_2)
+ @LIBFFI_BUILD_VERSIONED_SHLIB_FALSE@libffi_version_script = 
+ @LIBFFI_BUILD_VERSIONED_SHLIB_GNU_TRUE@@LIBFFI_BUILD_VERSIONED_SHLIB_TRUE@libffi_version_script = -Wl,--version-script,libffi.map
+ @LIBFFI_BUILD_VERSIONED_SHLIB_SUN_TRUE@@LIBFFI_BUILD_VERSIONED_SHLIB_TRUE@libffi_version_script = -Wl,-M,libffi.map-sun
+diff -urNp -x '*.orig' gcc-10.2.0.org/libgcc/Makefile.in gcc-10.2.0/libgcc/Makefile.in
+--- gcc-10.2.0.org/libgcc/Makefile.in  2020-07-23 08:35:18.748400018 +0200
++++ gcc-10.2.0/libgcc/Makefile.in      2021-03-21 01:23:21.860335808 +0100
+@@ -243,7 +243,7 @@ endif
  
  # Options to use when compiling libgcc2.a.
  #
  LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(HOST_LIBGCC2_CFLAGS) \
                 $(LIBGCC2_DEBUG_CFLAGS) -DIN_LIBGCC2 \
                 -fbuilding-libgcc -fno-stack-protector \
---- gcc-4.7.1/libjava/classpath/tools/Makefile.am.orig 2011-09-29 13:37:47.000000000 +0200
-+++ gcc-4.7.1/libjava/classpath/tools/Makefile.am      2012-07-12 18:29:33.452403949 +0200
-@@ -355,8 +355,8 @@
- if JAVA_MAINTAINER_MODE
- ## Compile ASM separately as it is latin-1 encoded.
-       AC=`echo $(JCOMPILER) | sed -e 's/UTF-8/ISO-8859-1/g'`; \
--        $$AC -g -w -d $(srcdir)/asm @asm.lst
--      $(JCOMPILER) $(USE_JAVAC_FLAGS) -g -d $(srcdir)/classes @classes.lst @vm-tools.lst
-+        $$AC -w -d $(srcdir)/asm @asm.lst
-+      $(JCOMPILER) $(USE_JAVAC_FLAGS) -d $(srcdir)/classes @classes.lst @vm-tools.lst
- endif
- ## END GCJ LOCAL
- ## Copy over tools resource files.
---- gcc-4.7.1/libjava/classpath/tools/Makefile.in.orig 2011-09-29 13:37:47.000000000 +0200
-+++ gcc-4.7.1/libjava/classpath/tools/Makefile.in      2012-07-12 18:29:52.035736502 +0200
-@@ -1413,8 +1413,8 @@
-       fi
-       cat classes.lst asm.lst vm-tools.lst > all-classes.lst
- @JAVA_MAINTAINER_MODE_TRUE@   AC=`echo $(JCOMPILER) | sed -e 's/UTF-8/ISO-8859-1/g'`; \
--@JAVA_MAINTAINER_MODE_TRUE@     $$AC -g -w -d $(srcdir)/asm @asm.lst
--@JAVA_MAINTAINER_MODE_TRUE@   $(JCOMPILER) $(USE_JAVAC_FLAGS) -g -d $(srcdir)/classes @classes.lst @vm-tools.lst
-+@JAVA_MAINTAINER_MODE_TRUE@     $$AC -w -d $(srcdir)/asm @asm.lst
-+@JAVA_MAINTAINER_MODE_TRUE@   $(JCOMPILER) $(USE_JAVAC_FLAGS) -d $(srcdir)/classes @classes.lst @vm-tools.lst
-       @list=`cd $(srcdir)/resource && find gnu/classpath/tools com/sun/tools/javac \
-              sun/rmi/rmic $(GJDOC_EX) -name \*.properties -print -o -name \*.jav -print`; \
-       for p in $$list; do \
---- gcc-4.7.1/libjava/Makefile.am.orig 2011-08-05 16:37:48.000000000 +0200
-+++ gcc-4.7.1/libjava/Makefile.am      2012-07-12 18:30:07.649069180 +0200
-@@ -399,7 +399,7 @@
- ## Extra CFLAGS used for JNI C sources shared with GNU Classpath.
- PEDANTIC_CFLAGS = -ansi -pedantic -Wall -Wno-long-long
--JCFLAGS = -g
-+JCFLAGS =
- JC1FLAGS = @LIBGCJ_JAVAFLAGS@ $(GCJFLAGS)
- LIBFFIINCS = @LIBFFIINCS@
---- gcc-4.7.1/libjava/Makefile.in.orig 2012-06-14 10:48:08.000000000 +0200
-+++ gcc-4.7.1/libjava/Makefile.in      2012-07-12 18:30:20.642401968 +0200
-@@ -1032,7 +1032,7 @@
- @BUILD_LIBGCJ_REDUCED_REFLECTION_FALSE@LIBGCJ_REDUCED_REFLECTION_FLAGS = 
- @BUILD_LIBGCJ_REDUCED_REFLECTION_TRUE@LIBGCJ_REDUCED_REFLECTION_FLAGS = -freduced-reflection
- PEDANTIC_CFLAGS = -ansi -pedantic -Wall -Wno-long-long
--JCFLAGS = -g
-+JCFLAGS =
- JC1FLAGS = @LIBGCJ_JAVAFLAGS@ $(GCJFLAGS)
- AM_CPPFLAGS = -I$(top_srcdir) \
-       -Iinclude -I$(top_srcdir)/include \
---- gcc-4.7.1/libjava/testsuite/Makefile.am.orig       2010-05-04 00:37:50.000000000 +0200
-+++ gcc-4.7.1/libjava/testsuite/Makefile.am    2012-07-12 18:30:54.965733863 +0200
-@@ -83,11 +83,11 @@
-         testtmpdir=`echo $$test | sed -e 's,/,_,g'`T; \
-         rm -rf $$testtmpdir; $(mkdir_p) $$testtmpdir; \
-         if test -n "$$testdep"; then \
--          $(GCJ) -C -g -w --encoding=UTF-8 -bootclasspath \
-+          $(GCJ) -C -w --encoding=UTF-8 -bootclasspath \
-             $(top_builddir)/libgcj-$(gcc_version).jar::$$testtmpdir \
-             -d $$testtmpdir $(srcdir)/$$testdep || exit; \
-         fi; \
--        $(GCJ) -C -g -w --encoding=UTF-8 -bootclasspath \
-+        $(GCJ) -C -w --encoding=UTF-8 -bootclasspath \
-           $(top_builddir)/libgcj-$(gcc_version).jar:$$testtmpdir \
-           -d $$testtmpdir $(srcdir)/$$test || exit; \
-         case "$$test" in \
---- gcc-4.7.1/libjava/testsuite/Makefile.in.orig       2012-05-21 20:14:01.000000000 +0200
-+++ gcc-4.7.1/libjava/testsuite/Makefile.in    2012-07-12 18:31:09.359066590 +0200
-@@ -569,11 +569,11 @@
- @JAVA_MAINTAINER_MODE_TRUE@     testtmpdir=`echo $$test | sed -e 's,/,_,g'`T; \
- @JAVA_MAINTAINER_MODE_TRUE@     rm -rf $$testtmpdir; $(mkdir_p) $$testtmpdir; \
- @JAVA_MAINTAINER_MODE_TRUE@     if test -n "$$testdep"; then \
--@JAVA_MAINTAINER_MODE_TRUE@       $(GCJ) -C -g -w --encoding=UTF-8 -bootclasspath \
-+@JAVA_MAINTAINER_MODE_TRUE@       $(GCJ) -C -w --encoding=UTF-8 -bootclasspath \
- @JAVA_MAINTAINER_MODE_TRUE@         $(top_builddir)/libgcj-$(gcc_version).jar::$$testtmpdir \
- @JAVA_MAINTAINER_MODE_TRUE@         -d $$testtmpdir $(srcdir)/$$testdep || exit; \
- @JAVA_MAINTAINER_MODE_TRUE@     fi; \
--@JAVA_MAINTAINER_MODE_TRUE@     $(GCJ) -C -g -w --encoding=UTF-8 -bootclasspath \
-+@JAVA_MAINTAINER_MODE_TRUE@     $(GCJ) -C -w --encoding=UTF-8 -bootclasspath \
- @JAVA_MAINTAINER_MODE_TRUE@       $(top_builddir)/libgcj-$(gcc_version).jar:$$testtmpdir \
- @JAVA_MAINTAINER_MODE_TRUE@       -d $$testtmpdir $(srcdir)/$$test || exit; \
- @JAVA_MAINTAINER_MODE_TRUE@     case "$$test" in \
---- gcc-4.7.1/libstdc++-v3/include/Makefile.am.orig    2012-03-23 12:00:54.000000000 +0100
-+++ gcc-4.7.1/libstdc++-v3/include/Makefile.am 2012-07-12 18:31:29.102399096 +0200
-@@ -1154,22 +1154,22 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libstdc++-v3/include/Makefile.am gcc-10.2.0/libstdc++-v3/include/Makefile.am
+--- gcc-10.2.0.org/libstdc++-v3/include/Makefile.am    2021-03-21 01:22:56.853335808 +0100
++++ gcc-10.2.0/libstdc++-v3/include/Makefile.am        2021-03-21 01:23:21.861335808 +0100
+@@ -1343,22 +1343,22 @@ ${host_builddir}/gthr-default.h: ${tople
  # Build two precompiled C++ includes, stdc++.h.gch/*.gch
  ${pch1a_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
        -mkdir -p ${pch1_output_builddir}
 -      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch3_source} -o $@
 +      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 ${pch3_source} -o $@
  
- # For robustness sake (in light of junk files or in-source
- # configuration), copy from the build or source tree to the install
---- gcc-4.7.1/libstdc++-v3/include/Makefile.in.orig    2012-03-23 12:00:54.000000000 +0100
-+++ gcc-4.7.1/libstdc++-v3/include/Makefile.in 2012-07-12 18:31:43.922398474 +0200
-@@ -1543,22 +1543,22 @@
+ # The real deal.
+ install-data-local: install-headers
+diff -urNp -x '*.orig' gcc-10.2.0.org/libstdc++-v3/include/Makefile.in gcc-10.2.0/libstdc++-v3/include/Makefile.in
+--- gcc-10.2.0.org/libstdc++-v3/include/Makefile.in    2021-03-21 01:22:56.854335808 +0100
++++ gcc-10.2.0/libstdc++-v3/include/Makefile.in        2021-03-21 01:23:21.861335808 +0100
+@@ -1821,22 +1821,22 @@ ${host_builddir}/gthr-default.h: ${tople
  # Build two precompiled C++ includes, stdc++.h.gch/*.gch
  ${pch1a_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
        -mkdir -p ${pch1_output_builddir}
 -      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch3_source} -o $@
 +      $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 ${pch3_source} -o $@
  
- # For robustness sake (in light of junk files or in-source
- # configuration), copy from the build or source tree to the install
---- gcc-4.7.1/Makefile.in.orig 2012-05-16 17:54:24.000000000 +0200
-+++ gcc-4.7.1/Makefile.in      2012-07-12 18:32:07.075730835 +0200
-@@ -364,7 +364,7 @@
- # Flags to pass to stage2 and later makes.  They are defined
- # here so that they can be overridden by Makefile fragments.
--BOOT_CFLAGS= -g -O2
-+BOOT_CFLAGS= -O2
- BOOT_LDFLAGS=
- BOOT_ADAFLAGS=-gnatpg -gnata
-@@ -574,7 +574,7 @@
- LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
- LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
- LDFLAGS_FOR_TARGET = @LDFLAGS_FOR_TARGET@
--GOCFLAGS_FOR_TARGET = -O2 -g
-+GOCFLAGS_FOR_TARGET = -O2
- FLAGS_FOR_TARGET = @FLAGS_FOR_TARGET@
- SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
+ # The real deal.
+ install-data-local: install-headers