]> TLD Linux GIT Repositories - packages/gcc.git/blobdiff - gcc.spec
- updated to 4.8.5
[packages/gcc.git] / gcc.spec
index d8c45e050ff6db4243c02581a4fec45496b48109..f9c89a9a267364b17ef95259a7eeafedd1bfae9b 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
 # - libgcj options:
 %bcond_without alsa            # don't build libgcj ALSA MIDI interface
 %bcond_without dssi            # don't build libgcj DSSI MIDI interface
-%bcond_without gtk             # don't build libgcj GTK peer
-%bcond_without apidocs         # do not build and package API docs
+%bcond_with    gtk             # build libgcj GTK peer
+%bcond_with    apidocs         # build and package API docs
 %bcond_with    mozilla         # build libgcjwebplugin (needs fix for new xulrunner)
 %bcond_with    qt              # build libgcj Qt peer (currently doesn't build with libtool-2.x)
-%bcond_without x               # don't build libgcj Xlib-dependent AWTs (incl. GTK/Qt)
+%bcond_with    x               # build libgcj Xlib-dependent AWTs (incl. GTK/Qt)
 # - other:
 %bcond_without bootstrap       # omit 3-stage bootstrap
 %bcond_with    tests           # torture gcc
@@ -82,7 +82,7 @@
 %endif
 
 %define                major_ver       4.8
-%define                minor_ver       3
+%define                minor_ver       5
 %define                major_ecj_ver   4.5
 # class data version seen with file(1) that this jvm is able to load
 %define                _classdataversion 50.0
@@ -94,12 +94,12 @@ Summary(pl.UTF-8):  Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       1
+Release:       4
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 7c60f24fab389f77af203d2516ee110f
+# Source0-md5: 80d2c2982a3392bb0b89673ff136e223
 Source1:       %{name}-optimize-la.pl
 Source2:       ftp://sourceware.org/pub/java/ecj-%{major_ecj_ver}.jar
 # Source2-md5: d7cd6a27c8801e66cbaa964a039ecfdb
@@ -113,7 +113,8 @@ Patch2:             %{name}-nodebug.patch
 Patch3:                %{name}-ada-link.patch
 Patch4:                %{name}-libjava-multilib.patch
 Patch5:                %{name}-enable-java-awt-qt.patch
-Patch6:        %{name}-install-libffi.patch
+Patch6:                %{name}-install-libffi.patch
+Patch100:      %{name}-branch.diff
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf >= 2.64
 %{?with_tests:BuildRequires:   autogen}
@@ -142,8 +143,7 @@ BuildRequires:      glibc-devel(ix86)
 %endif
 BuildRequires: gmp-c++-devel >= 4.1
 BuildRequires: gmp-devel >= 4.1
-BuildRequires: isl-devel >= 0.10
-BuildRequires: isl-devel < 0.13
+BuildRequires: isl-devel >= 0.13
 BuildRequires: libmpc-devel
 BuildRequires: mpfr-devel >= 2.3.0
 BuildRequires: ppl-devel >= 0.11
@@ -1678,6 +1678,7 @@ Ten pakiet zawiera 32-bitową wersję statycznej biblioteki GNU Atomic.
 %if %{with gcc_libffi}
 %patch6 -p0
 %endif
+%patch100 -p0
 
 mv ChangeLog ChangeLog.general