]> TLD Linux GIT Repositories - packages/gcc.git/commitdiff
- rediffed, release 3
authorMarcin Krol <hawk@tld-linux.org>
Sun, 21 Mar 2021 11:24:08 +0000 (12:24 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Sun, 21 Mar 2021 11:24:08 +0000 (12:24 +0100)
gcc-ada-link.patch
gcc-info.patch
gcc-moresparcs.patch
gcc-nodebug.patch
gcc.spec

index 240790ad474bb6000d076441070696e12534c37a..acb31939e1db9700bb046aaf0050382af157e85d 100644 (file)
@@ -1,22 +1,7 @@
---- a/gcc/ada/link.c   2004-09-13 12:18:40.000000000 +0200
-+++ b/gcc/ada/link.c   2004-09-26 12:24:29.079704096 +0200
-@@ -157,10 +157,10 @@
- #elif defined (linux) || defined(__GLIBC__)
- const char *__gnat_object_file_option = "-Wl,@";
--const char *__gnat_run_path_option = "-Wl,-rpath,";
-+const char *__gnat_run_path_option = "";
- char __gnat_shared_libgnat_default = STATIC;
--char __gnat_shared_libgcc_default = STATIC;
--int __gnat_link_max = 8192;
-+char __gnat_shared_libgcc_default = SHARED;
-+int __gnat_link_max = 131072;
- unsigned char __gnat_objlist_file_supported = 1;
- const char *__gnat_object_library_extension = ".a";
- unsigned char __gnat_separate_run_path_options = 0;
---- a/gcc/ada/gcc-interface/Makefile.in        2005-05-26 10:48:40.000000000 +0000
-+++ b/gcc/ada/gcc-interface/Makefile.in        2005-05-26 10:59:25.000000000 +0000
-@@ -126,7 +126,7 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gcc-interface/Makefile.in gcc-10.2.0/gcc/ada/gcc-interface/Makefile.in
+--- gcc-10.2.0.org/gcc/ada/gcc-interface/Makefile.in   2021-03-21 01:36:19.711335808 +0100
++++ gcc-10.2.0/gcc/ada/gcc-interface/Makefile.in       2021-03-21 01:36:41.726335808 +0100
+@@ -128,7 +128,7 @@ OUTPUT_OPTION = -o $@
  objext = .o
  exeext =
  arext  = .a
@@ -25,7 +10,7 @@
  shext  =
  hyphen = -
  
-@@ -210,7 +210,7 @@
+@@ -198,7 +198,7 @@ RTSDIR = rts$(subst /,_,$(MULTISUBDIR))
  # Link flags used to build gnat tools.  By default we prefer to statically
  # link with libgcc to avoid a dependency on shared libgcc (which is tricky
  # to deal with as it may conflict with the libgcc provided by the system).
  
  # End of variables for you to override.
  
-@@ -2489,7 +2489,8 @@
-               -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
-               $(GNATRTL_TASKING_OBJS) \
-               $(SO_OPTS)libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
--              $(THREADSLIB)
-+              $(THREADSLIB) \
-+              ./libgnat-$(LIBRARY_VERSION)$(soext)
-       cd $(RTSDIR); $(LN_S) libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
-               libgnat$(soext)
-       cd $(RTSDIR); $(LN_S) libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
---- a/gcc/ada/gcc-interface/Makefile.in~       2014-07-16 18:43:51.000000000 +0200
-+++ b/gcc/ada/gcc-interface/Makefile.in        2014-07-16 18:46:09.555516586 +0200
-@@ -2811,14 +2811,14 @@
+@@ -657,19 +657,20 @@ gnatlib-shared-default:
               gnatlib
        $(RM) $(RTSDIR)/libgna*$(soext)
        cd $(RTSDIR); `echo "$(GCC_FOR_TARGET)" \
                $(PICFLAG_FOR_TARGET) \
                -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(GNATRTL_TASKING_OBJS) \
+               $(SO_OPTS)libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
+-              $(THREADSLIB)
++              $(THREADSLIB) \
++              ./libgnat-$(LIBRARY_VERSION)$(soext)
+       cd $(RTSDIR); $(LN_S) libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
+               libgnat$(soext)
+       cd $(RTSDIR); $(LN_S) libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/link.c gcc-10.2.0/gcc/ada/link.c
+--- gcc-10.2.0.org/gcc/ada/link.c      2020-07-23 08:35:17.200382966 +0200
++++ gcc-10.2.0/gcc/ada/link.c  2021-03-21 01:36:41.725335808 +0100
+@@ -129,10 +129,10 @@ const char *__gnat_default_libgcc_subdir
+ #elif defined (__linux__) || defined (__GLIBC__)
+ const char *__gnat_object_file_option = "-Wl,@";
+-const char *__gnat_run_path_option = "-Wl,-rpath,";
++const char *__gnat_run_path_option = "";
+ char __gnat_shared_libgnat_default = STATIC;
+-char __gnat_shared_libgcc_default = STATIC;
+-int __gnat_link_max = 8192;
++char __gnat_shared_libgcc_default = SHARED;
++int __gnat_link_max = 131072;
+ unsigned char __gnat_objlist_file_supported = 1;
+ const char *__gnat_object_library_extension = ".a";
+ unsigned char __gnat_separate_run_path_options = 0;
index a363f06d07126f7cdefa48320409a8e725e29b8f..e8c7086d46561124be448cbcc518799103a0350f 100644 (file)
@@ -1,6 +1,52 @@
---- a/gcc/doc/cpp.texi 2004-09-17 10:22:36.000000000 +0200
-+++ b/gcc/doc/cpp.texi 2004-09-26 10:58:58.166721432 +0200
-@@ -50,9 +50,9 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gnat-style.texi gcc-10.2.0/gcc/ada/gnat-style.texi
+--- gcc-10.2.0.org/gcc/ada/gnat-style.texi     2020-07-23 08:35:17.120382083 +0200
++++ gcc-10.2.0/gcc/ada/gnat-style.texi 2021-03-21 01:21:39.481335808 +0100
+@@ -29,9 +29,9 @@ Texts.  A copy of the license is include
+ @include gcc-common.texi
+-@dircategory Software development
++@dircategory Programming Languages:
+ @direntry
+-* gnat-style: (gnat-style).      GNAT Coding Style
++* gnat-style: (gnat-style).           GNAT Coding Style
+ @end direntry
+ @macro syntax{element}
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gnat_rm.texi gcc-10.2.0/gcc/ada/gnat_rm.texi
+--- gcc-10.2.0.org/gcc/ada/gnat_rm.texi        2020-07-23 08:35:17.128382173 +0200
++++ gcc-10.2.0/gcc/ada/gnat_rm.texi    2021-03-21 01:21:39.485335808 +0100
+@@ -10,9 +10,9 @@
+ @paragraphindent 0
+ @exampleindent 4
+ @finalout
+-@dircategory GNU Ada Tools 
++@dircategory Programming Languages:
+ @direntry
+-* gnat_rm: (gnat_rm.info). gnat_rm
++* gnat_rm: (gnat_rm.info).            gnat_rm
+ @end direntry
+ @definfoenclose strong,`,'
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gnat_ugn.texi gcc-10.2.0/gcc/ada/gnat_ugn.texi
+--- gcc-10.2.0.org/gcc/ada/gnat_ugn.texi       2020-07-23 08:35:17.136382261 +0200
++++ gcc-10.2.0/gcc/ada/gnat_ugn.texi   2021-03-21 01:21:39.489335808 +0100
+@@ -10,9 +10,9 @@
+ @paragraphindent 0
+ @exampleindent 4
+ @finalout
+-@dircategory GNU Ada Tools 
++@dircategory Programming Languages:
+ @direntry
+-* gnat_ugn: (gnat_ugn.info). gnat_ugn
++* gnat_ugn: (gnat_ugn.info).          gnat_ugn
+ @end direntry
+ @definfoenclose strong,`,'
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/cpp.texi gcc-10.2.0/gcc/doc/cpp.texi
+--- gcc-10.2.0.org/gcc/doc/cpp.texi    2021-03-21 01:21:06.752335808 +0100
++++ gcc-10.2.0/gcc/doc/cpp.texi        2021-03-21 01:21:39.480335808 +0100
+@@ -48,9 +48,9 @@ This manual contains no Invariant Sectio
  @set cppmanual
  
  @ifinfo
  @end direntry
  @end ifinfo
  
---- a/gcc/doc/cppinternals.texi        2004-07-03 01:57:11.000000000 +0200
-+++ b/gcc/doc/cppinternals.texi        2004-09-26 10:58:58.208715048 +0200
-@@ -3,9 +3,9 @@
- @settitle The GNU C Preprocessor Internals
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/cppinternals.texi gcc-10.2.0/gcc/doc/cppinternals.texi
+--- gcc-10.2.0.org/gcc/doc/cppinternals.texi   2020-07-23 08:35:17.560386932 +0200
++++ gcc-10.2.0/gcc/doc/cppinternals.texi       2021-03-21 01:21:39.481335808 +0100
+@@ -5,9 +5,9 @@
+ @include gcc-common.texi
  
  @ifinfo
 -@dircategory Software development
@@ -26,8 +73,9 @@
  @end direntry
  @end ifinfo
  
---- a/gcc/doc/gcc.texi 2004-07-22 22:12:20.000000000 +0200
-+++ b/gcc/doc/gcc.texi 2004-09-26 10:58:58.218713528 +0200
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/gcc.texi gcc-10.2.0/gcc/doc/gcc.texi
+--- gcc-10.2.0.org/gcc/doc/gcc.texi    2020-07-23 08:35:17.564386975 +0200
++++ gcc-10.2.0/gcc/doc/gcc.texi        2021-03-21 01:21:39.481335808 +0100
 @@ -61,15 +61,14 @@ Texts being (a) (see below), and with th
       funds for GNU development.
  @end copying
  @end direntry
  This file documents the use of the GNU compilers.
  @sp 1
---- a/gcc/doc/gccint.texi      2004-05-24 00:54:29.000000000 +0200
-+++ b/gcc/doc/gccint.texi      2004-09-26 10:58:58.222712920 +0200
-@@ -46,9 +46,9 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/gccint.texi gcc-10.2.0/gcc/doc/gccint.texi
+--- gcc-10.2.0.org/gcc/doc/gccint.texi 2020-07-23 08:35:17.564386975 +0200
++++ gcc-10.2.0/gcc/doc/gccint.texi     2021-03-21 01:21:39.481335808 +0100
+@@ -47,9 +47,9 @@ Texts being (a) (see below), and with th
       funds for GNU development.
  @end copying
  @ifnottex
  @end direntry
  This file documents the internals of the GNU compilers.
  @sp 1
---- a/gcc/ada/gnat-style.texi  2004-09-01 13:51:52.000000000 +0200
-+++ b/gcc/ada/gnat-style.texi  2004-09-26 10:58:58.342694680 +0200
-@@ -28,9 +28,9 @@
- @setchapternewpage odd
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/doc/install.texi gcc-10.2.0/gcc/doc/install.texi
+--- gcc-10.2.0.org/gcc/doc/install.texi        2021-03-21 01:21:15.938335808 +0100
++++ gcc-10.2.0/gcc/doc/install.texi    2021-03-21 01:21:39.491335808 +0100
+@@ -91,9 +91,9 @@ Free Documentation License}''.
+ @ifinfo
+ @insertcopying
+ @end ifinfo
 -@dircategory Software development
 +@dircategory Programming Languages:
  @direntry
--* gnat-style: (gnat-style).      GNAT Coding Style
-+* gnat-style: (gnat-style).           GNAT Coding Style
+-* gccinstall: (gccinstall).    Installing the GNU Compiler Collection.
++* gccinstall: (gccinstall).           Installing the GNU Compiler Collection
  @end direntry
  
- @macro syntax{element}
---- gcc-6.4.0/gcc/ada/gnat_rm.texi.orig        2016-01-04 14:03:35.362396000 +0100
-+++ gcc-6.4.0/gcc/ada/gnat_rm.texi     2018-04-04 20:06:55.773027894 +0200
-@@ -10,9 +10,9 @@
- @paragraphindent 0
- @exampleindent 4
- @finalout
--@dircategory GNU Ada Tools 
-+@dircategory Programming Languages:
- @direntry
--* gnat_rm: (gnat_rm.info). gnat_rm
-+* gnat_rm: (gnat_rm.info).            gnat_rm
- @end direntry
+ @c Part 3 Titlepage and Copyright
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/fortran/gfc-internals.texi gcc-10.2.0/gcc/fortran/gfc-internals.texi
+--- gcc-10.2.0.org/gcc/fortran/gfc-internals.texi      2020-07-23 08:35:17.604387417 +0200
++++ gcc-10.2.0/gcc/fortran/gfc-internals.texi  2021-03-21 01:21:39.494335808 +0100
+@@ -53,9 +53,9 @@ Texts being (a) (see below), and with th
+ @end copying
  
- @definfoenclose strong,`,'
---- gcc-6.4.0/gcc/ada/gnat_ugn.texi.orig       2018-04-04 16:44:59.699832904 +0200
-+++ gcc-6.4.0/gcc/ada/gnat_ugn.texi    2018-04-04 20:07:10.206361061 +0200
-@@ -10,9 +10,9 @@
- @paragraphindent 0
- @exampleindent 4
- @finalout
--@dircategory GNU Ada Tools 
+ @ifinfo
+-@dircategory Software development
 +@dircategory Programming Languages:
  @direntry
--* gnat_ugn: (gnat_ugn.info). gnat_ugn
-+* gnat_ugn: (gnat_ugn.info).          gnat_ugn
+-* gfortran: (gfortran).                  The GNU Fortran Compiler.
++* gfortran: (gfortran).                       The GNU Fortran Compiler
  @end direntry
- @definfoenclose strong,`,'
---- a/gcc/fortran/gfortran.texi        2004-09-16 15:13:39.000000000 +0200
-+++ b/gcc/fortran/gfortran.texi        2004-09-26 11:05:50.258074024 +0200
-@@ -62,9 +62,9 @@
+ This file documents the internals of the GNU Fortran
+ compiler, (@command{gfortran}).
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/fortran/gfortran.texi gcc-10.2.0/gcc/fortran/gfortran.texi
+--- gcc-10.2.0.org/gcc/fortran/gfortran.texi   2020-07-23 08:35:17.604387417 +0200
++++ gcc-10.2.0/gcc/fortran/gfortran.texi       2021-03-21 01:21:39.491335808 +0100
+@@ -99,9 +99,9 @@ Texts being (a) (see below), and with th
  @end copying
  
  @ifinfo
  @end direntry
  This file documents the use and the internals of
  the GNU Fortran compiler, (@command{gfortran}).
---- a/gcc/doc/install.texi     2005-11-30 12:02:42.000000000 +0100
-+++ b/gcc/doc/install.texi     2005-12-11 02:44:22.598279768 +0100
-@@ -87,9 +87,9 @@
- @ifinfo
- @insertcopying
- @end ifinfo
--@dircategory Software development
-+@dircategory Programming Languages:
- @direntry
--* gccinstall: (gccinstall).    Installing the GNU Compiler Collection.
-+* gccinstall: (gccinstall).           Installing the GNU Compiler Collection
- @end direntry
- @c Part 3 Titlepage and Copyright
---- gcc-4.6.2/gcc/go/gccgo.texi.orig   2011-02-14 05:42:53.000000000 +0100
-+++ gcc-4.6.2/gcc/go/gccgo.texi        2011-10-31 18:27:12.670749858 +0100
-@@ -48,9 +48,9 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/go/gccgo.texi gcc-10.2.0/gcc/go/gccgo.texi
+--- gcc-10.2.0.org/gcc/go/gccgo.texi   2020-07-23 08:35:17.644387858 +0200
++++ gcc-10.2.0/gcc/go/gccgo.texi       2021-03-21 01:21:39.492335808 +0100
+@@ -48,9 +48,9 @@ man page gfdl(7).
  
  @ifinfo
  @format
  @end direntry
  @end format
  
---- gcc-4.8.2/libgomp/libgomp.texi.orig        2013-01-14 19:18:49.000000000 +0100
-+++ gcc-4.8.2/libgomp/libgomp.texi     2014-04-21 08:06:10.259411139 +0200
-@@ -29,9 +29,9 @@
- @end copying
- @ifinfo
--@dircategory GNU Libraries
-+@dircategory Libraries:
- @direntry
--* libgomp: (libgomp).          GNU Offloading and Multi Processing Runtime Library.
-+* libgomp: (libgomp).                 GNU Offloading and Multi Processing Runtime Library
- @end direntry
- This manual documents the GNU implementation of the OpenMP API for 
---- gcc-4.8.2/libitm/libitm.texi.orig  2013-02-03 18:46:11.000000000 +0100
-+++ gcc-4.8.2/libitm/libitm.texi       2014-04-21 08:06:38.919410542 +0200
-@@ -18,9 +18,9 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libffi/doc/libffi.texi gcc-10.2.0/libffi/doc/libffi.texi
+--- gcc-10.2.0.org/libffi/doc/libffi.texi      2020-07-23 08:35:18.740399932 +0200
++++ gcc-10.2.0/libffi/doc/libffi.texi  2021-03-21 01:21:39.493335808 +0100
+@@ -31,9 +31,9 @@ section entitled ``GNU General Public Li
+ @end quotation
  @end copying
  
- @ifinfo
--@dircategory GNU Libraries
+-@dircategory Development
 +@dircategory Libraries:
  @direntry
--* libitm: (libitm).                    GNU Transactional Memory Library
-+* libitm: (libitm).                   GNU Transactional Memory Library
+-* libffi: (libffi).             Portable foreign-function interface library.
++* libffi: (libffi).                   Portable foreign-function interface library
  @end direntry
  
- This manual documents the GNU Transactional Memory Library.
---- gcc-4.8.2/libquadmath/libquadmath.texi.orig        2013-01-22 09:23:32.000000000 +0100
-+++ gcc-4.8.2/libquadmath/libquadmath.texi     2014-04-21 08:07:12.262743180 +0200
-@@ -23,9 +23,9 @@
+ @titlepage
+diff -urNp -x '*.orig' gcc-10.2.0.org/libgomp/libgomp.texi gcc-10.2.0/libgomp/libgomp.texi
+--- gcc-10.2.0.org/libgomp/libgomp.texi        2020-07-23 08:35:19.016402971 +0200
++++ gcc-10.2.0/libgomp/libgomp.texi    2021-03-21 01:21:39.492335808 +0100
+@@ -29,9 +29,9 @@ texts being (a) (see below), and with th
  @end copying
  
  @ifinfo
 -@dircategory GNU Libraries
 +@dircategory Libraries:
  @direntry
--* libquadmath: (libquadmath).                  GCC Quad-Precision Math Library
-+* libquadmath: (libquadmath).         GCC Quad-Precision Math Library
- @end direntry
- This manual documents the GCC Quad-Precision Math Library API.
---- gcc-4.9.2/libffi/doc/libffi.texi.orig      2014-02-13 17:18:13.000000000 +0100
-+++ gcc-4.9.2/libffi/doc/libffi.texi   2015-01-13 20:19:48.088168568 +0100
-@@ -31,9 +31,9 @@
- @end quotation
- @end copying
--@dircategory Development
-+@dircategory Libraries:
- @direntry
--* libffi: (libffi).             Portable foreign-function interface library.
-+* libffi: (libffi).                   Portable foreign-function interface library
+-* libgomp: (libgomp).          GNU Offloading and Multi Processing Runtime Library.
++* libgomp: (libgomp).                 GNU Offloading and Multi Processing Runtime Library
  @end direntry
  
- @titlepage
---- gcc-4.9.2/libiberty/libiberty.texi.orig    2015-01-13 20:22:23.151495398 +0100
-+++ gcc-4.9.2/libiberty/libiberty.texi 2015-01-13 20:22:25.921495282 +0100
+ This manual documents libgomp, the GNU Offloading and Multi Processing
+diff -urNp -x '*.orig' gcc-10.2.0.org/libiberty/libiberty.texi gcc-10.2.0/libiberty/libiberty.texi
+--- gcc-10.2.0.org/libiberty/libiberty.texi    2020-07-23 08:35:19.048403324 +0200
++++ gcc-10.2.0/libiberty/libiberty.texi        2021-03-21 01:21:39.493335808 +0100
 @@ -11,10 +11,9 @@
  @finalout
  @c %**end of header
  @end direntry
  
  @macro libib
---- gcc-4.9.2/gcc/fortran/gfc-internals.texi.orig      2014-01-02 22:25:41.000000000 +0100
-+++ gcc-4.9.2/gcc/fortran/gfc-internals.texi   2015-01-13 20:23:53.034825013 +0100
-@@ -53,9 +53,9 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libitm/libitm.texi gcc-10.2.0/libitm/libitm.texi
+--- gcc-10.2.0.org/libitm/libitm.texi  2020-07-23 08:35:19.056403412 +0200
++++ gcc-10.2.0/libitm/libitm.texi      2021-03-21 01:21:39.493335808 +0100
+@@ -18,9 +18,9 @@ Free Documentation License''.
  @end copying
  
  @ifinfo
--@dircategory Software development
-+@dircategory Programming Languages:
+-@dircategory GNU Libraries
++@dircategory Libraries:
  @direntry
--* gfortran: (gfortran).                  The GNU Fortran Compiler.
-+* gfortran: (gfortran).                       The GNU Fortran Compiler
+-* libitm: (libitm).                    GNU Transactional Memory Library
++* libitm: (libitm).                   GNU Transactional Memory Library
  @end direntry
- This file documents the internals of the GNU Fortran
- compiler, (@command{gfortran}).
+ This manual documents the GNU Transactional Memory Library.
+diff -urNp -x '*.orig' gcc-10.2.0.org/libquadmath/libquadmath.texi gcc-10.2.0/libquadmath/libquadmath.texi
+--- gcc-10.2.0.org/libquadmath/libquadmath.texi        2020-07-23 08:35:19.120404117 +0200
++++ gcc-10.2.0/libquadmath/libquadmath.texi    2021-03-21 01:21:39.493335808 +0100
+@@ -23,9 +23,9 @@ copy and modify this GNU manual.
+ @end copying
+ @ifinfo
+-@dircategory GNU Libraries
++@dircategory Libraries:
+ @direntry
+-* libquadmath: (libquadmath).                  GCC Quad-Precision Math Library
++* libquadmath: (libquadmath).         GCC Quad-Precision Math Library
+ @end direntry
+ This manual documents the GCC Quad-Precision Math Library API.
index 0a243b52e2df56f9946dbb4d2e038ab8feb4609f..f75ab778530a7461e859fb14078dd5903e10f2e2 100644 (file)
@@ -1,15 +1,16 @@
---- gcc-4.7.1/gcc/config.gcc.orig      2012-07-10 17:33:40.596463050 +0200
-+++ gcc-4.7.1/gcc/config.gcc   2012-07-12 18:39:03.475713361 +0200
-@@ -2401,7 +2401,7 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/config.gcc gcc-10.2.0/gcc/config.gcc
+--- gcc-10.2.0.org/gcc/config.gcc      2021-03-21 11:32:24.611515690 +0100
++++ gcc-10.2.0/gcc/config.gcc  2021-03-21 11:32:46.784515690 +0100
+@@ -3289,7 +3289,7 @@ sparc-*-rtems*)
        tm_file="${tm_file} dbxelf.h elfos.h sparc/sysv4.h sparc/sp-elf.h sparc/rtemself.h rtems.h newlib-stdint.h"
-       tmake_file="sparc/t-sparc sparc/t-elf t-rtems"
+       tmake_file="${tmake_file} sparc/t-sparc sparc/t-rtems"
        ;;
 -sparc-*-linux*)
 +sparc-*-linux* | sparcv[789]*-*-linux*)
        tm_file="${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/tso.h"
        extra_options="${extra_options} sparc/long-double-switch.opt"
        case ${target} in
-@@ -2878,7 +2878,7 @@ sparc64-*-rtems*)
+@@ -3343,7 +3343,7 @@ sparc64-*-rtems*)
        extra_options="${extra_options}"
        tmake_file="${tmake_file} sparc/t-sparc sparc/t-rtems-64"
        ;;
        tm_file="sparc/biarch64.h ${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/default64.h sparc/linux64.h sparc/tso.h"
        extra_options="${extra_options} sparc/long-double-switch.opt"
        tmake_file="${tmake_file} sparc/t-sparc sparc/t-linux64"
---- gcc-4.7.1/libgcc/config.host.orig  2012-04-30 19:39:57.000000000 +0200
-+++ gcc-4.7.1/libgcc/config.host       2012-07-12 18:39:51.112378028 +0200
-@@ -1012,7 +1012,7 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libgcc/config.host gcc-10.2.0/libgcc/config.host
+--- gcc-10.2.0.org/libgcc/config.host  2020-07-23 08:35:18.752400064 +0200
++++ gcc-10.2.0/libgcc/config.host      2021-03-21 11:32:46.785515690 +0100
+@@ -1363,7 +1363,7 @@ sparc-*-elf*)
        tmake_file="${tmake_file} t-fdpbit t-crtfm"
        extra_parts="$extra_parts crti.o crtn.o crtfastmath.o"
        ;;
@@ -29,7 +31,7 @@
        tmake_file="${tmake_file} t-crtfm"
        if test "${host_address}" = 64; then
                tmake_file="$tmake_file sparc/t-linux64"
-@@ -1060,7 +1060,7 @@
+@@ -1411,7 +1411,7 @@ sparc64-*-freebsd*|ultrasparc-*-freebsd*
        tmake_file="$tmake_file t-crtfm"
        extra_parts="$extra_parts crtfastmath.o"
        ;;
index 2ecd3b27c7bcaf0fcd1cfeb8b09cb7beaa88b82d..aa44dd396aa75fbec5f7d728466b01e6eb833d80 100644 (file)
@@ -1,5 +1,29 @@
---- gcc-4.7.1/gcc/ada/gcc-interface/Makefile.in.orig   2012-07-10 17:33:42.146462985 +0200
-+++ gcc-4.7.1/gcc/ada/gcc-interface/Makefile.in        2012-07-12 18:27:21.682409479 +0200
+diff -urNp -x '*.orig' gcc-10.2.0.org/Makefile.in gcc-10.2.0/Makefile.in
+--- gcc-10.2.0.org/Makefile.in 2020-07-23 08:35:16.912379792 +0200
++++ gcc-10.2.0/Makefile.in     2021-03-21 01:23:21.870335808 +0100
+@@ -373,7 +373,7 @@ BUILD_PREFIX_1 = @BUILD_PREFIX_1@
+ # Flags to pass to stage2 and later makes.  They are defined
+ # here so that they can be overridden by Makefile fragments.
+-BOOT_CFLAGS= -g -O2
++BOOT_CFLAGS= -O2
+ BOOT_LDFLAGS=
+ BOOT_ADAFLAGS= -gnatpg
+@@ -619,8 +619,8 @@ CXXFLAGS_FOR_TARGET = @CXXFLAGS_FOR_TARG
+ LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
+ LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
+ LDFLAGS_FOR_TARGET = @LDFLAGS_FOR_TARGET@
+-GOCFLAGS_FOR_TARGET = -O2 -g
+-GDCFLAGS_FOR_TARGET = -O2 -g
++GOCFLAGS_FOR_TARGET = -O2
++GDCFLAGS_FOR_TARGET = -O2
+ FLAGS_FOR_TARGET = @FLAGS_FOR_TARGET@
+ SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
+diff -urNp -x '*.orig' gcc-10.2.0.org/gcc/ada/gcc-interface/Makefile.in gcc-10.2.0/gcc/ada/gcc-interface/Makefile.in
+--- gcc-10.2.0.org/gcc/ada/gcc-interface/Makefile.in   2020-07-23 08:35:17.112381997 +0200
++++ gcc-10.2.0/gcc/ada/gcc-interface/Makefile.in       2021-03-21 01:23:21.859335808 +0100
 @@ -66,7 +66,7 @@
  # CFLAGS is for the user to override to, e.g., do a bootstrap with -O2.
  # BOOT_CFLAGS is the value of CFLAGS to pass
  # Pretend that _Unwind_GetIPInfo is available for the target by default.  This
  # should be autodetected during the configuration of libada and passed down to
  # here, but we need something for --disable-libada and hope for the best.
---- gcc-4.7.1/libada/Makefile.in.orig  2012-06-12 17:12:37.000000000 +0200
-+++ gcc-4.7.1/libada/Makefile.in       2012-07-12 18:27:53.482408144 +0200
-@@ -59,7 +59,7 @@ LDFLAGS=
+diff -urNp -x '*.orig' gcc-10.2.0.org/libada/Makefile.in gcc-10.2.0/libada/Makefile.in
+--- gcc-10.2.0.org/libada/Makefile.in  2020-07-23 08:35:18.684399314 +0200
++++ gcc-10.2.0/libada/Makefile.in      2021-03-21 01:23:21.859335808 +0100
+@@ -61,7 +61,7 @@ LDFLAGS=
  CFLAGS=-g
  PICFLAG = @PICFLAG@
  GNATLIBFLAGS= -W -Wall -gnatpg -nostdinc
 -GNATLIBCFLAGS= -g -O2
 +GNATLIBCFLAGS= -O2
  GNATLIBCFLAGS_FOR_C = -W -Wall $(GNATLIBCFLAGS) $(CFLAGS_FOR_TARGET) \
-       -fexceptions -DIN_RTS @have_getipinfo@
+       -fexceptions -DIN_RTS @have_getipinfo@ @have_capability@
  
---- gcc-4.7.1/libffi/Makefile.am.orig  2012-02-27 11:00:12.000000000 +0100
-+++ gcc-4.7.1/libffi/Makefile.am       2012-07-12 18:28:20.115740360 +0200
-@@ -168,7 +168,7 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libffi/Makefile.am gcc-10.2.0/libffi/Makefile.am
+--- gcc-10.2.0.org/libffi/Makefile.am  2020-07-23 08:35:18.736399887 +0200
++++ gcc-10.2.0/libffi/Makefile.am      2021-03-21 01:23:21.859335808 +0100
+@@ -202,7 +202,7 @@ nodist_libffi_convenience_la_SOURCES = $
  
  LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
  
  if FFI_DEBUG
  # Build debug. Define FFI_DEBUG on the commandline so that, when building with
  # MSVC, it can link against the debug CRT.
---- gcc-4.7.1/libffi/Makefile.in.orig  2012-06-14 10:48:08.000000000 +0200
-+++ gcc-4.7.1/libffi/Makefile.in       2012-07-12 18:28:35.029073067 +0200
-@@ -486,7 +486,7 @@ libffi_convenience_la_LIBADD = $(libffi_
+diff -urNp -x '*.orig' gcc-10.2.0.org/libffi/Makefile.in gcc-10.2.0/libffi/Makefile.in
+--- gcc-10.2.0.org/libffi/Makefile.in  2020-07-23 08:35:54.708796179 +0200
++++ gcc-10.2.0/libffi/Makefile.in      2021-03-21 01:23:21.860335808 +0100
+@@ -604,7 +604,7 @@ libffi_convenience_la_LIBADD = $(libffi_
  libffi_convenience_la_DEPENDENCIES = $(libffi_la_DEPENDENCIES)
  nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
  LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
  @LIBAT_BUILD_VERSIONED_SHLIB_FALSE@libffi_version_script = 
  @LIBAT_BUILD_VERSIONED_SHLIB_GNU_TRUE@@LIBAT_BUILD_VERSIONED_SHLIB_TRUE@libffi_version_script = -Wl,--version-script,libffi.map
  @LIBAT_BUILD_VERSIONED_SHLIB_SUN_TRUE@@LIBAT_BUILD_VERSIONED_SHLIB_TRUE@libffi_version_script = -Wl,-M,libffi.map-sun
---- gcc-4.7.1/libgcc/Makefile.in.orig  2012-05-24 16:59:38.000000000 +0200
-+++ gcc-4.7.1/libgcc/Makefile.in       2012-07-12 18:28:59.042405393 +0200
-@@ -221,7 +221,7 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libgcc/Makefile.in gcc-10.2.0/libgcc/Makefile.in
+--- gcc-10.2.0.org/libgcc/Makefile.in  2020-07-23 08:35:18.748400018 +0200
++++ gcc-10.2.0/libgcc/Makefile.in      2021-03-21 01:23:21.860335808 +0100
+@@ -243,7 +243,7 @@ endif
  
  # Options to use when compiling libgcc2.a.
  #
  LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(HOST_LIBGCC2_CFLAGS) \
                 $(LIBGCC2_DEBUG_CFLAGS) -DIN_LIBGCC2 \
                 -fbuilding-libgcc -fno-stack-protector \
---- gcc-4.7.1/libstdc++-v3/include/Makefile.am.orig    2012-03-23 12:00:54.000000000 +0100
-+++ gcc-4.7.1/libstdc++-v3/include/Makefile.am 2012-07-12 18:31:29.102399096 +0200
-@@ -1154,22 +1154,22 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libstdc++-v3/include/Makefile.am gcc-10.2.0/libstdc++-v3/include/Makefile.am
+--- gcc-10.2.0.org/libstdc++-v3/include/Makefile.am    2021-03-21 01:22:56.853335808 +0100
++++ gcc-10.2.0/libstdc++-v3/include/Makefile.am        2021-03-21 01:23:21.861335808 +0100
+@@ -1343,22 +1343,22 @@ ${host_builddir}/gthr-default.h: ${tople
  # Build two precompiled C++ includes, stdc++.h.gch/*.gch
  ${pch1a_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
        -mkdir -p ${pch1_output_builddir}
  
  # For robustness sake (in light of junk files or in-source
  # configuration), copy from the build or source tree to the install
---- gcc-4.7.1/libstdc++-v3/include/Makefile.in.orig    2012-03-23 12:00:54.000000000 +0100
-+++ gcc-4.7.1/libstdc++-v3/include/Makefile.in 2012-07-12 18:31:43.922398474 +0200
-@@ -1543,22 +1543,22 @@
+diff -urNp -x '*.orig' gcc-10.2.0.org/libstdc++-v3/include/Makefile.in gcc-10.2.0/libstdc++-v3/include/Makefile.in
+--- gcc-10.2.0.org/libstdc++-v3/include/Makefile.in    2021-03-21 01:22:56.854335808 +0100
++++ gcc-10.2.0/libstdc++-v3/include/Makefile.in        2021-03-21 01:23:21.861335808 +0100
+@@ -1821,22 +1821,22 @@ ${host_builddir}/gthr-default.h: ${tople
  # Build two precompiled C++ includes, stdc++.h.gch/*.gch
  ${pch1a_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
        -mkdir -p ${pch1_output_builddir}
  
  # For robustness sake (in light of junk files or in-source
  # configuration), copy from the build or source tree to the install
---- gcc-4.7.1/Makefile.in.orig 2012-05-16 17:54:24.000000000 +0200
-+++ gcc-4.7.1/Makefile.in      2012-07-12 18:32:07.075730835 +0200
-@@ -364,7 +364,7 @@
- # Flags to pass to stage2 and later makes.  They are defined
- # here so that they can be overridden by Makefile fragments.
--BOOT_CFLAGS= -g -O2
-+BOOT_CFLAGS= -O2
- BOOT_LDFLAGS=
- BOOT_ADAFLAGS=-gnatpg -gnata
-@@ -618,8 +618,8 @@ CXXFLAGS_FOR_TARGET = @CXXFLAGS_FOR_TARG
- LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
- LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
- LDFLAGS_FOR_TARGET = @LDFLAGS_FOR_TARGET@
--GOCFLAGS_FOR_TARGET = -O2 -g
--GDCFLAGS_FOR_TARGET = -O2 -g
-+GOCFLAGS_FOR_TARGET = -O2
-+GDCFLAGS_FOR_TARGET = -O2
- FLAGS_FOR_TARGET = @FLAGS_FOR_TARGET@
- SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
index 9aecdbb1d417173987608387f3e06a72b944efe5..863949bf707733eb7817ec19783dbe07ccbece0b 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -104,7 +104,7 @@ Summary(pl.UTF-8):  Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       2
+Release:       3
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages