]> TLD Linux GIT Repositories - packages/grub2.git/blobdiff - grub2.spec
- partial PLD merge
[packages/grub2.git] / grub2.spec
index dc359e8cd2c91ccc71e0d355470940a84c261cce..b1cb292f9c67b6b670e776b92ff8fc3e0f0f8cbf 100644 (file)
@@ -30,6 +30,7 @@
 %define                platforms %{?with_efi:efi} %{?with_pc:pc}
 %endif
 
+%define                rel     6
 Summary:       GRand Unified Bootloader
 Summary(de.UTF-8):     GRUB2 - ein Bootloader für x86
 Summary(hu.UTF-8):     GRUB2 - rendszerbetöltő x86 gépekhez
@@ -38,14 +39,14 @@ Summary(pt_BR.UTF-8):       Gerenciador de inicialização GRUB2
 %define        beta    beta2
 Name:          grub2
 Version:       2.02
-Release:       0.%{beta}.5
+Release:       0.%{beta}.%{rel}
 License:       GPL v2
 Group:         Base
 # 1. Download and unpack latest official beta snapshot from http://git.savannah.gnu.org/cgit/grub.git
 # 2. Run ./autogen.sh and ./linguas.sh
 # 3. Recompress and upload to DF
 Source0:       grub-%{version}-%{beta}.tar.xz
-# Source0-md5: f262e61eba2e76a6f60b39a810814284
+# Source0-md5: f262e61eba2e76a6f60b39a810814284
 Source1:       update-grub
 Source2:       update-grub.8
 Source3:       grub.sysconfig
@@ -62,6 +63,12 @@ Patch9:              just-say-linux.patch
 Patch10:       ignore-kernel-symlinks.patch
 Patch11:       choose-preferred-initrd.patch
 Patch12:       %{name}-cfg.patch
+Patch13:       efi-net-fix.patch
+Patch14:       grub2-xfs-Add-helper-for-inode-size.patch
+Patch15:       grub2-xfs-Convert-inode-numbers-to-cpu-endianity-immediate.patch
+Patch16:       grub2-xfs-Fix-termination-loop-for-directory-iteration.patch
+Patch17:       grub2-xfs-V5-filesystem-format-support.patch
+Patch18:       blscfg.patch
 URL:           http://www.gnu.org/software/grub/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1:1.11.1-1
@@ -71,7 +78,8 @@ BuildRequires:        flex >= 2.5.35
 BuildRequires: fonts-TTF-DejaVu
 BuildRequires: freetype-devel >= 2
 BuildRequires: gawk
-BuildRequires: gettext-devel
+BuildRequires: gcc >= 5:3.4
+BuildRequires: gettext-tools
 BuildRequires: glibc-localedb-all
 BuildRequires: glibc-static
 BuildRequires: help2man
@@ -89,12 +97,8 @@ BuildRequires:       xz
 BuildRequires: xz-devel
 %ifarch %{x8664}
 BuildRequires: /usr/lib/libc.so
-%if "%{pld_release}" == "ac"
-BuildRequires: libgcc32
-%else
 BuildRequires: gcc-multilib
 %endif
-%endif
 Requires:      %{name}-platform = %{version}-%{release}
 Requires:      issue
 Requires:      which
@@ -271,7 +275,7 @@ starfield theme for GRUB.
 Motyw starfield dla GRUB-a.
 
 %prep
-%setup -q -n grub-%{version}-%{beta}
+%setup -q -n grub-%{version}~%{beta}
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -284,6 +288,12 @@ Motyw starfield dla GRUB-a.
 %patch10 -p1
 %patch11 -p1
 %patch12 -p0
+%patch13 -p1
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
 
 # we don't have C.utf-8 and need an UTF-8 locale for build
 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
@@ -293,13 +303,13 @@ sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
 # https://savannah.gnu.org/bugs/?34539
 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
 install -d our-ld
-ln -s /usr/bin/ld.bfd our-ld/ld
+ln -f -s /usr/bin/ld.bfd our-ld/ld
 export PATH=$(pwd)/our-ld:$PATH
 
 ## not only the typicall autotools stuff
 #./autogen.sh
 
-%{__gettextize}
+#{__gettextize}
 %{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
@@ -315,7 +325,7 @@ for platform in %{platforms} ; do
                platform_opts=""
        fi
 
-       ln -s ../configure .
+       ln -f -s ../configure .
        # mawk stalls at ./genmoddep.awk, so force gawk
        AWK=gawk \
        %configure \