]> TLD Linux GIT Repositories - packages/kernel.git/blobdiff - kernel-vanilla.spec
- fix kernel_release
[packages/kernel.git] / kernel-vanilla.spec
index 1d3e396c268a68fd1f7017822bd7005e221b743d..b44568c14982330d4a5332487445983383aeceb8 100644 (file)
@@ -13,7 +13,7 @@
 # modules will be looked from /lib/modules/%{kernel_release}
 # localversion is just that without version for "> localversion"
 %define                localversion    %{rel}
-%define                kernel_release  %{version}%{?alt_kernel:.%{alt_kernel}}-%{localversion}
+%define                kernel_release  %{version}%{?alt_kernel:-%{alt_kernel}}-%{localversion}
 
 Summary:       The Linux kernel (the core of the Linux operating system)
 Summary(de.UTF-8):     Der Linux-Kernel (Kern des Linux-Betriebssystems)
@@ -383,10 +383,10 @@ EOF
 cd %{objdir}
 install -d arch/%{target_arch_dir}
 %ifarch i686
-       cat $RPM_SOURCE_DIR/%{SOURCE10} > %{defconfig}
+       cat %{SOURCE10} > %{defconfig}
 %endif
 %ifarch x86_64
-       cat $RPM_SOURCE_DIR/%{SOURCE11} > %{defconfig}
+       cat %{SOURCE11} > %{defconfig}
 %endif
 
 ln -sf %{defconfig} .config