]> TLD Linux GIT Repositories - packages/kernel.git/blobdiff - kernel-vanilla.spec
- fix kernel_release
[packages/kernel.git] / kernel-vanilla.spec
index 6718a62edc3c081a83463a860891a04519cc48e9..b44568c14982330d4a5332487445983383aeceb8 100644 (file)
@@ -3,9 +3,9 @@
 %bcond_without doc             # don't build kernel-doc package
 %bcond_with    verbose         # verbose build (V=1)
 
-%define                rel             1
 %define                basever         3.8
 %define                postver         .8
+%define                rel             1
 
 %define                alt_kernel      3.8-vanilla
 
@@ -13,7 +13,7 @@
 # modules will be looked from /lib/modules/%{kernel_release}
 # localversion is just that without version for "> localversion"
 %define                localversion    %{rel}
-%define                kernel_release  %{version}%{?alt_kernel:.%{alt_kernel}}-%{localversion}
+%define                kernel_release  %{version}%{?alt_kernel:-%{alt_kernel}}-%{localversion}
 
 Summary:       The Linux kernel (the core of the Linux operating system)
 Summary(de.UTF-8):     Der Linux-Kernel (Kern des Linux-Betriebssystems)
@@ -37,6 +37,9 @@ Source2:      kernel.sysconfig
 Source3:       kernel-module-build.pl
 Source4:       kernel.make
 
+Source10:      kernel-vanilla-x86.config
+Source11:      kernel-vanilla-x86_64.config
+
 URL:           http://www.kernel.org/
 BuildRequires: binutils >= 3:2.18
 BuildRequires: /sbin/depmod
@@ -380,12 +383,11 @@ EOF
 cd %{objdir}
 install -d arch/%{target_arch_dir}
 %ifarch i686
-%define         kernel_config           kernel-%{alt_kernel}-x86.config
-%else
-%define         kernel_config           kernel-%{alt_kernel}-%{_target_base_arch}.config
+       cat %{SOURCE10} > %{defconfig}
+%endif
+%ifarch x86_64
+       cat %{SOURCE11} > %{defconfig}
 %endif
-echo "Building config file using %{kernel_config}..."
-cat $RPM_SOURCE_DIR/%{kernel_config} > %{defconfig}
 
 ln -sf %{defconfig} .config
 cd -