]> TLD Linux GIT Repositories - packages/libvirt.git/blobdiff - libvirt-sasl.patch
- updateed to 5.4.0
[packages/libvirt.git] / libvirt-sasl.patch
index 7823a6085f5e1ea67065e608dbf5aeac867599bf..f1f6e5f8848885e5689b15beb701b82cc1fb79ac 100644 (file)
-diff -urp libvirt-1.3.3.orig/daemon/libvirtd.conf libvirt-1.3.3/daemon/libvirtd.conf
---- libvirt-1.3.3.orig/daemon/libvirtd.conf    2016-04-14 10:15:59.438170000 +0000
-+++ libvirt-1.3.3/daemon/libvirtd.conf 2016-04-14 10:16:21.849170000 +0000
-@@ -128,7 +128,7 @@
- #          the network providing auth (eg, TLS/x509 certificates)
- #
- #  - sasl: use SASL infrastructure. The actual auth scheme is then
--#          controlled from /etc/sasl2/libvirt.conf. For the TCP
-+#          controlled from /etc/sasl/libvirt.conf. For the TCP
- #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
- #          For non-TCP or TLS sockets, any scheme is allowed.
- #
-@@ -159,7 +159,7 @@
- # If you don't enable SASL, then all TCP traffic is cleartext.
- # Don't do this outside of a dev/test scenario. For real world
- # use, always enable SASL and use the GSSAPI or DIGEST-MD5
--# mechanism in /etc/sasl2/libvirt.conf
-+# mechanism in /etc/sasl/libvirt.conf
- #auth_tcp = "sasl"
+diff -urp libvirt-5.4.0.orig/docs/auth.html libvirt-5.4.0/docs/auth.html
+--- libvirt-5.4.0.orig/docs/auth.html  2019-06-17 20:17:53.120000000 +0200
++++ libvirt-5.4.0/docs/auth.html       2019-06-17 20:18:17.708000000 +0200
+@@ -318,7 +318,7 @@ to turn on SASL auth in these listeners.
+         <p>
+ Since the libvirt SASL config file defaults to using GSSAPI (Kerberos), a
+ config change is rquired to enable plain password auth. This is done by
+-editting <code>/etc/sasl2/libvirt.conf</code> to set the <code>mech_list</code>
++editting <code>/etc/sasl/libvirt.conf</code> to set the <code>mech_list</code>
+ parameter to <code>scram-sha-1</code>.
+     </p>
+         <p>
+diff -urp libvirt-5.4.0.orig/docs/auth.html.in libvirt-5.4.0/docs/auth.html.in
+--- libvirt-5.4.0.orig/docs/auth.html.in       2019-06-17 20:17:53.125000000 +0200
++++ libvirt-5.4.0/docs/auth.html.in    2019-06-17 20:18:17.709000000 +0200
+@@ -277,7 +277,7 @@ to turn on SASL auth in these listeners.
+     <p>
+ Since the libvirt SASL config file defaults to using GSSAPI (Kerberos), a
+ config change is rquired to enable plain password auth. This is done by
+-editting <code>/etc/sasl2/libvirt.conf</code> to set the <code>mech_list</code>
++editting <code>/etc/sasl/libvirt.conf</code> to set the <code>mech_list</code>
+ parameter to <code>scram-sha-1</code>.
+     </p>
+     <p>
+diff -urp libvirt-5.4.0.orig/src/Makefile.in libvirt-5.4.0/src/Makefile.in
+--- libvirt-5.4.0.orig/src/Makefile.in 2019-06-17 20:17:53.264000000 +0200
++++ libvirt-5.4.0/src/Makefile.in      2019-06-17 20:18:17.713000000 +0200
+@@ -6257,7 +6257,7 @@ REMOTE_DRIVER_PROTOCOL = \
  
- # Change the authentication scheme for TLS sockets.
-diff -urp libvirt-1.3.3.orig/daemon/Makefile.am libvirt-1.3.3/daemon/Makefile.am
---- libvirt-1.3.3.orig/daemon/Makefile.am      2016-04-14 10:15:59.438170000 +0000
-+++ libvirt-1.3.3/daemon/Makefile.am   2016-04-14 10:16:21.849170000 +0000
-@@ -521,13 +521,13 @@ $(srcdir)/libvirtd.8.in: libvirtd.pod.in
- # the WITH_LIBVIRTD conditional
- if WITH_SASL
- install-data-sasl:
--      $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sasl2/
-+      $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sasl/
-       $(INSTALL_DATA) $(srcdir)/libvirtd.sasl \
--              $(DESTDIR)$(sysconfdir)/sasl2/libvirt.conf
-+              $(DESTDIR)$(sysconfdir)/sasl/libvirt.conf
- uninstall-data-sasl:
--      rm -f $(DESTDIR)$(sysconfdir)/sasl2/libvirt.conf
--      rmdir $(DESTDIR)$(sysconfdir)/sasl2/ || :
-+      rm -f $(DESTDIR)$(sysconfdir)/sasl/libvirt.conf
-+      rmdir $(DESTDIR)$(sysconfdir)/sasl/ || :
- else ! WITH_SASL
- install-data-sasl:
- uninstall-data-sasl:
-diff -urp libvirt-1.3.3.orig/daemon/Makefile.in libvirt-1.3.3/daemon/Makefile.in
---- libvirt-1.3.3.orig/daemon/Makefile.in      2016-04-14 10:15:59.436170000 +0000
-+++ libvirt-1.3.3/daemon/Makefile.in   2016-04-14 10:16:21.852170000 +0000
-@@ -2832,13 +2832,13 @@ $(srcdir)/libvirtd.8.in: libvirtd.pod.in
  # This is needed for clients too, so can't wrap in
  # the WITH_LIBVIRTD conditional
- @WITH_SASL_TRUE@install-data-sasl:
--@WITH_SASL_TRUE@      $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sasl2/
-+@WITH_SASL_TRUE@      $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sasl/
- @WITH_SASL_TRUE@      $(INSTALL_DATA) $(srcdir)/libvirtd.sasl \
--@WITH_SASL_TRUE@              $(DESTDIR)$(sysconfdir)/sasl2/libvirt.conf
-+@WITH_SASL_TRUE@              $(DESTDIR)$(sysconfdir)/sasl/libvirt.conf
- @WITH_SASL_TRUE@uninstall-data-sasl:
--@WITH_SASL_TRUE@      rm -f $(DESTDIR)$(sysconfdir)/sasl2/libvirt.conf
--@WITH_SASL_TRUE@      rmdir $(DESTDIR)$(sysconfdir)/sasl2/ || :
-+@WITH_SASL_TRUE@      rm -f $(DESTDIR)$(sysconfdir)/sasl/libvirt.conf
-+@WITH_SASL_TRUE@      rmdir $(DESTDIR)$(sysconfdir)/sasl/ || :
- @WITH_SASL_FALSE@install-data-sasl:
- @WITH_SASL_FALSE@uninstall-data-sasl:
-diff -urp libvirt-1.3.3.orig/docs/auth.html libvirt-1.3.3/docs/auth.html
---- libvirt-1.3.3.orig/docs/auth.html  2016-04-14 10:15:59.421170000 +0000
-+++ libvirt-1.3.3/docs/auth.html       2016-04-14 10:16:21.852170000 +0000
-@@ -404,7 +404,7 @@ again:
- The plain TCP socket of the libvirt daemon defaults to using SASL for authentication.
- The SASL mechanism configured by default is DIGEST-MD5, which provides a basic
- username+password style authentication. To enable Kerberos single-sign-on instead,
--the libvirt SASL configuration file must be changed. This is <code>/etc/sasl2/libvirt.conf</code>.
-+the libvirt SASL configuration file must be changed. This is <code>/etc/sasl/libvirt.conf</code>.
- The <code>mech_list</code> parameter must first be changed to <code>gssapi</code>
- instead of the default <code>digest-md5</code>, and keytab should be set to
- <code>/etc/libvirt/krb5.tab</code> . If SASL is enabled on the UNIX
-diff -urp libvirt-1.3.3.orig/docs/auth.html.in libvirt-1.3.3/docs/auth.html.in
---- libvirt-1.3.3.orig/docs/auth.html.in       2016-04-14 10:15:59.414170000 +0000
-+++ libvirt-1.3.3/docs/auth.html.in    2016-04-14 10:16:21.853170000 +0000
-@@ -234,7 +234,7 @@ again:
- The plain TCP socket of the libvirt daemon defaults to using SASL for authentication.
- The SASL mechanism configured by default is DIGEST-MD5, which provides a basic
- username+password style authentication. To enable Kerberos single-sign-on instead,
--the libvirt SASL configuration file must be changed. This is <code>/etc/sasl2/libvirt.conf</code>.
-+the libvirt SASL configuration file must be changed. This is <code>/etc/sasl/libvirt.conf</code>.
- The <code>mech_list</code> parameter must first be changed to <code>gssapi</code>
- instead of the default <code>digest-md5</code>, and keytab should be set to
- <code>/etc/libvirt/krb5.tab</code> . If SASL is enabled on the UNIX
-diff -urp libvirt-1.3.3.orig/libvirt.spec libvirt-1.3.3/libvirt.spec
---- libvirt-1.3.3.orig/libvirt.spec    2016-04-14 10:15:59.436170000 +0000
-+++ libvirt-1.3.3/libvirt.spec 2016-04-14 10:16:21.860170000 +0000
-@@ -2332,7 +2332,7 @@ exit 0
- %dir %attr(0755, root, root) %{_localstatedir}/lib/libvirt/
- %if %{with_sasl}
--%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
-+%config(noreplace) %{_sysconfdir}/sasl/libvirt.conf
- %endif
- %if %{with_wireshark}
-diff -urp libvirt-1.3.3.orig/libvirt.spec.in libvirt-1.3.3/libvirt.spec.in
---- libvirt-1.3.3.orig/libvirt.spec.in 2016-04-14 10:16:00.591170000 +0000
-+++ libvirt-1.3.3/libvirt.spec.in      2016-04-14 10:16:21.872170000 +0000
-@@ -2332,7 +2332,7 @@ exit 0
- %dir %attr(0755, root, root) %{_localstatedir}/lib/libvirt/
- %if %{with_sasl}
--%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
-+%config(noreplace) %{_sysconfdir}/sasl/libvirt.conf
- %endif
- %if %{with_wireshark}
-diff -urp libvirt-1.3.3.orig/src/qemu/qemu.conf libvirt-1.3.3/src/qemu/qemu.conf
---- libvirt-1.3.3.orig/src/qemu/qemu.conf      2016-04-14 10:16:00.616170000 +0000
-+++ libvirt-1.3.3/src/qemu/qemu.conf   2016-04-14 10:16:21.872170000 +0000
-@@ -74,18 +74,18 @@
+-@WITH_SASL_TRUE@sasldir = $(sysconfdir)/sasl2
++@WITH_SASL_TRUE@sasldir = $(sysconfdir)/sasl
+ THREAD_LIBS = $(LIB_PTHREAD) $(LTLIBMULTITHREAD)
+ SECDRIVER_CFLAGS = $(am__append_191) $(am__append_193)
+ SECDRIVER_LIBS = $(am__append_192) $(am__append_194)
+diff -urp libvirt-5.4.0.orig/src/qemu/qemu.conf libvirt-5.4.0/src/qemu/qemu.conf
+--- libvirt-5.4.0.orig/src/qemu/qemu.conf      2019-06-17 20:17:53.240000000 +0200
++++ libvirt-5.4.0/src/qemu/qemu.conf   2019-06-17 20:18:17.713000000 +0200
+@@ -135,18 +135,18 @@
  # Examples include vinagre, virt-viewer and virt-manager
  # itself. UltraVNC, RealVNC, TightVNC do not support this
  #
@@ -134,7 +59,7 @@ diff -urp libvirt-1.3.3.orig/src/qemu/qemu.conf libvirt-1.3.3/src/qemu/qemu.conf
  
  
  # QEMU implements an extension for providing audio over a VNC connection,
-@@ -143,17 +143,17 @@
+@@ -211,17 +211,17 @@
  # Enable use of SASL encryption on the SPICE server. This requires
  # a SPICE client which supports the SASL protocol extension.
  #
@@ -153,12 +78,12 @@ diff -urp libvirt-1.3.3.orig/src/qemu/qemu.conf libvirt-1.3.3/src/qemu/qemu.conf
 -#spice_sasl_dir = "/some/directory/sasl2"
 +#spice_sasl_dir = "/some/directory/sasl"
  
- # By default, if no graphical front end is configured, libvirt will disable
-diff -urp libvirt-1.3.3.orig/src/qemu/test_libvirtd_qemu.aug.in libvirt-1.3.3/src/qemu/test_libvirtd_qemu.aug.in
---- libvirt-1.3.3.orig/src/qemu/test_libvirtd_qemu.aug.in      2016-04-14 10:16:00.617170000 +0000
-+++ libvirt-1.3.3/src/qemu/test_libvirtd_qemu.aug.in   2016-04-14 10:16:21.872170000 +0000
-@@ -9,14 +9,14 @@ module Test_libvirtd_qemu =
+ # Enable use of TLS encryption on the chardev TCP transports.
+ #
+diff -urp libvirt-5.4.0.orig/src/qemu/test_libvirtd_qemu.aug.in libvirt-5.4.0/src/qemu/test_libvirtd_qemu.aug.in
+--- libvirt-5.4.0.orig/src/qemu/test_libvirtd_qemu.aug.in      2019-06-17 20:17:53.240000000 +0200
++++ libvirt-5.4.0/src/qemu/test_libvirtd_qemu.aug.in   2019-06-17 20:18:17.713000000 +0200
+@@ -13,7 +13,7 @@ module Test_libvirtd_qemu =
  { "vnc_tls_x509_verify" = "1" }
  { "vnc_password" = "XYZ12345" }
  { "vnc_sasl" = "1" }
@@ -167,59 +92,51 @@ diff -urp libvirt-1.3.3.orig/src/qemu/test_libvirtd_qemu.aug.in libvirt-1.3.3/sr
  { "vnc_allow_host_audio" = "0" }
  { "spice_listen" = "0.0.0.0" }
  { "spice_tls" = "1" }
- { "spice_tls_x509_cert_dir" = "/etc/pki/libvirt-spice" }
+@@ -21,7 +21,7 @@ module Test_libvirtd_qemu =
+ { "spice_auto_unix_socket" = "1" }
  { "spice_password" = "XYZ12345" }
  { "spice_sasl" = "1" }
 -{ "spice_sasl_dir" = "/some/directory/sasl2" }
 +{ "spice_sasl_dir" = "/some/directory/sasl" }
- { "nographics_allow_host_audio" = "1" }
- { "remote_display_port_min" = "5900" }
- { "remote_display_port_max" = "65535" }
-diff -urp libvirt-1.3.3.orig/tests/confdata/libvirtd.conf libvirt-1.3.3/tests/confdata/libvirtd.conf
---- libvirt-1.3.3.orig/tests/confdata/libvirtd.conf    2016-04-14 10:16:00.575170000 +0000
-+++ libvirt-1.3.3/tests/confdata/libvirtd.conf 2016-04-14 10:16:21.872170000 +0000
-@@ -108,7 +108,7 @@ unix_sock_admin_perms = "0700"
+ { "chardev_tls" = "1" }
+ { "chardev_tls_x509_cert_dir" = "/etc/pki/libvirt-chardev" }
+ { "chardev_tls_x509_verify" = "1" }
+diff -urp libvirt-5.4.0.orig/src/remote/libvirtd.conf libvirt-5.4.0/src/remote/libvirtd.conf
+--- libvirt-5.4.0.orig/src/remote/libvirtd.conf        2019-06-17 20:17:53.242000000 +0200
++++ libvirt-5.4.0/src/remote/libvirtd.conf     2019-06-17 20:18:17.713000000 +0200
+@@ -123,7 +123,7 @@
  #          the network providing auth (eg, TLS/x509 certificates)
  #
  #  - sasl: use SASL infrastructure. The actual auth scheme is then
 -#          controlled from /etc/sasl2/libvirt.conf. For the TCP
 +#          controlled from /etc/sasl/libvirt.conf. For the TCP
  #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
- #          For non-TCP or TLS sockets,  any scheme is allowed.
+ #          For non-TCP or TLS sockets, any scheme is allowed.
  #
-@@ -139,7 +139,7 @@ auth_unix_rw = "none"
+@@ -154,7 +154,7 @@
  # If you don't enable SASL, then all TCP traffic is cleartext.
  # Don't do this outside of a dev/test scenario. For real world
  # use, always enable SASL and use the GSSAPI or DIGEST-MD5
 -# mechanism in /etc/sasl2/libvirt.conf
 +# mechanism in /etc/sasl/libvirt.conf
- auth_tcp = "sasl"
#auth_tcp = "sasl"
  
  # Change the authentication scheme for TLS sockets.
-diff -urp libvirt-1.3.3.orig/tests/confdata/libvirtd.out libvirt-1.3.3/tests/confdata/libvirtd.out
---- libvirt-1.3.3.orig/tests/confdata/libvirtd.out     2016-04-14 10:16:00.575170000 +0000
-+++ libvirt-1.3.3/tests/confdata/libvirtd.out  2016-04-14 10:16:21.872170000 +0000
-@@ -87,7 +87,7 @@ unix_sock_admin_perms = "0700"
- #          the network providing auth (eg, TLS/x509 certificates)
- #
- #  - sasl: use SASL infrastructure. The actual auth scheme is then
--#          controlled from /etc/sasl2/libvirt.conf. For the TCP
-+#          controlled from /etc/sasl/libvirt.conf. For the TCP
- #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
- #          For non-TCP or TLS sockets,  any scheme is allowed.
- #
-@@ -116,7 +116,7 @@ auth_unix_rw = "none"
- # If you don't enable SASL, then all TCP traffic is cleartext.
- # Don't do this outside of a dev/test scenario. For real world
- # use, always enable SASL and use the GSSAPI or DIGEST-MD5
--# mechanism in /etc/sasl2/libvirt.conf
-+# mechanism in /etc/sasl/libvirt.conf
- auth_tcp = "sasl"
- # Change the authentication scheme for TLS sockets.
- #
-diff -urp libvirt-1.3.3.orig/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-sasl.args libvirt-1.3.3/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-sasl.args
---- libvirt-1.3.3.orig/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-sasl.args      2016-04-14 10:15:59.729170000 +0000
-+++ libvirt-1.3.3/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-sasl.args   2016-04-14 10:16:21.873170000 +0000
+diff -urp libvirt-5.4.0.orig/src/remote/Makefile.inc.am libvirt-5.4.0/src/remote/Makefile.inc.am
+--- libvirt-5.4.0.orig/src/remote/Makefile.inc.am      2019-06-17 20:17:53.240000000 +0200
++++ libvirt-5.4.0/src/remote/Makefile.inc.am   2019-06-17 20:18:17.714000000 +0200
+@@ -244,7 +244,7 @@ endif WITH_LIBVIRTD
+ # This is needed for clients too, so can't wrap in
+ # the WITH_LIBVIRTD conditional
+ if WITH_SASL
+-sasldir = $(sysconfdir)/sasl2
++sasldir = $(sysconfdir)/sasl
+ install-sasl:
+       $(MKDIR_P) $(DESTDIR)$(sasldir)
+diff -urp libvirt-5.4.0.orig/tests/qemuargv2xmldata/graphics-vnc-sasl.args libvirt-5.4.0/tests/qemuargv2xmldata/graphics-vnc-sasl.args
+--- libvirt-5.4.0.orig/tests/qemuargv2xmldata/graphics-vnc-sasl.args   2019-06-17 20:17:54.132000000 +0200
++++ libvirt-5.4.0/tests/qemuargv2xmldata/graphics-vnc-sasl.args        2019-06-17 20:18:17.714000000 +0200
 @@ -3,7 +3,7 @@ PATH=/bin \
  HOME=/home/test \
  USER=test \
@@ -227,11 +144,11 @@ diff -urp libvirt-1.3.3.orig/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-sa
 -SASL_CONF_PATH=/root/.sasl2 \
 +SASL_CONF_PATH=/root/.sasl \
  QEMU_AUDIO_DRV=none \
- /usr/bin/qemu \
+ /usr/bin/qemu-system-i686 \
  -name QEMUGuest1 \
-diff -urp libvirt-1.3.3.orig/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-tls.args libvirt-1.3.3/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-tls.args
---- libvirt-1.3.3.orig/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-tls.args       2016-04-14 10:15:59.730170000 +0000
-+++ libvirt-1.3.3/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-tls.args    2016-04-14 10:16:21.873170000 +0000
+diff -urp libvirt-5.4.0.orig/tests/qemuargv2xmldata/graphics-vnc-tls.args libvirt-5.4.0/tests/qemuargv2xmldata/graphics-vnc-tls.args
+--- libvirt-5.4.0.orig/tests/qemuargv2xmldata/graphics-vnc-tls.args    2019-06-17 20:17:54.132000000 +0200
++++ libvirt-5.4.0/tests/qemuargv2xmldata/graphics-vnc-tls.args 2019-06-17 20:18:17.714000000 +0200
 @@ -3,7 +3,7 @@ PATH=/bin \
  HOME=/home/test \
  USER=test \
@@ -239,62 +156,104 @@ diff -urp libvirt-1.3.3.orig/tests/qemuargv2xmldata/qemuargv2xml-graphics-vnc-tl
 -SASL_CONF_PATH=/root/.sasl2 \
 +SASL_CONF_PATH=/root/.sasl \
  QEMU_AUDIO_DRV=none \
- /usr/bin/qemu \
+ /usr/bin/qemu-system-i686 \
  -name QEMUGuest1 \
-diff -urp libvirt-1.3.3.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-spice-sasl.args libvirt-1.3.3/tests/qemuxml2argvdata/qemuxml2argv-graphics-spice-sasl.args
---- libvirt-1.3.3.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-spice-sasl.args    2016-04-14 10:15:59.691170000 +0000
-+++ libvirt-1.3.3/tests/qemuxml2argvdata/qemuxml2argv-graphics-spice-sasl.args 2016-04-14 10:16:21.873170000 +0000
-@@ -3,7 +3,7 @@ PATH=/bin \
HOME=/home/test \
USER=test \
LOGNAME=test \
+diff -urp libvirt-5.4.0.orig/tests/qemuxml2argvdata/graphics-spice-sasl.args libvirt-5.4.0/tests/qemuxml2argvdata/graphics-spice-sasl.args
+--- libvirt-5.4.0.orig/tests/qemuxml2argvdata/graphics-spice-sasl.args 2019-06-17 20:17:54.162000000 +0200
++++ libvirt-5.4.0/tests/qemuxml2argvdata/graphics-spice-sasl.args      2019-06-17 20:18:17.714000000 +0200
+@@ -6,7 +6,7 @@ LOGNAME=test \
XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
 -SASL_CONF_PATH=/root/.sasl2 \
 +SASL_CONF_PATH=/root/.sasl \
  QEMU_AUDIO_DRV=spice \
- /usr/bin/qemu \
+ /usr/bin/qemu-system-i686 \
  -name QEMUGuest1 \
-diff -urp libvirt-1.3.3.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args libvirt-1.3.3/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args
---- libvirt-1.3.3.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args      2016-04-14 10:15:59.692170000 +0000
-+++ libvirt-1.3.3/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-sasl.args   2016-04-14 10:16:21.874170000 +0000
-@@ -3,7 +3,7 @@ PATH=/bin \
HOME=/home/test \
USER=test \
LOGNAME=test \
+diff -urp libvirt-5.4.0.orig/tests/qemuxml2argvdata/graphics-vnc-sasl.args libvirt-5.4.0/tests/qemuxml2argvdata/graphics-vnc-sasl.args
+--- libvirt-5.4.0.orig/tests/qemuxml2argvdata/graphics-vnc-sasl.args   2019-06-17 20:17:54.163000000 +0200
++++ libvirt-5.4.0/tests/qemuxml2argvdata/graphics-vnc-sasl.args        2019-06-17 20:18:17.714000000 +0200
+@@ -6,7 +6,7 @@ LOGNAME=test \
XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
 -SASL_CONF_PATH=/root/.sasl2 \
 +SASL_CONF_PATH=/root/.sasl \
  QEMU_AUDIO_DRV=none \
- /usr/bin/qemu \
+ /usr/bin/qemu-system-i686 \
  -name QEMUGuest1 \
-diff -urp libvirt-1.3.3.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args libvirt-1.3.3/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args
---- libvirt-1.3.3.orig/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args       2016-04-14 10:15:59.672170000 +0000
-+++ libvirt-1.3.3/tests/qemuxml2argvdata/qemuxml2argv-graphics-vnc-tls.args    2016-04-14 10:16:21.874170000 +0000
-@@ -3,7 +3,7 @@ PATH=/bin \
HOME=/home/test \
USER=test \
LOGNAME=test \
+diff -urp libvirt-5.4.0.orig/tests/qemuxml2argvdata/graphics-vnc-tls.args libvirt-5.4.0/tests/qemuxml2argvdata/graphics-vnc-tls.args
+--- libvirt-5.4.0.orig/tests/qemuxml2argvdata/graphics-vnc-tls.args    2019-06-17 20:17:54.165000000 +0200
++++ libvirt-5.4.0/tests/qemuxml2argvdata/graphics-vnc-tls.args 2019-06-17 20:18:17.714000000 +0200
+@@ -6,7 +6,7 @@ LOGNAME=test \
XDG_DATA_HOME=/tmp/lib/domain--1-QEMUGuest1/.local/share \
XDG_CACHE_HOME=/tmp/lib/domain--1-QEMUGuest1/.cache \
XDG_CONFIG_HOME=/tmp/lib/domain--1-QEMUGuest1/.config \
 -SASL_CONF_PATH=/root/.sasl2 \
 +SASL_CONF_PATH=/root/.sasl \
  QEMU_AUDIO_DRV=none \
- /usr/bin/qemu \
+ /usr/bin/qemu-system-i686 \
  -name QEMUGuest1 \
-diff -urp libvirt-1.3.3.orig/tests/qemuxml2argvtest.c libvirt-1.3.3/tests/qemuxml2argvtest.c
---- libvirt-1.3.3.orig/tests/qemuxml2argvtest.c        2016-04-14 10:15:59.666170000 +0000
-+++ libvirt-1.3.3/tests/qemuxml2argvtest.c     2016-04-14 10:16:21.875170000 +0000
-@@ -897,7 +897,7 @@ mymain(void)
+diff -urp libvirt-5.4.0.orig/tests/qemuxml2argvtest.c libvirt-5.4.0/tests/qemuxml2argvtest.c
+--- libvirt-5.4.0.orig/tests/qemuxml2argvtest.c        2019-06-17 20:17:53.274000000 +0200
++++ libvirt-5.4.0/tests/qemuxml2argvtest.c     2019-06-17 20:18:17.715000000 +0200
+@@ -1145,7 +1145,7 @@ mymain(void)
  
      driver.config->vncSASL = 1;
      VIR_FREE(driver.config->vncSASLdir);
 -    ignore_value(VIR_STRDUP(driver.config->vncSASLdir, "/root/.sasl2"));
 +    ignore_value(VIR_STRDUP(driver.config->vncSASLdir, "/root/.sasl"));
-     DO_TEST("graphics-vnc-sasl", QEMU_CAPS_VNC);
+     DO_TEST("graphics-vnc-sasl", QEMU_CAPS_VNC, QEMU_CAPS_DEVICE_CIRRUS_VGA);
      driver.config->vncTLS = 1;
      driver.config->vncTLSx509verify = 1;
-@@ -919,7 +919,7 @@ mymain(void)
+@@ -1177,7 +1177,7 @@ mymain(void)
      DO_TEST("graphics-spice-no-args",
-             QEMU_CAPS_SPICE);
+             QEMU_CAPS_SPICE, QEMU_CAPS_DEVICE_CIRRUS_VGA);
      driver.config->spiceSASL = 1;
 -    ignore_value(VIR_STRDUP(driver.config->spiceSASLdir, "/root/.sasl2"));
 +    ignore_value(VIR_STRDUP(driver.config->spiceSASLdir, "/root/.sasl"));
      DO_TEST("graphics-spice-sasl",
-             QEMU_CAPS_VGA_QXL,
              QEMU_CAPS_SPICE,
+             QEMU_CAPS_DEVICE_QXL);
+diff -urp libvirt-5.4.0.orig/tests/virconfdata/libvirtd.conf libvirt-5.4.0/tests/virconfdata/libvirtd.conf
+--- libvirt-5.4.0.orig/tests/virconfdata/libvirtd.conf 2019-06-17 20:17:54.591000000 +0200
++++ libvirt-5.4.0/tests/virconfdata/libvirtd.conf      2019-06-17 20:18:17.715000000 +0200
+@@ -108,7 +108,7 @@ unix_sock_admin_perms = "0700"
+ #          the network providing auth (eg, TLS/x509 certificates)
+ #
+ #  - sasl: use SASL infrastructure. The actual auth scheme is then
+-#          controlled from /etc/sasl2/libvirt.conf. For the TCP
++#          controlled from /etc/sasl/libvirt.conf. For the TCP
+ #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
+ #          For non-TCP or TLS sockets,  any scheme is allowed.
+ #
+@@ -139,7 +139,7 @@ auth_unix_rw = "none"
+ # If you don't enable SASL, then all TCP traffic is cleartext.
+ # Don't do this outside of a dev/test scenario. For real world
+ # use, always enable SASL and use the GSSAPI or DIGEST-MD5
+-# mechanism in /etc/sasl2/libvirt.conf
++# mechanism in /etc/sasl/libvirt.conf
+ auth_tcp = "sasl"
+ # Change the authentication scheme for TLS sockets.
+diff -urp libvirt-5.4.0.orig/tests/virconfdata/libvirtd.out libvirt-5.4.0/tests/virconfdata/libvirtd.out
+--- libvirt-5.4.0.orig/tests/virconfdata/libvirtd.out  2019-06-17 20:17:54.591000000 +0200
++++ libvirt-5.4.0/tests/virconfdata/libvirtd.out       2019-06-17 20:18:17.715000000 +0200
+@@ -87,7 +87,7 @@ unix_sock_admin_perms = "0700"
+ #          the network providing auth (eg, TLS/x509 certificates)
+ #
+ #  - sasl: use SASL infrastructure. The actual auth scheme is then
+-#          controlled from /etc/sasl2/libvirt.conf. For the TCP
++#          controlled from /etc/sasl/libvirt.conf. For the TCP
+ #          socket only GSSAPI & DIGEST-MD5 mechanisms will be used.
+ #          For non-TCP or TLS sockets,  any scheme is allowed.
+ #
+@@ -116,7 +116,7 @@ auth_unix_rw = "none"
+ # If you don't enable SASL, then all TCP traffic is cleartext.
+ # Don't do this outside of a dev/test scenario. For real world
+ # use, always enable SASL and use the GSSAPI or DIGEST-MD5
+-# mechanism in /etc/sasl2/libvirt.conf
++# mechanism in /etc/sasl/libvirt.conf
+ auth_tcp = "sasl"
+ # Change the authentication scheme for TLS sockets.
+ #