]> TLD Linux GIT Repositories - packages/lighttpd.git/blobdiff - lighttpd.spec
- ehh, drop upstart leftovers again
[packages/lighttpd.git] / lighttpd.spec
index b11931e6b596a97bbc74abaa20a7cbe4235f5324..4d7f4834204990f10011ea1bf5893c09fc68fec1 100644 (file)
@@ -1,4 +1,3 @@
-
 # TODO:
 # - provide or autogenerate self signed cert in post, so after installing
 #   lighttpd-ssl server will still work
@@ -21,6 +20,7 @@
 %bcond_with    webdav_locks    # webdav locks with extra efsprogs deps
 %bcond_with    valgrind        # compile code with valgrind support.
 %bcond_with    deflate         # build deflate module (needs patch update with current svn)
+%bcond_with    h264_streaming          # build h264_streaming module
 
 %if %{with webdav_locks}
 %define                webdav_progs    1
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.35
-Release:       6
+Version:       1.4.39
+Release:       2
 License:       BSD
 Group:         Networking/Daemons/HTTP
-Source0:       http://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.bz2
-# Source0-md5: f7a88130ee9984b421ad8aa80629750a
+Source0:       http://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
+# Source0-md5: 63c7563be1c7a7a9819a51f07f1af8b2
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -90,7 +90,9 @@ Source135:    %{name}-mod_extforward.conf
 Source136:     %{name}-mod_h264_streaming.conf
 Source137:     %{name}-mod_cgi_php.conf
 Source138:     %{name}-mod_compress.tmpwatch
+# use branch.sh script to create branch.diff
 #Patch100:     %{name}-branch.diff
+## Patch100-md5:       cdcde8cb4632a42c5ae21d73aae9d34b
 Patch0:                %{name}-use_bin_sh.patch
 Patch1:                %{name}-mod_evasive-status_code.patch
 Patch2:                %{name}-mod_h264_streaming.patch
@@ -126,8 +128,10 @@ BuildRequires:     pkgconfig
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.647
 %{?with_webdav_props:BuildRequires:    sqlite3-devel}
+BuildRequires: tar >= 1:1.22
 %{?with_valgrind:BuildRequires:        valgrind}
 BuildRequires: which
+BuildRequires: xz
 BuildRequires: zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -827,14 +831,13 @@ Plik monitrc do monitorowania serwera www lighttpd.
 %prep
 %setup -q
 #%patch100 -p0
-#%patch4 -p0
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
+%{?with_h264_streaming:%patch2 -p1}
 %patch3 -p1
 %{?with_deflate:%patch5 -p1}
 %patch6 -p1
-%patch7 -p0
+%patch7 -p1
 
 rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead
 
@@ -844,6 +847,7 @@ cp -p %{SOURCE14} PLD-TODO
 
 %if "%{pld_release}" == "ac"
 %{__sed} -i -e 's/ serial_tests//' configure.ac
+%{__sed} -i -e 's/dist-xz/dist-bzip2/' configure.ac
 %endif
 
 %build
@@ -883,7 +887,7 @@ export LIGHTTPD_TEST_PORT=$((2048 + RANDOM % 10))
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig,init,monit}} \
+install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig,monit}} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{conf,vhosts,webapps}.d \
        $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}} \
        $RPM_BUILD_ROOT%{_datadir}/lighttpd/errordocs \
@@ -927,7 +931,9 @@ cp -p %{SOURCE109} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evasive.conf
 cp -p %{SOURCE110} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evhost.conf
 cp -p %{SOURCE112} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_fastcgi.conf
 cp -p %{SOURCE113} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_flv_streaming.conf
+%if %{with h264_streaming}
 cp -p %{SOURCE136} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_h264_streaming.conf
+%endif
 cp -p %{SOURCE114} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_indexfile.conf
 cp -p %{SOURCE115} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_proxy.conf
 cp -p %{SOURCE118} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_rrdtool.conf
@@ -1214,10 +1220,12 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_flv_streaming.conf
 %attr(755,root,root) %{_libdir}/mod_flv_streaming.so
 
+%if %{with h264_streaming}
 %files mod_h264_streaming
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_h264_streaming.conf
 %attr(755,root,root) %{_libdir}/mod_h264_streaming.so
+%endif
 
 %files mod_indexfile
 %defattr(644,root,root,755)