]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
883b926f1e6028b8acb935b97806d71a59c2ae7f
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - spec default value for --with-replicators (=internal/shared/none, configure default is none)?
4 #   (also internal vs shared for lvm1,pool,cluster,snapshots,mirrors,raid,replicators,thin,cache;
5 #    note: dmeventd requires mirrors=internal)
6 #
7 # Conditional build:
8 # - functionality
9 %bcond_without  cluster         # disable all cluster support (cmirrord)
10 %bcond_without  lvmdbusd        # lvmdbusd
11 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
12 %bcond_without  lvmlockd        # lvmlockd
13 %bcond_with     sanlock         # sanlock support in lvmlockd
14 %bcond_with     replicator      # internal replicator support
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17 # - bindings
18 %bcond_without  python          # Python bindings
19 %bcond_without  python2         # Python 2 binding
20 %bcond_without  python3         # Python 3 binding and lvmdbusd
21
22 # for convenience
23 %if %{without python}
24 %undefine       with_python2
25 %undefine       with_python3
26 %endif
27 %if %{without python3}
28 %undefine       with_lvmdbusd
29 %endif
30
31 %define         ver     2.03.11
32 %define         tgz_ver %(echo %{version} | tr . _)
33
34 Summary:        The new version of Logical Volume Manager for Linux
35 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
36 Name:           lvm2
37 Version:        %{ver}
38 Release:        1
39 License:        GPL v2 and LGPL v2.1
40 Group:          Applications/System
41 Source0:        https://github.com/lvmteam/lvm2/archive/v%{tgz_ver}.tar.gz
42 # Source0-md5:  98b9e5afc0c401e74255387e375f99c1
43 Patch0:         %{name}-selinux.patch
44 Patch1:         device-mapper-dmsetup-export.patch
45 Patch2:         %{name}-tld_init.patch
46 Patch3:         %{name}-run-dir.patch
47 Patch4:         device-mapper-dmsetup-deps-export.patch
48 Patch5:         %{name}-thin.patch
49 Patch6:         %{name}-no-systemd.patch
50 Patch7:         bashizm.patch
51 Patch8:         link.patch
52 URL:            http://www.sourceware.org/lvm2/
53 BuildRequires:  autoconf >= 2.69
54 BuildRequires:  automake
55 # for /run detection
56 BuildRequires:  filesystem >= 3.0-43
57 BuildRequires:  libblkid-devel >= 2.24
58 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
59 %{?with_selinux:BuildRequires:  libsepol-devel}
60 BuildRequires:  ncurses-devel
61 BuildRequires:  pkgconfig
62 %{?with_python2:BuildRequires:  python-devel >= 2}
63 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
64 %if %{with lvmdbusd}
65 BuildRequires:  python3-dbus
66 BuildRequires:  python3-pyudev
67 %endif
68 BuildRequires:  readline-devel
69 BuildRequires:  rpmbuild(macros) >= 1.647
70 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
71 BuildRequires:  udev-devel >= 1:176
72 %if %{with cluster}
73 BuildRequires:  corosync-devel
74 BuildRequires:  dlm-devel >= 3.99.5
75 %endif
76 Requires(post,postun):  /sbin/chkconfig
77 Requires:       device-mapper >= %{version}-%{release}
78 %{?with_selinux:Requires:       libselinux >= 1.10}
79 # doesn't work with 2.4 kernels
80 Requires:       uname(release) >= 2.6
81 Suggests:       thin-provisioning-tools >= 0.5.4
82 Obsoletes:      lvm
83 Obsoletes:      lvm2-clvmd
84 Obsoletes:      lvm2-systemd
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _sbindir        /sbin
88 %define         _usrsbindir     /usr/sbin
89
90 # changing CFLAGS in the middle confuses confcache
91 %undefine       configure_cache
92
93 # borken on AC
94 %define         filterout_ld    -Wl,--as-needed
95
96 # causes: undefined reference to `__stack_chk_fail_local'
97 %define         filterout_c     -fstack-protector
98
99 %define         skip_post_check_so      '.*(libdevmapper-event.so|libdevmapper-event-lvm2.so).*'
100
101 %description
102 This package includes a number of utilities for creating, checking,
103 and repairing logical volumes.
104
105 %description -l pl.UTF-8
106 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
107 logicznych wolumenów dyskowych (LVM2).
108
109 %package cmirrord
110 Summary:        Cluster mirror log daemon
111 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
112 Group:          Applications/System
113 Requires:       %{name} = %{version}-%{release}
114
115 %description cmirrord
116 cmirrord is the daemon that tracks mirror log information in a
117 cluster. It is specific to device-mapper based mirrors (and by
118 extension, LVM cluster mirrors). Cluster mirrors are not possible
119 without this daemon running.
120
121 This daemon relies on the cluster infrastructure provided by the
122 Cluster MANager (CMAN), which must be set up and running in order for
123 cmirrord to function.
124
125 %description cmirrord
126 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
127 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
128 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
129 lustrzanych ten demon jest niezbędny.
130
131 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
132 (Cluster MANager), który musi być skonfigurowany i działający, aby
133 działał cmirrord.
134
135 %package dbusd
136 Summary:        LVM2 D-Bus daemon
137 Summary(pl.UTF-8):      Demon LVM2 D-Bus
138 Group:          Daemons
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       python3-dbus
141 Requires:       python3-pygobject3 >= 3
142 Requires:       python3-pyudev
143
144 %description dbusd
145 Daemon for access to LVM2 functionality through a D-Bus interface.
146
147 %description dbusd -l pl.UTF-8
148 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
149 D-Bus.
150
151 %package lockd
152 Summary:        LVM2 locking daemon
153 Summary(pl.UTF-8):      Demon blokad LVM2
154 Group:          Daemons
155 Requires:       %{name} = %{version}-%{release}
156 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
157 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
158
159 %description lockd
160 LVM commands use lvmlockd to coordinate access to shared storage.
161
162 %description lockd -l pl.UTF-8
163 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
164 współdzielonej pamięci masowej.
165
166 %package resource-agents
167 Summary:        OCF Resource Agents for LVM2 processes
168 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
169 Group:          Applications/System
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       resource-agents
172
173 %description resource-agents
174 OCF Resource Agents for LVM2 processes.
175
176 %description resource-agents -l pl.UTF-8
177 Agenci OCF do monitorowania procesów LVM2.
178
179 %package -n python-lvm
180 Summary:        Python 2 interface to LVM2
181 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
182 Group:          Libraries/Python
183 Requires:       device-mapper-libs = %{version}-%{release}
184
185 %description -n python-lvm
186 Python 2 interface to LVM2.
187
188 %description -n python-lvm -l pl.UTF-8
189 Interfejs Pythona 2 do LVM2.
190
191 %package -n python3-lvm
192 Summary:        Python 3 interface to LVM2
193 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
194 Group:          Libraries/Python
195 Requires:       device-mapper-libs = %{version}-%{release}
196
197 %description -n python3-lvm
198 Python 3 interface to LVM2.
199
200 %description -n python3-lvm -l pl.UTF-8
201 Interfejs Pythona 3 do LVM2.
202
203 %package -n device-mapper
204 Summary:        Userspace support for the device-mapper
205 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
206 Group:          Base
207 Requires(post,postun):  /sbin/ldconfig
208 Requires:       device-mapper-libs = %{version}-%{release}
209
210 %description -n device-mapper
211 The goal of this driver is to support volume management. The driver
212 enables the definition of new block devices composed of ranges of
213 sectors of existing devices. This can be used to define disk
214 partitions - or logical volumes. This light-weight kernel component
215 can support user-space tools for logical volume management.
216
217 %description -n device-mapper -l pl.UTF-8
218 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
219 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
220 sektorów na istniejących urządzeniach. Może to być wykorzystane do
221 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
222 składnik jądra może wspierać działające w przestrzeni użytkownika
223 narzędzia do zarządzania logicznymi wolumenami.
224
225 %package -n device-mapper-libs
226 Summary:        Device-mapper shared libraries
227 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
228 Group:          Libraries
229 Requires:       libblkid >= 2.24
230 Requires:       udev-libs >= 1:176
231 Conflicts:      device-mapper < 2.02.119-1
232
233 %description -n device-mapper-libs
234 Device-mapper shared libraries.
235
236 %description -n device-mapper-libs -l pl.UTF-8
237 Biblioteki współdzielone device-mappera.
238
239 %package -n device-mapper-devel
240 Summary:        Header files for device-mapper libraries
241 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
242 Group:          Development/Libraries
243 Requires:       device-mapper-libs = %{version}-%{release}
244 Requires:       libblkid-devel >= 2.24
245 %if %{with selinux}
246 Requires:       libselinux-devel
247 Requires:       libsepol-devel
248 %endif
249 Requires:       udev-devel >= 1:176
250
251 %description -n device-mapper-devel
252 Header files for device-mapper libraries.
253
254 %description -n device-mapper-devel -l pl.UTF-8
255 Pliki nagłówkowe bibliotek device-mappera.
256
257 %package -n device-mapper-static
258 Summary:        Static devmapper library
259 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
260 License:        LGPL v2.1
261 Group:          Development/Libraries
262 Requires:       device-mapper-devel = %{version}-%{release}
263
264 %description -n device-mapper-static
265 Static devmapper library.
266
267 %description -n device-mapper-static -l pl.UTF-8
268 Statyczna biblioteka devmapper.
269
270 %package -n device-mapper-dietlibc
271 Summary:        Static devmapper library built with dietlibc
272 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
273 License:        LGPL v2.1
274 Group:          Development/Libraries
275 Requires:       device-mapper-devel = %{version}-%{release}
276
277 %description -n device-mapper-dietlibc
278 Static devmapper library built with dietlibc.
279
280 %description -n device-mapper-dietlibc -l pl.UTF-8
281 Statyczna biblioteka devmapper zbudowana z dietlibc.
282
283 %prep
284 %setup -q -n lvm2-%{tgz_ver}
285 %{?with_selinux:%patch0 -p1}
286 %patch1 -p1
287 %patch2 -p1
288 %patch3 -p1
289 %patch4 -p1
290 %patch5 -p1
291 %patch6 -p1
292 %patch7 -p1
293 %patch8 -p1
294
295 # do not force --export-symbol linker option for e.g. statically linked executables
296 # -rdynamic compiler option drives linker in the right way.
297 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.ac
298
299 %build
300 cp -f /usr/share/automake/config.sub autoconf
301 %{__aclocal}
302 %{__autoconf}
303
304 %configure \
305         --enable-applib \
306         --enable-cache_check_needs_check \
307         --enable-cmdlib \
308         %{?with_lvmdbusd:--enable-dbus-service} \
309         %{?debug:--enable-debug} \
310         --enable-dmeventd \
311         --enable-fsadm \
312         --with-default-locking-dir=/var/lock/lvm \
313 %if %{with lvmlockd}
314         %{?with_cluster:--enable-lvmlockd-dlm} \
315         %{?with_sanlock:--enable-lvmlockd-sanlock} \
316 %endif
317         --enable-lvmpolld \
318         --enable-ocf \
319         %{?with_python2:--enable-python2_bindings} \
320         %{?with_python3:--enable-python3_bindings} \
321         --enable-readline \
322         %{!?with_selinux:--disable-selinux} \
323         --enable-pkgconfig \
324         --enable-thin_check_needs_check \
325         --enable-udev_sync \
326         --enable-udev_rules \
327         --disable-udev-systemd-background-jobs \
328         --with-cache=internal \
329         --with-cache-check=/usr/sbin/cache_check \
330         --with-cache-dump=/usr/sbin/cache_dump \
331         --with-cache-repair=/usr/sbin/cache_repair \
332         --with-cache-restore=/usr/sbin/cache_restore \
333         --with-cluster=internal \
334 %if %{with cluster}
335         --enable-cmirrord \
336 %endif
337         --with-dmeventd-path=%{_sbindir}/dmeventd \
338         --with-interface=ioctl \
339         --with-lvm1=internal \
340         --with-mirrors=internal \
341         --with-optimisation="%{rpmcflags}" \
342         --with-pool=internal \
343         %{?with_replicator:--with-replicators=internal} \
344         --with-snapshots=internal \
345         --with-thin=internal \
346         --with-thin-check=/usr/sbin/thin_check \
347         --with-thin-dump=/usr/sbin/thin_dump \
348         --with-thin-repair=/usr/sbin/thin_repair \
349         --with-thin-restore=/usr/sbin/thin_restore \
350         --with-udev-prefix=/ \
351         --with-usrlibdir=%{_libdir}
352 # use bash because of "set -o pipefail"
353 %{__make} -j1 \
354         SHELL=/bin/bash
355 %{__make} -j1 -C libdm \
356         LIB_STATIC=libdevmapper.a
357
358 %install
359 rm -rf $RPM_BUILD_ROOT
360 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
361
362 %{__make} install install_system_dirs install_initscripts \
363         DESTDIR=$RPM_BUILD_ROOT \
364         OWNER="" \
365         GROUP="" \
366         python3dir=%{py3_sitescriptdir}
367
368 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
369 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
370         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
371         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
372         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
373 done
374
375 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
376
377 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
378
379 %clean
380 rm -rf $RPM_BUILD_ROOT
381
382 %triggerin -- lvm2 < 2.03.00
383 %service lvm2-lvmetad stop
384 /sbin/chkconfig --del lvm2-lvmetad
385
386 %triggerin -- lvm2-clvmd
387 %service clvmd stop
388 /sbin/chkconfig --del clvmd
389
390 %post
391 /sbin/chkconfig --add lvm2-monitor
392 %service lvm2-monitor restart
393 /sbin/chkconfig --add lvm2-lvmpolld
394 %service lvm2-lvmpolld restart
395 # no service restart available
396 /sbin/chkconfig --add blk-availability
397 # no service blk-availability restart
398
399 %preun
400 if [ "$1" = "0" ]; then
401         %service lvm2-lvmpolld stop
402         /sbin/chkconfig --del lvm2-lvmpolld
403         %service lvm2-monitor stop
404         /sbin/chkconfig --del lvm2-monitor
405         #no service blk-availability stop
406         /sbin/chkconfig --del blk-availability
407 fi
408
409 %post   -n device-mapper-libs -p /sbin/ldconfig
410 %postun -n device-mapper-libs -p /sbin/ldconfig
411
412 %files
413 %defattr(644,root,root,755)
414 %doc README WHATS_NEW doc/*
415 %attr(755,root,root) %{_sbindir}/blkdeactivate
416 %attr(755,root,root) %{_sbindir}/fsadm
417 %attr(755,root,root) %{_sbindir}/lvchange
418 %attr(755,root,root) %{_sbindir}/lvconvert
419 %attr(755,root,root) %{_sbindir}/lvcreate
420 %attr(755,root,root) %{_sbindir}/lvdisplay
421 %attr(755,root,root) %{_sbindir}/lvextend
422 %attr(755,root,root) %{_sbindir}/lvm
423 %attr(755,root,root) %{_sbindir}/lvmconfig
424 %attr(755,root,root) %{_sbindir}/lvmdiskscan
425 %attr(755,root,root) %{_sbindir}/lvmdump
426 %attr(755,root,root) %{_sbindir}/lvmsadc
427 %attr(755,root,root) %{_sbindir}/lvmsar
428 %attr(755,root,root) %{_sbindir}/lvreduce
429 %attr(755,root,root) %{_sbindir}/lvremove
430 %attr(755,root,root) %{_sbindir}/lvrename
431 %attr(755,root,root) %{_sbindir}/lvresize
432 %attr(755,root,root) %{_sbindir}/lvs
433 %attr(755,root,root) %{_sbindir}/lvscan
434 %attr(755,root,root) %{_sbindir}/pvchange
435 %attr(755,root,root) %{_sbindir}/pvck
436 %attr(755,root,root) %{_sbindir}/pvcreate
437 %attr(755,root,root) %{_sbindir}/pvdisplay
438 %attr(755,root,root) %{_sbindir}/pvmove
439 %attr(755,root,root) %{_sbindir}/pvremove
440 %attr(755,root,root) %{_sbindir}/pvresize
441 %attr(755,root,root) %{_sbindir}/pvs
442 %attr(755,root,root) %{_sbindir}/pvscan
443 %attr(755,root,root) %{_sbindir}/vgcfgbackup
444 %attr(755,root,root) %{_sbindir}/vgcfgrestore
445 %attr(755,root,root) %{_sbindir}/vgchange
446 %attr(755,root,root) %{_sbindir}/vgck
447 %attr(755,root,root) %{_sbindir}/vgconvert
448 %attr(755,root,root) %{_sbindir}/vgcreate
449 %attr(755,root,root) %{_sbindir}/vgdisplay
450 %attr(755,root,root) %{_sbindir}/vgexport
451 %attr(755,root,root) %{_sbindir}/vgextend
452 %attr(755,root,root) %{_sbindir}/vgimport
453 %attr(755,root,root) %{_sbindir}/vgimportclone
454 %attr(755,root,root) %{_sbindir}/vgmerge
455 %attr(755,root,root) %{_sbindir}/vgmknodes
456 %attr(755,root,root) %{_sbindir}/vgreduce
457 %attr(755,root,root) %{_sbindir}/vgremove
458 %attr(755,root,root) %{_sbindir}/vgrename
459 %attr(755,root,root) %{_sbindir}/vgs
460 %attr(755,root,root) %{_sbindir}/vgscan
461 %attr(755,root,root) %{_sbindir}/vgsplit
462 %{_mandir}/man5/lvm.conf.5*
463 %{_mandir}/man7/lvmcache.7*
464 %{_mandir}/man7/lvmraid.7*
465 %{_mandir}/man7/lvmreport.7*
466 %{_mandir}/man7/lvmsystemid.7*
467 %{_mandir}/man7/lvmthin.7*
468 %{_mandir}/man7/lvmvdo.7*
469 %{_mandir}/man8/blkdeactivate.8*
470 %{_mandir}/man8/fsadm.8*
471 %{_mandir}/man8/lvchange.8*
472 %{_mandir}/man8/lvconvert.8*
473 %{_mandir}/man8/lvcreate.8*
474 %{_mandir}/man8/lvdisplay.8*
475 %{_mandir}/man8/lvextend.8*
476 %{_mandir}/man8/lvm-config.8*
477 %{_mandir}/man8/lvm-dumpconfig.8*
478 %{_mandir}/man8/lvm-fullreport.8*
479 %{_mandir}/man8/lvm-lvpoll.8*
480 %{_mandir}/man8/lvm.8*
481 %{_mandir}/man8/lvmconfig.8*
482 %{_mandir}/man8/lvmdiskscan.8*
483 %{_mandir}/man8/lvmdump.8*
484 %{_mandir}/man8/lvmsadc.8*
485 %{_mandir}/man8/lvmsar.8*
486 %{_mandir}/man8/lvreduce.8*
487 %{_mandir}/man8/lvremove.8*
488 %{_mandir}/man8/lvrename.8*
489 %{_mandir}/man8/lvresize.8*
490 %{_mandir}/man8/lvs.8*
491 %{_mandir}/man8/lvscan.8*
492 %{_mandir}/man8/pvchange.8*
493 %{_mandir}/man8/pvck.8*
494 %{_mandir}/man8/pvcreate.8*
495 %{_mandir}/man8/pvdisplay.8*
496 %{_mandir}/man8/pvmove.8*
497 %{_mandir}/man8/pvremove.8*
498 %{_mandir}/man8/pvresize.8*
499 %{_mandir}/man8/pvs.8*
500 %{_mandir}/man8/pvscan.8*
501 %{_mandir}/man8/vgcfgbackup.8*
502 %{_mandir}/man8/vgcfgrestore.8*
503 %{_mandir}/man8/vgchange.8*
504 %{_mandir}/man8/vgck.8*
505 %{_mandir}/man8/vgconvert.8*
506 %{_mandir}/man8/vgcreate.8*
507 %{_mandir}/man8/vgdisplay.8*
508 %{_mandir}/man8/vgexport.8*
509 %{_mandir}/man8/vgextend.8*
510 %{_mandir}/man8/vgimport.8*
511 %{_mandir}/man8/vgimportclone.8*
512 %{_mandir}/man8/vgmerge.8*
513 %{_mandir}/man8/vgmknodes.8*
514 %{_mandir}/man8/vgreduce.8*
515 %{_mandir}/man8/vgremove.8*
516 %{_mandir}/man8/vgrename.8*
517 %{_mandir}/man8/vgs.8*
518 %{_mandir}/man8/vgscan.8*
519 %{_mandir}/man8/vgsplit.8*
520 %attr(750,root,root) %dir %{_sysconfdir}/lvm
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
523 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
527 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
528 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
529 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
530 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
531 %dir %{_sysconfdir}/lvm/cache
532 %ghost %{_sysconfdir}/lvm/cache/.cache
533 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
534 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
535 %attr(700,root,root) %dir /var/run/lvm
536 %attr(700,root,root) %dir /var/lock/lvm
537 %if %{with lvmlockd}
538 %attr(755,root,root) %{_sbindir}/lvmlockctl
539 %attr(755,root,root) %{_sbindir}/lvmlockd
540 %{_mandir}/man8/lvmlockctl.8*
541 %{_mandir}/man8/lvmlockd.8*
542 %endif
543 %if %{with lvmpolld}
544 %attr(755,root,root) %{_sbindir}/lvmpolld
545 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
546 %{_mandir}/man8/lvmpolld.8*
547 %endif
548
549 %if %{with cluster}
550 %files cmirrord
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_usrsbindir}/cmirrord
553 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
554 %{_mandir}/man8/cmirrord.8*
555 %endif
556
557 %if %{with lvmdbusd}
558 %files dbusd
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_sbindir}/lvmdbusd
561 %{py3_sitescriptdir}/lvmdbusd
562 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
563 %{_mandir}/man8/lvmdbusd.8*
564 %endif
565
566 %files resource-agents
567 %defattr(644,root,root,755)
568 %dir %{_prefix}/lib/ocf/resource.d/lvm2
569 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
570
571 %if %{with python2}
572 %files -n python-lvm
573 %defattr(644,root,root,755)
574 #%attr(755,root,root) %{py_sitedir}/lvm.so
575 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
576 %endif
577
578 %if %{with python3}
579 %files -n python3-lvm
580 %defattr(644,root,root,755)
581 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
582 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
583 %endif
584
585 %files -n device-mapper
586 %defattr(644,root,root,755)
587 %doc *_DM
588 /lib/udev/rules.d/10-dm.rules
589 /lib/udev/rules.d/11-dm-lvm.rules
590 /lib/udev/rules.d/13-dm-disk.rules
591 /lib/udev/rules.d/69-dm-lvm-metad.rules
592 /lib/udev/rules.d/95-dm-notify.rules
593 %attr(755,root,root) %{_sbindir}/dmeventd
594 %attr(755,root,root) %{_sbindir}/dmsetup
595 %attr(755,root,root) %{_sbindir}/dmstats
596 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
597 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
598 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
599 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
600 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
601 %dir %{_libdir}/device-mapper
602 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
603 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
604 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
605 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
606 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
607 %{_mandir}/man8/dmsetup.8*
608 %{_mandir}/man8/dmstats.8*
609 %{_mandir}/man8/dmeventd.8*
610
611 %files -n device-mapper-libs
612 %defattr(644,root,root,755)
613 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
614 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
615 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
616 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
617
618 %files -n device-mapper-devel
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/libdevmapper.so
621 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
622 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
623 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
624 %{_includedir}/libdevmapper.h
625 %{_includedir}/libdevmapper-event.h
626 %{_includedir}/lvm2cmd.h
627 %{_pkgconfigdir}/devmapper.pc
628 %{_pkgconfigdir}/devmapper-event.pc
629
630 %files -n device-mapper-static
631 %defattr(644,root,root,755)
632 %{_libdir}/libdevmapper.a