]> TLD Linux GIT Repositories - packages/lvm2.git/blobdiff - lvm2.spec
- updated to 2.02.166
[packages/lvm2.git] / lvm2.spec
index 1c1283817a1d4aabf08ccd4ca878f0a5272d5698..f583adf7ce4849b320d93cf17149d942764e9930 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
@@ -14,7 +14,8 @@
 %bcond_with    sanlock         # sanlock support in lvmlockd
 %bcond_with    replicator      # internal replicator support
 %bcond_without selinux         # SELinux support
-%bcond_without python          # Python binding
+%bcond_without python2         # Python 2.x binding
+%bcond_without python3         # Python 3.x binding
 
 # lvmlockd requires lvmetad and lvmpolld
 %if %{without lvmetad} || %{without lvmpolld}
 Summary:       The new version of Logical Volume Manager for Linux
 Summary(pl.UTF-8):     Nowa wersja Logical Volume Managera dla Linuksa
 Name:          lvm2
-Version:       2.02.140
+Version:       2.02.166
 Release:       1
 License:       GPL v2 and LGPL v2.1
 Group:         Applications/System
 Source0:       ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
-# Source0-md5: f2191c4798c8927a6d31a96010b9f568
+# Source0-md5: c5a54ee0b86703daaad6e856439e115a
 Source1:       clvmd.sysconfig
 Patch0:                %{name}-selinux.patch
 Patch1:                %{name}-diet.patch
@@ -59,13 +60,18 @@ URL:                http://www.sourceware.org/lvm2/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
 # for /run detection
+BuildRequires: autoconf-archive
 BuildRequires: filesystem >= 3.0-43
 BuildRequires: libblkid-devel >= 2.24
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.10}
 %{?with_selinux:BuildRequires: libsepol-devel}
 BuildRequires: ncurses-devel
 BuildRequires: pkgconfig
-%{?with_python:BuildRequires:  python-devel >= 2}
+%{?with_python2:BuildRequires: python-devel >= 1:2.6}
+%if %{with python3}
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-modules >= 1:3.2
+%endif
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.647
 %{?with_sanlock:BuildRequires: sanlock-devel >= 3.2.4}
@@ -204,6 +210,18 @@ Python interface to LVM2.
 %description -n python-lvm -l pl.UTF-8
 Interfejs Pythona do LVM2.
 
+%package -n python3-lvm
+Summary:       Python interface to LVM2
+Summary(pl.UTF-8):     Interfejs Pythona do LVM2
+Group:         Libraries/Python
+Requires:      device-mapper-libs = %{version}-%{release}
+
+%description -n python3-lvm
+Python interface to LVM2.
+
+%description -n python3-lvm -l pl.UTF-8
+Interfejs Pythona do LVM2.
+
 %package -n device-mapper
 Summary:       Userspace support for the device-mapper
 Summary(pl.UTF-8):     Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
@@ -392,7 +410,8 @@ unset CC
 %endif
        %{?with_lvmetad:--enable-lvmetad} \
        --enable-ocf \
-       %{?with_python:--enable-python_bindings} \
+       %{?with_python2:--enable-python2-bindings} \
+       %{?with_python3:--enable-python3-bindings} \
        --enable-readline \
        %{!?with_selinux:--disable-selinux} \
        --enable-pkgconfig \
@@ -513,6 +532,8 @@ fi
 %attr(755,root,root) %{_sbindir}/vg*
 %{_mandir}/man5/lvm.conf.5*
 %{_mandir}/man7/lvmcache.7*
+%{_mandir}/man7/lvmraid.7*
+%{_mandir}/man7/lvmreport.7*
 %{_mandir}/man7/lvmsystemid.7*
 %{_mandir}/man7/lvmthin.7*
 %{_mandir}/man8/blkdeactivate.8*
@@ -527,6 +548,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
@@ -566,13 +588,20 @@ fi
 %dir %{_prefix}/lib/ocf/resource.d/lvm2
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
 
-%if %{with python}
+%if %{with python2}
 %files -n python-lvm
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/lvm.so
 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
 %endif
 
+%if %{with python3}
+%files -n python3-lvm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py3_sitedir}/lvm*.so
+%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
+%endif
+
 %files -n device-mapper
 %defattr(644,root,root,755)
 %doc *_DM