]> TLD Linux GIT Repositories - packages/lvm2.git/commitdiff
- updated to 2.02.140
authorMarcin Krol <hawk@tld-linux.org>
Wed, 20 Jan 2016 07:18:33 +0000 (07:18 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 20 Jan 2016 07:18:33 +0000 (07:18 +0000)
device-mapper-dmsetup-export.patch
lvm2-diet.patch
lvm2.spec

index 7ea1a4b863041b9e12b4f26be63f13867937bde1..53c3ba7bc4b390f457b6987f12b4b97d23cca944 100644 (file)
@@ -7,35 +7,38 @@ Index: LVM2.2.02.98/man/dmsetup.8.in
 ===================================================================
 --- LVM2.2.02.116.orig/man/dmsetup.8.in        2015-01-30 16:19:53.000000000 +0000
 +++ LVM2.2.02.116/man/dmsetup.8.in     2015-02-03 21:05:01.635601115 +0000
-@@ -19,6 +19,9 @@ dmsetup \(em low level logical volume ma
- .IR options ]
- .RI [ device_name ]
+@@ -48,6 +48,14 @@ dmsetup \(em low level logical volume ma
+ .
  .HP
-+.B dmsetup export
-+.RI [ device_name ]
+ .B dmsetup
++.de CMD_EXPORT
++.  BR export
++.  RI [ device_name ]
++..
++.CMD_EXPORT
++.
 +.HP
- .B dmsetup help
- .RB [ \-c | \-C | \-\-columns ]
- .HP
-@@ -309,6 +312,11 @@ device_name in subsequent dmsetup comman
- \fBblkdevname\fP (block device name),
++.B dmsetup
+ .de CMD_HELP
+ .  BR help
+ .  RB [ \-c | \-C | \-\-columns ]
+@@ -629,6 +637,11 @@ device. Device names on output can be cu
  \fBdevname\fP (map name for device-mapper devices, equal to blkdevname otherwise).
+ .
  .HP
-+.B export
-+.RI [ device_name ]
++.CMD_EXPORT
 +.br
 +Outputs information in key/value format to be imported by other programs.
++.
 +.HP
- .B help
- .RB [ \-c | \-C | \-\-columns ]
+ .CMD_HELP
  .br
+ Outputs a summary of the commands available, optionally including
 Index: LVM2.2.02.98/tools/dmsetup.c
 ===================================================================
 --- LVM2.2.02.98.orig/tools/dmsetup.c
 +++ LVM2.2.02.98/tools/dmsetup.c
-@@ -1706,10 +1706,97 @@ static int _status(CMD_ARGS)
-       out:
-       dm_task_destroy(dmt);
+@@ -2194,6 +2194,93 @@ out:
        return r;
  }
  
@@ -129,11 +132,7 @@ Index: LVM2.2.02.98/tools/dmsetup.c
  /* Show target names and their version numbers */
  static int _targets(CMD_ARGS)
  {
-       int r = 0;
-       struct dm_task *dmt;
-@@ -3056,10 +3143,11 @@ static struct command _commands[] = {
-       {"ls", "[--target <target_type>] [--exec <command>] [-o <options>] [--tree]", 0, 0, 0, 0, _ls},
-       {"info", "[<device>]", 0, -1, 1, 0, _info},
+@@ -5155,6 +5242,7 @@ static struct command _dmsetup_commands[
        {"deps", "[-o <options>] [<device>]", 0, -1, 1, 0, _deps},
        {"stats", "<command> [<options>] [<devices>]", 1, -1, 1, 1, _stats},
        {"status", "[<device>] [--noflush] [--target <target_type>]", 0, -1, 1, 0, _status},
@@ -141,5 +140,3 @@ Index: LVM2.2.02.98/tools/dmsetup.c
        {"table", "[<device>] [--target <target_type>] [--showkeys]", 0, -1, 1, 0, _status},
        {"wait", "<device> [<event_nr>] [--noflush]", 0, 2, 0, 0, _wait},
        {"mknodes", "[<device>]", 0, -1, 1, 0, _mknodes},
-       {"mangle", "[<device>]", 0, -1, 1, 0, _mangle},
-       {"udevcreatecookie", "", 0, 0, 0, 0, _udevcreatecookie},
index 1799ebc8ac594cdb0da5c572e1444ad60a00e315..8ca191f8e5947018047d238bf7339cc2245037ab 100644 (file)
 
 --- LVM2.2.02.105/tools/Makefile.in.orig       2014-01-26 18:33:51.531497416 +0100
 +++ LVM2.2.02.105/tools/Makefile.in    2014-01-26 19:14:42.264728615 +0100
-@@ -127,20 +127,20 @@
+@@ -128,20 +128,19 @@
  CFLAGS_dmsetup.o += $(UDEV_CFLAGS) $(EXTRA_EXEC_CFLAGS)
  
  dmsetup: dmsetup.o $(top_builddir)/libdm/libdevmapper.$(LIB_SUFFIX)
  
  dmsetup.static: dmsetup.o $(interfacebuilddir)/libdevmapper.a
 -      $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) \
--            -o $@ dmsetup.o -ldevmapper $(STATIC_LIBS) $(LIBS)
+-            -o $@ dmsetup.o -ldevmapper $(M_LIBS) $(PTHREAD_LIBS) $(STATIC_LIBS) $(LIBS)
+-
 +      $(CC) $(CFLAGS) -static -L$(interfacebuilddir) $(LDFLAGS) \
-+            -o $@ dmsetup.o -ldevmapper $(STATIC_LIBS) $(LIBS) $(PTHREAD_LIBS) $(DIETLIBC_LIBS)
++              -o $@ dmsetup.o -ldevmapper $(STATIC_LIBS) $(LIBS) $(PTHREAD_LIBS) $(DIETLIBC_LIBS)
  all: device-mapper
  
  CFLAGS_lvm.o += $(EXTRA_EXEC_CFLAGS)
                $(LVMLIBS) $(READLINE_LIBS) $(LIBS) -rdynamic
  
  ifeq ("@BUILD_LVMETAD@", "yes")
-@@ -148,7 +148,7 @@
+@@ -150,7 +149,7 @@
  
  lvm.static: $(OBJECTS) lvm-static.o $(top_builddir)/lib/liblvm-internal.a  $(interfacebuilddir)/libdevmapper.a
        $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) -o $@ \
index 5cd551d736702566ac6fc1ef7a0e75f6c10639c9..1c1283817a1d4aabf08ccd4ca878f0a5272d5698 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
 Summary:       The new version of Logical Volume Manager for Linux
 Summary(pl.UTF-8):     Nowa wersja Logical Volume Managera dla Linuksa
 Name:          lvm2
-Version:       2.02.132
-Release:       4
+Version:       2.02.140
+Release:       1
 License:       GPL v2 and LGPL v2.1
 Group:         Applications/System
 Source0:       ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
-# Source0-md5: 80af5af726949bbbb2aceb15b24b7d20
+# Source0-md5: f2191c4798c8927a6d31a96010b9f568
 Source1:       clvmd.sysconfig
 Patch0:                %{name}-selinux.patch
 Patch1:                %{name}-diet.patch