]> TLD Linux GIT Repositories - packages/lvm2.git/commitdiff
- fixed post/postun broken by PLD merge
authorMarcin Krol <hawk@tld-linux.org>
Mon, 16 Apr 2018 09:39:19 +0000 (09:39 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 16 Apr 2018 09:39:19 +0000 (09:39 +0000)
lvm2.spec

index ff787b375cdd9c875d3eebed652e44c353b0cf18..de25117084f8f24557096394cf1bf3dfb4ef6b56 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
 %undefine      with_lvmpolld
 %endif
 
-# only glibc possible on SPARC
-%ifarch sparc sparcv9 sparc64
-%define                with_glibc 1
-%endif
 # if one of the *libc is enabled disable default dietlibc
 %if %{with dietlibc} && %{with uClibc}
 %undefine      with_dietlibc
@@ -539,13 +535,22 @@ cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
 rm -rf $RPM_BUILD_ROOT
 
 %post
+/sbin/chkconfig --add lvm2-lvmetad
+%service lvm2-lvmetad restart
 /sbin/chkconfig --add lvm2-monitor
 %service lvm2-monitor restart
+/sbin/chkconfig --add lvm2-lvmpolld
+%service lvm2-lvmpolld restart
+# no service restart available
 /sbin/chkconfig --add blk-availability
 # no service blk-availability restart
 
 %postun
 if [ "$1" = "0" ]; then
+       %service lvm2-lvmetad stop
+       /sbin/chkconfig --del lvm2-lvmetad
+       %service lvm2-lvmpolld stop
+       /sbin/chkconfig --del lvm2-lvmpolld
        %service lvm2-monitor stop
        /sbin/chkconfig --del lvm2-monitor
        #no service blk-availability stop