]> TLD Linux GIT Repositories - packages/lxappearance.git/blob - lxappearance.spec
ca2c41d0ec8decb8d20a76de2fcd2a9d85be0093
[packages/lxappearance.git] / lxappearance.spec
1 #
2 # Conditional build:
3 %bcond_with             gtk3    # build GTK+3 disables GTK+2
4 %bcond_without          gtk2    # build with GTK+2
5
6 %if %{with gtk3}
7 %undefine       with_gtk2
8 %endif
9
10 Summary:        Desktop-independent theme switcher for GTK+
11 Name:           lxappearance
12 Version:        0.6.1
13 Release:        3
14 License:        GPL v3
15 Group:          X11/Applications
16 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
17 # Source0-md5:  79740125628a8374c1101cf26e558fa5
18 Patch0:         mate-desktop.patch
19 URL:            http://wiki.lxde.org/en/LXAppearance
20 BuildRequires:  gettext-tools
21 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
22 %{?with_gtk3:BuildRequires:     gtk+3-devel}
23 BuildRequires:  intltool
24 BuildRequires:  pkgconfig
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 LXAppearance is part of LXDE project. It's a desktop-independent theme
31 switcher for GTK+.
32
33 %package devel
34 Summary:        Header files for lxappearance
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for lxappearance.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44
45 %build
46 %configure \
47         %{?with_gtk3:--enable-gtk3}
48 %{__make} V=1
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT%{_libdir}/lxappearance/plugins
56
57 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/tt_RU
58
59 %find_lang %{name}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files -f %{name}.lang
65 %defattr(644,root,root,755)
66 %doc AUTHORS README
67 %attr(755,root,root) %{_bindir}/lxappearance
68 %dir %{_libdir}/lxappearance
69 %dir %{_libdir}/lxappearance/plugins
70 %{_mandir}/man1/lxappearance.1*
71 %{_desktopdir}/lxappearance.desktop
72 %{_datadir}/lxappearance
73
74 %files devel
75 %defattr(644,root,root,755)
76 %dir %{_includedir}/lxappearance
77 %{_includedir}/lxappearance/lxappearance.h
78 %{_pkgconfigdir}/lxappearance.pc