]> TLD Linux GIT Repositories - packages/lxappearance.git/blob - lxappearance.spec
d44abe51181c24858d95274a9c85e5dec499cafc
[packages/lxappearance.git] / lxappearance.spec
1 # Conditional build:
2 %bcond_with             gtk3    # build GTK+3 disables GTK+2
3 %bcond_without          gtk2    # build with GTK+2
4
5 %if %{with gtk3}
6 %undefine       with_gtk2
7 %endif
8
9 Summary:        Desktop-independent theme switcher for GTK+
10 Name:           lxappearance
11 Version:        0.6.2
12 Release:        1
13 License:        GPL v3
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
16 # Source0-md5:  21ee79c7686a80efddaa1b7928f51e21
17 URL:            http://wiki.lxde.org/en/LXAppearance
18 BuildRequires:  gettext-tools
19 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
20 %{?with_gtk3:BuildRequires:     gtk+3-devel}
21 BuildRequires:  intltool
22 BuildRequires:  pkgconfig
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 LXAppearance is part of LXDE project. It's a desktop-independent theme
29 switcher for GTK+.
30
31 %package devel
32 Summary:        Header files for lxappearance
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Header files for lxappearance.
38
39 %prep
40 %setup -q
41
42 %build
43 %configure \
44         %{?with_gtk3:--enable-gtk3}
45 %{__make} V=1
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_libdir}/lxappearance/plugins
53
54 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/tt_RU
55
56 %find_lang %{name}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files -f %{name}.lang
62 %defattr(644,root,root,755)
63 %doc AUTHORS README
64 %attr(755,root,root) %{_bindir}/lxappearance
65 %dir %{_libdir}/lxappearance
66 %dir %{_libdir}/lxappearance/plugins
67 %{_mandir}/man1/lxappearance.1*
68 %{_desktopdir}/lxappearance.desktop
69 %{_datadir}/lxappearance
70
71 %files devel
72 %defattr(644,root,root,755)
73 %dir %{_includedir}/lxappearance
74 %{_includedir}/lxappearance/lxappearance.h
75 %{_pkgconfigdir}/lxappearance.pc