]> TLD Linux GIT Repositories - packages/lxlauncher.git/blob - lxlauncher.spec
a2f70c65f897cd8d58bf5f8747eb07350608c303
[packages/lxlauncher.git] / lxlauncher.spec
1 # Conditional build:
2 %bcond_with             gtk3    # build GTK+3 disables GTK+2
3 %bcond_without          gtk2    # build with GTK+2
4
5 %if %{with gtk3}
6 %undefine       with_gtk2
7 %endif
8
9 Summary:        lxlauncher
10 Name:           lxlauncher
11 Version:        0.2.4
12 Release:        1
13 License:        GPL v3
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
16 # Source0-md5:  8a21590c085ad82f4f50e4affb7ad0ab
17 URL:            http://wiki.lxde.org/en/LXLauncher
18 BuildRequires:  gettext-tools
19 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
20 %{?with_gtk3:BuildRequires:     gtk+3-devel}
21 BuildRequires:  intltool >= 0.40.0
22 BuildRequires:  menu-cache-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  startup-notification-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 LXLauncher is an open source clone of Asus launcher for EeePC. It
29 outperformes the original launcher developed by Xandros.
30
31 %prep
32 %setup -q
33
34 %build
35 %configure \
36         %{?with_gtk3:--enable-gtk3}
37 touch po/stamp-it
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 # there is no frp locale so drop frp
47 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/{frp,ur_PK}
48 mv $RPM_BUILD_ROOT%{_datadir}/locale/tt{_RU,}
49
50 %find_lang %{name}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files -f %{name}.lang
56 %defattr(644,root,root,755)
57 %doc AUTHORS README NEWS
58 %{_sysconfdir}/xdg/lxlauncher
59 %{_sysconfdir}/xdg/menus/lxlauncher-applications.menu
60 %attr(755,root,root) %{_bindir}/lxlauncher
61 %{_datadir}/desktop-directories/*directory