]> TLD Linux GIT Repositories - packages/lxpanel.git/blob - lxpanel.spec
- add required ldconfig stuff
[packages/lxpanel.git] / lxpanel.spec
1 # TODO:  /etc/xdg/lxpanel - proper tags/flags etc.
2 %bcond_with             gtk3    # build GTK+3 disables GTK+2
3 %bcond_without          gtk2    # build with GTK+2
4 Summary:        LXPanel is a lightweight X11 desktop panel
5 Name:           lxpanel
6 Version:        0.8.2
7 Release:        2
8 License:        GPL v2
9 Group:          X11/Applications
10 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
11 # Source0-md5:  8d7c93c4ebb4af8bf436ef6d3aee4ea9
12 URL:            http://wiki.lxde.org/en/LXPanel
13 BuildRequires:  autoconf
14 BuildRequires:  automake >= 1:1.12
15 BuildRequires:  alsa-lib-devel
16 BuildRequires:  gettext-tools
17 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
18 %{?with_gtk3:BuildRequires:     gtk+3-devel}
19 BuildRequires:  intltool
20 BuildRequires:  keybinder-devel
21 BuildRequires:  libfm-devel
22 BuildRequires:  libiw-devel
23 BuildRequires:  libwnck2-devel
24 BuildRequires:  libtool
25 BuildRequires:  menu-cache-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires(post,postun):  /sbin/ldconfig
30 Requires:       lxmenu-data
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 LXPanel is a lightweight X11 desktop panel.
35
36 %package devel
37 Summary:        Header files for lxpanel library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxpanel
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for lxpanel library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki lxpanel.
47
48 %prep
49 %setup -q
50
51 %build
52 %{__aclocal}
53 %{__autoheader}
54 %{__libtoolize}
55 %{__intltoolize}
56 %{__automake}
57 %{__autoconf}
58 %configure \
59         %{?with_gtk3:--enable-gtk3}
60 %{__make} V=1
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT/etc/ld.so.conf.d
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %if "%{_lib}" == "lib64"
69 echo "%{_libdir}/lxpanel" >$RPM_BUILD_ROOT/etc/ld.so.conf.d/lxpanel64.conf
70 %else
71 echo "%{_libdir}/lxpanel" >$RPM_BUILD_ROOT/etc/ld.so.conf.d/lxpanel.conf
72 %endif
73
74 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/{frp,ur_PK,tt_RU}
75
76 %find_lang %{name}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 /sbin/ldconfig
83
84 %postun
85 /sbin/ldconfig
86
87 %files -f %{name}.lang
88 %defattr(644,root,root,755)
89 %doc AUTHORS README
90 %if "%{_lib}" == "lib64"
91 /etc/ld.so.conf.d/lxpanel64.conf
92 %else
93 /etc/ld.so.conf.d/lxpanel.conf
94 %endif
95 %attr(755,root,root) %{_bindir}/lxpanel
96 %attr(755,root,root) %{_bindir}/lxpanelctl
97 %dir %{_libdir}/lxpanel
98 %attr(755,root,root) %{_libdir}/lxpanel/liblxpanel.so.*.*.*
99 %attr(755,root,root) %ghost /%{_libdir}/lxpanel/liblxpanel.so.0
100 %dir %{_libdir}/lxpanel/plugins
101 %attr(755,root,root) %{_libdir}/lxpanel/plugins/*.so
102 %{_mandir}/man1/lxpanel.1*
103 %{_mandir}/man1/lxpanelctl.1*
104
105 %dir %{_datadir}/lxpanel
106 ##%{_datadir}/lxpanel/profile
107 %{_datadir}/lxpanel/ui
108
109 %dir %{_datadir}/lxpanel/images
110 %{_datadir}/lxpanel/images/*.png
111
112 %dir %{_datadir}/lxpanel/images/xkb-flags
113 # TODO: lang tags here
114 %{_datadir}/lxpanel/images/xkb-flags/*.png
115
116 %dir %{_datadir}/lxpanel/xkeyboardconfig
117 %{_datadir}/lxpanel/xkeyboardconfig/*.cfg
118
119 %{_sysconfdir}/xdg/lxpanel
120
121 %files devel
122 %defattr(644,root,root,755)
123 %dir %{_includedir}/lxpanel
124 %{_includedir}/lxpanel/*.h
125 %{_pkgconfigdir}/lxpanel.pc
126 %attr(755,root,root) %{_libdir}/lxpanel/liblxpanel.so