]> TLD Linux GIT Repositories - packages/lxpanel.git/blob - lxpanel.spec
3f2600269fc1147e951ddeda0649446ea04542c9
[packages/lxpanel.git] / lxpanel.spec
1 # TODO:  /etc/xdg/lxpanel - proper tags/flags etc.
2 %bcond_with             gtk3    # build GTK+3 disables GTK+2
3 %bcond_without          gtk2    # build with GTK+2
4 Summary:        LXPanel is a lightweight X11 desktop panel
5 Name:           lxpanel
6 Version:        0.8.1
7 Release:        5
8 License:        GPL v2
9 Group:          X11/Applications
10 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
11 # Source0-md5:  6ea8dea8dc6c781b7adfbccbcd59c512
12 URL:            http://wiki.lxde.org/en/LXPanel
13 BuildRequires:  autoconf
14 BuildRequires:  automake >= 1:1.12
15 BuildRequires:  alsa-lib-devel
16 BuildRequires:  gettext-tools
17 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
18 %{?with_gtk3:BuildRequires:     gtk+3-devel}
19 BuildRequires:  intltool
20 BuildRequires:  keybinder-devel
21 BuildRequires:  libfm-devel
22 BuildRequires:  libiw-devel
23 BuildRequires:  libwnck2-devel
24 BuildRequires:  libtool
25 BuildRequires:  menu-cache-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       lxmenu-data
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 LXPanel is a lightweight X11 desktop panel.
34
35 %package devel
36 Summary:        Header files for lxpanel library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxpanel
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for lxpanel library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki lxpanel.
46
47 %prep
48 %setup -q
49
50 %build
51 %{__aclocal}
52 %{__autoheader}
53 %{__libtoolize}
54 %{__intltoolize}
55 %{__automake}
56 %{__autoconf}
57 %configure \
58         %{?with_gtk3:--enable-gtk3}
59 %{__make} V=1
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/{frp,ur_PK,tt_RU}
67
68 %find_lang %{name}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files -f %{name}.lang
74 %defattr(644,root,root,755)
75 %doc AUTHORS README
76 %attr(755,root,root) %{_bindir}/lxpanel
77 %attr(755,root,root) %{_bindir}/lxpanelctl
78 %dir %{_libdir}/lxpanel
79 %attr(755,root,root) %{_libdir}/lxpanel/liblxpanel.so.*.*.*
80 %attr(755,root,root) %ghost /%{_libdir}/lxpanel/liblxpanel.so.0
81 %dir %{_libdir}/lxpanel/plugins
82 %attr(755,root,root) %{_libdir}/lxpanel/plugins/*.so
83 %{_mandir}/man1/lxpanel.1*
84 %{_mandir}/man1/lxpanelctl.1*
85
86 %dir %{_datadir}/lxpanel
87 ##%{_datadir}/lxpanel/profile
88 %{_datadir}/lxpanel/ui
89
90 %dir %{_datadir}/lxpanel/images
91 %{_datadir}/lxpanel/images/*.png
92
93 %dir %{_datadir}/lxpanel/images/xkb-flags
94 # TODO: lang tags here
95 %{_datadir}/lxpanel/images/xkb-flags/*.png
96
97 %dir %{_datadir}/lxpanel/xkeyboardconfig
98 %{_datadir}/lxpanel/xkeyboardconfig/*.cfg
99
100 %{_sysconfdir}/xdg/lxpanel
101
102 %files devel
103 %defattr(644,root,root,755)
104 %dir %{_includedir}/lxpanel
105 %{_includedir}/lxpanel/*.h
106 %{_pkgconfigdir}/lxpanel.pc
107 %attr(755,root,root) %{_libdir}/lxpanel/liblxpanel.so