]> TLD Linux GIT Repositories - packages/lxpanel.git/blob - lxpanel.spec
676b4a5334e4c4b1e165f52ebbd459d53392fa5a
[packages/lxpanel.git] / lxpanel.spec
1 # TODO:  /etc/xdg/lxpanel - proper tags/flags etc.
2 Summary:        LXPanel is a lightweight X11 desktop panel
3 Name:           lxpanel
4 Version:        0.8.1
5 Release:        3
6 License:        GPL v2
7 Group:          X11/Applications
8 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
9 # Source0-md5:  6ea8dea8dc6c781b7adfbccbcd59c512
10 URL:            http://wiki.lxde.org/en/LXPanel
11 BuildRequires:  autoconf
12 BuildRequires:  automake >= 1:1.12
13 BuildRequires:  alsa-lib-devel
14 BuildRequires:  gettext-tools
15 BuildRequires:  gtk+3-devel >= 3.0.0
16 BuildRequires:  intltool
17 BuildRequires:  keybinder-devel
18 BuildRequires:  libfm-devel
19 BuildRequires:  libiw-devel
20 BuildRequires:  libwnck2-devel
21 BuildRequires:  libtool
22 BuildRequires:  menu-cache-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       lxmenu-data
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 LXPanel is a lightweight X11 desktop panel.
31
32 %package devel
33 Summary:        Header files for lxpanel library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxpanel
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for lxpanel library.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe biblioteki lxpanel.
43
44 %prep
45 %setup -q
46
47 %build
48 %{__aclocal}
49 %{__autoheader}
50 %{__libtoolize}
51 %{__intltoolize}
52 %{__automake}
53 %{__autoconf}
54 %configure \
55         --enable-gtk3
56 %{__make} V=1
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/{frp,ur_PK,tt_RU}
64
65 %find_lang %{name}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files -f %{name}.lang
71 %defattr(644,root,root,755)
72 %doc AUTHORS README
73 %attr(755,root,root) %{_bindir}/lxpanel
74 %attr(755,root,root) %{_bindir}/lxpanelctl
75 %dir %{_libdir}/lxpanel
76 %attr(755,root,root) %{_libdir}/lxpanel/liblxpanel.so.*.*.*
77 %attr(755,root,root) %ghost /%{_libdir}/lxpanel/liblxpanel.so.0
78 %dir %{_libdir}/lxpanel/plugins
79 %attr(755,root,root) %{_libdir}/lxpanel/plugins/*.so
80 %{_mandir}/man1/lxpanel.1*
81 %{_mandir}/man1/lxpanelctl.1*
82
83 %dir %{_datadir}/lxpanel
84 ##%{_datadir}/lxpanel/profile
85 %{_datadir}/lxpanel/ui
86
87 %dir %{_datadir}/lxpanel/images
88 %{_datadir}/lxpanel/images/*.png
89
90 %dir %{_datadir}/lxpanel/images/xkb-flags
91 # TODO: lang tags here
92 %{_datadir}/lxpanel/images/xkb-flags/*.png
93
94 %dir %{_datadir}/lxpanel/xkeyboardconfig
95 %{_datadir}/lxpanel/xkeyboardconfig/*.cfg
96
97 %{_sysconfdir}/xdg/lxpanel
98
99 %files devel
100 %defattr(644,root,root,755)
101 %dir %{_includedir}/lxpanel
102 %{_includedir}/lxpanel/*.h
103 %{_pkgconfigdir}/lxpanel.pc
104 %attr(755,root,root) %{_libdir}/lxpanel/liblxpanel.so