]> TLD Linux GIT Repositories - packages/lxpolkit.git/blob - lxpolkit.spec
- from PLD
[packages/lxpolkit.git] / lxpolkit.spec
1 #
2 # Conditional build:
3 %bcond_with             gtk3            # build GTK+3 disables GTK+2
4 %bcond_without          gtk2    # build with GTK+2
5
6 %if %{with gtk3}
7 %undefine       with_gtk2
8 %endif
9
10 Summary:        LXPolkit is a simple PolicyKit authentication agent
11 Name:           lxpolkit
12 Version:        0.1.0
13 Release:        1
14 License:        GPL v3
15 Group:          X11/Applications
16 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.gz
17 # Source0-md5:  2597b00035fe1d695219e0f9bfa8c26f
18 # FIXME: check url, if site cames back online
19 URL:            http://wiki.lxde.org/en/LXPolkit
20 BuildRequires:  gettext-tools
21 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
22 %{?with_gtk3:BuildRequires:     gtk+3-devel}
23 BuildRequires:  intltool
24 BuildRequires:  pkgconfig
25 BuildRequires:  polkit-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 LXPolkit is a simple PolicyKit authentication agent.
30
31 %prep
32 %setup -q
33
34 %build
35 %configure \
36         %{?with_gtk3:--enable-gtk3}
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/tt_RU
45
46 %find_lang %{name}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files -f %{name}.lang
52 %defattr(644,root,root,755)
53 %doc AUTHORS README
54 /etc/xdg/autostart/lxpolkit.desktop
55 %attr(755,root,root) %{_libdir}/lxpolkit
56 %{_datadir}/lxpolkit