]> TLD Linux GIT Repositories - packages/lxrandr.git/blob - lxrandr.spec
- updated to 0.3.0
[packages/lxrandr.git] / lxrandr.spec
1 # Conditional build:
2 %bcond_with             gtk3    # build GTK+3 disables GTK+2
3 %bcond_without          gtk2    # build with GTK+2
4
5 %if %{with gtk3}
6 %undefine       with_gtk2
7 %endif
8
9 Summary:        GTK+2 interface to XRandR for LXDE desktop
10 Name:           lxrandr
11 Version:        0.3.0
12 Release:        1
13 License:        GPL v3
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
16 # Source0-md5:  250f0ebb09c1e02f430f951911ba1259
17 Patch0:         mate-desktop.patch
18 URL:            http://wiki.lxde.org/en/LXRandR
19 BuildRequires:  gettext-tools
20 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
21 %{?with_gtk3:BuildRequires:     gtk+3-devel}
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A GTK+ interface to XRandR for LXDE desktop.
27
28 %prep
29 %setup -q
30 %patch0 -p1
31
32 %build
33 %configure \
34         %{?with_gtk3:--enable-gtk3}
35 touch po/stamp-it
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{frp,ur_PK,tt_RU}
44
45 %find_lang %{name}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files -f %{name}.lang
51 %defattr(644,root,root,755)
52 %doc AUTHORS README
53 %attr(755,root,root) %{_bindir}/lxrandr
54 %{_desktopdir}/lxrandr.desktop
55 %{_mandir}/man1/lxrandr*