]> TLD Linux GIT Repositories - packages/lxrandr.git/blob - lxrandr.spec
b737730aa2f28798034786fe5bd99c65bbd49384
[packages/lxrandr.git] / lxrandr.spec
1 #
2 # Conditional build:
3 %bcond_with             gtk3            # build GTK+3 disables GTK+2
4 %bcond_without          gtk2    # build with GTK+2
5
6 %if %{with gtk3}
7 %undefine       with_gtk2
8 %endif
9
10 Summary:        a GTK+2 interface to XRandR for LXDE desktop
11 Name:           lxrandr
12 Version:        0.1.2
13 Release:        4
14 License:        GPL v3
15 Group:          X11/Applications
16 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.gz
17 # Source0-md5:  8a7391581541bba58839ac11dbf5b575
18 Patch0:         mate-desktop.patch
19 URL:            http://wiki.lxde.org/en/LXRandR
20 BuildRequires:  gettext-tools
21 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
22 %{?with_gtk3:BuildRequires:     gtk+3-devel}
23 BuildRequires:  pkgconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A GTK+ interface to XRandR for LXDE desktop.
28
29 %prep
30 %setup -q
31 %patch0 -p1
32
33 %build
34 %configure \
35         %{?with_gtk3:--enable-gtk3}
36 touch po/stamp-it
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{frp,ur_PK,tt_RU}
45
46 %find_lang %{name}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files -f %{name}.lang
52 %defattr(644,root,root,755)
53 %doc AUTHORS README
54 %attr(755,root,root) %{_bindir}/lxrandr
55 %{_desktopdir}/lxrandr.desktop
56 %{_mandir}/man1/lxrandr*