]> TLD Linux GIT Repositories - packages/lxsession.git/blob - lxsession.spec
- from PLD
[packages/lxsession.git] / lxsession.spec
1 #
2 # Conditional build:
3 %bcond_with             gtk3            # build GTK+3, disables GTK+2
4 %bcond_without          gtk2    # build with GTK+2
5
6 %if %{with gtk3}
7 %undefine       with_gtk2
8 %endif
9
10 Summary:        Default session manager for LXDE
11 Name:           lxsession
12 Version:        0.4.9.2
13 Release:        4
14 License:        GPL v2
15 Group:          X11/Applications
16 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.gz
17 # Source0-md5:  bc3eb71936dbdf813e9ac2f00ab948f0
18 URL:            http://wiki.lxde.org/en/LXSession
19 BuildRequires:  dbus-devel
20 BuildRequires:  dbus-glib-devel
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel
23 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
24 %{?with_gtk3:BuildRequires:     gtk+3-devel}
25 BuildRequires:  intltool
26 BuildRequires:  libgee0.6-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  polkit-devel
29 BuildRequires:  vala
30 BuildRequires:  xorg-lib-libX11-devel
31 Provides:       lxpolkit = 0.1.0-2
32 Provides:       lxsession-edit = 0.2.0-3
33 Obsoletes:      lxpolkit
34 Obsoletes:      lxsession-edit
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 LXSession is the default session manager of LXDE.
39
40 LXSession automatically starts a set of applications and sets up a
41 working desktop environment. Moreover, the session manager is able to
42 remember the applications in use when a user logs out and to restart
43 them the next time the user logs in.
44
45 %prep
46 %setup -q
47
48 %build
49 %configure \
50         %{?with_gtk3:--enable-gtk3}
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{frp,ur_PK,tt_RU}
59
60 %find_lang %{name}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files -f %{name}.lang
66 %defattr(644,root,root,755)
67 %doc AUTHORS README
68 %attr(755,root,root) %{_bindir}/lxclipboard
69 %attr(755,root,root) %{_bindir}/lxlock
70 %attr(755,root,root) %{_bindir}/lxpolkit
71 %attr(755,root,root) %{_bindir}/lxsession*
72 %{_datadir}/lxsession
73 %{_desktopdir}/lxsession*.desktop
74 %{_mandir}/man1/lxsession*