]> TLD Linux GIT Repositories - packages/lxshortcut.git/blob - lxshortcut.spec
f8425bb0d4444dd21106d4e22859cd18f7a36e48
[packages/lxshortcut.git] / lxshortcut.spec
1 #
2 # Conditional build:
3 %bcond_with             gtk3            # build GTK+3 disables GTK+2
4 %bcond_without          gtk2    # build with GTK+2
5
6 %if %{with gtk3}
7 %undefine       with_gtk2
8 %endif
9
10 Summary:        Program to edit application shortcuts
11 Name:           lxshortcut
12 Version:        0.1.2
13 Release:        4
14 License:        GPL v3
15 Group:          X11/Applications
16 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.gz
17 # Source0-md5:  72f0dfafa8098be853beae6e33b5e13b
18 URL:            http://wiki.lxde.org/en/LXShortCut
19 BuildRequires:  gettext-tools
20 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
21 %{?with_gtk3:BuildRequires:     gtk+3-devel}
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 LXShortcut is a small program used to edit application shortcuts
27 created with freedesktop.org Desktop Entry spec.
28
29 %prep
30 %setup -q
31
32 %build
33 %configure \
34         %{?with_gtk3:--enable-gtk3}
35 touch po/stamp-it
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 # duplicate of ur
44 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
45 # unsupported by glibc
46 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/frp
47
48 mv $RPM_BUILD_ROOT%{_datadir}/locale/tt{_RU,}
49
50 %find_lang %{name}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files -f %{name}.lang
56 %defattr(644,root,root,755)
57 %doc AUTHORS README
58 %attr(755,root,root) %{_bindir}/lxshortcut
59 %{_datadir}/lxshortcut