]> TLD Linux GIT Repositories - packages/lxshortcut.git/blob - lxshortcut.spec
- release 5
[packages/lxshortcut.git] / lxshortcut.spec
1 # Conditional build:
2 %bcond_with             gtk3    # build GTK+3 disables GTK+2
3 %bcond_without          gtk2    # build with GTK+2
4
5 %if %{with gtk3}
6 %undefine       with_gtk2
7 %endif
8
9 Summary:        Program to edit application shortcuts
10 Name:           lxshortcut
11 Version:        0.1.2
12 Release:        5
13 License:        GPL v3
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.gz
16 # Source0-md5:  72f0dfafa8098be853beae6e33b5e13b
17 URL:            http://wiki.lxde.org/en/LXShortCut
18 BuildRequires:  gettext-tools
19 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
20 %{?with_gtk3:BuildRequires:     gtk+3-devel}
21 BuildRequires:  pkgconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 LXShortcut is a small program used to edit application shortcuts
26 created with freedesktop.org Desktop Entry spec.
27
28 %prep
29 %setup -q
30
31 %build
32 %configure \
33         %{?with_gtk3:--enable-gtk3}
34 touch po/stamp-it
35 %{__make}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 %{__make} install \
40         DESTDIR=$RPM_BUILD_ROOT
41
42 # duplicate of ur
43 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
44 # unsupported by glibc
45 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/frp
46
47 mv $RPM_BUILD_ROOT%{_datadir}/locale/tt{_RU,}
48
49 %find_lang %{name}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files -f %{name}.lang
55 %defattr(644,root,root,755)
56 %doc AUTHORS README
57 %attr(755,root,root) %{_bindir}/lxshortcut
58 %{_datadir}/lxshortcut