]> TLD Linux GIT Repositories - packages/lxtask.git/blob - lxtask.spec
- updated to 0.1.8
[packages/lxtask.git] / lxtask.spec
1 # Conditional build:
2 %bcond_with             gtk3    # build GTK+3 disables GTK+2
3 %bcond_without          gtk2    # build with GTK+2
4
5 %if %{with gtk3}
6 %undefine       with_gtk2
7 %endif
8
9 Summary:        Lightweight task manager
10 Name:           lxtask
11 Version:        0.1.8
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.xz
16 # Source0-md5:  dd4f423dda192cb50618c6b1e76ec6b7
17 URL:            http://wiki.lxde.org/en/LXTask
18 BuildRequires:  gettext-tools
19 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.12.0}
20 %{?with_gtk3:BuildRequires:     gtk+3-devel}
21 BuildRequires:  intltool
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 LXTask - lightweight and desktop-independent task manager derived from
27 xfce4-taskmanager with all dependencies on xfce removed, new features,
28 and some improvement of the user interface.
29
30 %prep
31 %setup -q
32
33 %build
34 %configure \
35         %{?with_gtk3:--enable-gtk3}
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 # duplicate of ur
44 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
45 # unsupported by glibc
46 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/frp
47 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/tt_RU
48
49 %find_lang %{name}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files -f %{name}.lang
55 %defattr(644,root,root,755)
56 %doc AUTHORS README
57 %attr(755,root,root) %{_bindir}/lxtask
58 %{_desktopdir}/lxtask.desktop
59 %{_mandir}/man1/lxtask.1.*