]> TLD Linux GIT Repositories - packages/lxterminal.git/commitdiff
- updated to 0.2.0
authorMarcin Krol <hawk@tld-linux.org>
Tue, 21 Jul 2015 13:07:32 +0000 (13:07 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Tue, 21 Jul 2015 13:07:32 +0000 (13:07 +0000)
lxterminal.spec
wordseps.patch

index 2574cdd55560e68ea921be61372b514172077633..2e2b6c43c10f4372a8a7df93d7af0a4c1bbdeb89 100644 (file)
@@ -9,12 +9,12 @@
 
 Summary:       LXTerminal is the standard terminal emulator of LXDE
 Name:          lxterminal
-Version:       0.1.11
-Release:       6
+Version:       0.2.0
+Release:       1
 License:       GPL v2
 Group:         X11/Applications
 Source0:       http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.gz
-# Source0-md5: fd9140b45c0f28d021253c4aeb8c4aea
+# Source0-md5: e80ad1b6e26212f3d43908c2ad87ba4d
 Patch0:                wordseps.patch
 URL:           http://wiki.lxde.org/en/LXTerminal
 BuildRequires: autoconf
@@ -45,6 +45,7 @@ LXTerminal is the standard terminal emulator of LXDE.
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
+%{__automake}
 %{__intltoolize}
 %configure \
        --disable-silent-rules \
@@ -74,5 +75,5 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/%{name}
 %{_desktopdir}/%{name}.desktop
 %{_mandir}/man1/%{name}*
-%{_pixmapsdir}/%{name}.png
+%{_iconsdir}/hicolor/128x128/apps/%{name}.png
 %{_datadir}/%{name}
index ac880cd9304426a18fe49d69fb951e858035c378..2b4ba55fb688812806d659c16aa2d9c15f9deec1 100644 (file)
@@ -1,17 +1,11 @@
-similar patches:
-- konsole: http://git.pld-linux.org/?p=packages/kdebase.git;a=blob;f=kdebase-konsole-wordseps.patch
-- Terminal: http://git.pld-linux.org/?p=packages/Terminal.git;a=blob;f=wordseps.patch
-- Gnome-terminal: http://git.pld-linux.org/?p=packages/gnome-terminal.git;a=blob;f=wordseps.patch
-- mate-terminal: http://git.pld-linux.org/?p=packages/mate-terminal.git;a=blob;f=wordseps.patch
-
---- lxterminal-0.1.11/src/setting.c~   2012-04-21 22:50:34.000000000 +0300
-+++ lxterminal-0.1.11/src/setting.c    2012-04-21 22:50:36.003908733 +0300
-@@ -123,7 +123,7 @@
-     if (setting->tab_position == NULL)
-         setting->tab_position = g_strdup("top");
+--- lxterminal-0.2.0/src/setting.c     2015-07-21 12:54:57.452951514 +0000
++++ lxterminal-0.2.0/src/setting.c     2015-07-21 12:56:51.532951514 +0000
+@@ -307,7 +307,7 @@
+     }
      if (setting->word_selection_characters == NULL)
+     {
 -        setting->word_selection_characters = g_strdup("-A-Za-z0-9,./?%&#:_~");
 +        setting->word_selection_characters = g_strdup("-A-Za-z0-9,./?%&#:_~=+;@");
-     if (setting->background_alpha == NULL)
-         setting->background_alpha = 65535;
-     return setting;
+     }
+     
+     /* Default configuration for shortcut group settings. */